Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

No Taillights, Running Lights or Gauge Lights (K5 Blazer)


Recommended Posts

Hi all, I just picked up my first Blazer a few days ago and I've run into a few issues with it so far. It's a 1990 K5, 5.7 TBI V8, and I'm having an issue getting the taillights, running lights and gauge lights to work. I did some research and saw that people said to swap out the switch for the headlight knob, and to also check the tailgate area for open wires that might be crossing, broken etc. I swapped out the switch for the headlights today, didn't seem to fix the issue. Also checked the tailgate, everything seemed to be in order along with checking each of the fuses on the panel. They all checked out with a tool my buddy had that checks for the grounds and contacts. I'm brand new to a lot of the GM stuff coming from a Jeep, so I'm at a loss on what to do next. Any help would be greatly appreciated, trying to get this thing road worthy!
 
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.