Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Darmichar

Replacing 2.0 HMI module with 2.5 HMI module to add CarPlay/Android Auto to 2014-2015 Silverado

Recommended Posts

I don't know for sure, just going on what info I can find that seems to make sense. Are you sure the Wifi actually works in your 14 and not just shows the option on the screen? Maybe it was a late production model that go the 2015 module. 
 
Here's what I'm basing my thoughts on. 
 
This is a 2014 Onstar/Bluetooth module. 
image.png.7799745e48ae06f9efc16972f3ee1e28.png
 
and here is a 2015 Module 
image.png.8503e88216d448fd210a47b0c9f3459b.png
 
Ahh I see where the confusion is.

So, there's 2 different types of Wifi we're discussing.

The OnStar module has wifi because OnStar provides a service to allow your truck to be a mobile hotspot. You purchase data from them and can use it on the road.

It makes its own network.

The HMI contains a wifi receiver which allows you to connect to networks to download updates and such.

Does that make sense?

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites
7 hours ago, th3magpi3 said:

Ahh I see where the confusion is.

So, there's 2 different types of Wifi we're discussing.

The OnStar module has wifi because OnStar provides a service to allow your truck to be a mobile hotspot. You purchase data from them and can use it on the road.

It makes its own network.

The HMI contains a wifi receiver which allows you to connect to networks to download updates and such.

Does that make sense?

Sent from my Pixel XL using Tapatalk
 

Yep. Makes sense. I didn't know you could connect the HMI to wifi. I just figured it was getting all its data from the onstar module. Cool that it work like that. I don't care that much about having wifi from onstar since I can just use my phone as a hotspot. 

 

 

Edited by truckmann

Share this post


Link to post
Share on other sites
Yep. Makes sense. I didn't know you could connect to the HMI to wifi. I just figured it was getting all its data from the onstar module. Cool that it work like that. I don't care that much about having wifi from onstar since I can just use my phone as a hotspot. 
 
 
I think it's mainly used as a selling feature.

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites
Yep. Makes sense. I didn't know you could connect to the HMI to wifi. I just figured it was getting all its data from the onstar module. Cool that it work like that. I don't care that much about having wifi from onstar since I can just use my phone as a hotspot. 
 
 
I think it's mainly used as a selling feature.

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites

So I know this has been hit multiple times but I wanted to have someone confirm it for me. I have a 2015 z71 with navigation and Bose audio. It was bought in 2014. So based on what I have read I should need a new 2.5 HMI and a radio upgrade that are both programmed for my VIN and an upgrade to my USB connectors? I don’t care about the navigation so I plan on saving money there if I can. 

 

Also so thanks for all the hard work you have all been doing on his. It is impressive and makes me want to try and help in any way I can. 

Share this post


Link to post
Share on other sites

Just got my 2.5 HMI and Radio back from Chis White Auto - installed everything along with the USB plug and now I'm getting this error. :rolleyes:

 

Anyone have any ideas? This is on a 2015 GMC Sierra SLT.

WhatsApp Image 2018-09-13 at 5.56.29 PM (1).jpeg

Share this post


Link to post
Share on other sites
Just now, dubwise said:

Just got my 2.5 HMI and Radio back from Chis White Auto - installed everything along with the USB plug and now I'm getting this error. :rolleyes:

 

Anyone have any ideas? This is on a 2015 GMC Sierra SLT.

WhatsApp Image 2018-09-13 at 5.56.29 PM (1).jpeg

Yep. Your date and time is different. Probably set to sometime in january and like 2013?

 

Set it to the proper date and time, toggle the key in the on and off position 5-7 times, start the vehicle, turn it off, restart your phone, turn the truck back on and connect them back up. 

 

If that doesnt work I usually just go for a drive without the phone plugged in and do another restart. 

Share this post


Link to post
Share on other sites
8 minutes ago, th3magpi3 said:

Yep. Your date and time is different. Probably set to sometime in january and like 2013?

 

Set it to the proper date and time, toggle the key in the on and off position 5-7 times, start the vehicle, turn it off, restart your phone, turn the truck back on and connect them back up. 

 

If that doesnt work I usually just go for a drive without the phone plugged in and do another restart. 

This ^^^

 

My module acted the same way.  I fixed it by:

 

1.  Updating date/time on the radio

2.  Uninstalling AA on my Galaxy S8

3.  Reinstalling AA fresh on the S8

4.  Connecting in the truck

 

I've heard that cabling can also cause this, you may need to get a newer USB cable.

 

Good luck!

Rick

Share this post


Link to post
Share on other sites

I managed to fix this after tinkering around with it for more than 5 mins. I verified date/time and everything was correct. I ended up factory resetting the radio under the settings and that did the trick! I thought for sure that would have been done when the unit was programmed, but apparently not.

 

Anyway I'm up and going now. Thanks for the suggestions guys.

 

Hope this helps someone in the future.

Share this post


Link to post
Share on other sites

I just got my setup back from Chris at WAMS. He did an outstanding job and fast turn around. I purchased a used 2.5 HMI and 2016 radio module as well as the new USB port for the center console from eBay. Sent the radio and hmi to WAMS and he programmed them and sent them back. Took 20 minutes to swap everything out. Works great! He even put the latest software on it. Worth every penny! I had NAV so I got the hmi with NAV. System is so much faster and my CarPlay is back. I also get HD radio now since the 2016 radio modules have that.

Share this post


Link to post
Share on other sites
18 minutes ago, Ben Bassinger said:

I just got my setup back from Chris at WAMS. He did an outstanding job and fast turn around. I purchased a used 2.5 HMI and 2016 radio module as well as the new USB port for the center console from eBay. Sent the radio and hmi to WAMS and he programmed them and sent them back. Took 20 minutes to swap everything out. Works great! He even put the latest software on it. Worth every penny! I had NAV so I got the hmi with NAV. System is so much faster and my CarPlay is back. I also get HD radio now since the 2016 radio modules have that.
 

Mind if I ask what he charges to do this? I have a 2.5 HMI (non nav) and the usb port now and looking for a deal on the radio module. Just wondering what programming is going to cost me. 

 

 

Share this post


Link to post
Share on other sites

Just a thought, but since we are all going through the trouble of updating, would it be possible to update to a 2019 HMI? I think they have a few new features. 

Share this post


Link to post
Share on other sites

I’ve had several people ask so here are the parts I got.

HMI: 84028492
Radio Module: 23402903
USB port: 13509942

There are many options that work, but this is what I have.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.