Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
i82much

6.0 hesitation

Recommended Posts

I have a 2016 6.0 2500HD.  It seems to hesitate, kind of like a lean miss, at around 1/3 throttle, particularly going uphill and staying in a lower gear.  It isn't terrible.  Truck is still well within the warranty, but I was curious if anyone else has experienced this just so I can have some ideas going into the dealer for warranty service.  I've heard the 6L90 can do some weird things that feel like an engine miss, so perhaps this is not really an engine issue.  

Share this post


Link to post
Share on other sites
I have a 2016 6.0 2500HD.  It seems to hesitate, kind of like a lean miss, at around 1/3 throttle, particularly going uphill and staying in a lower gear.  It isn't terrible.  Truck is still well within the warranty, but I was curious if anyone else has experienced this just so I can have some ideas going into the dealer for warranty service.  I've heard the 6L90 can do some weird things that feel like an engine miss, so perhaps this is not really an engine issue.  
I've been having the same problem, especially when I have the ac on.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites
35 minutes ago, 16Lucho said:

I've been having the same problem, especially when I have the ac on.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

I almost never have my ac off!  cools me in the summer, dries the air in winter.  i was going windows down for awhile there but a damned yellow jacket flew in the window and stung me in the head, so back to the ac!

Share this post


Link to post
Share on other sites

I get a pulsating/surging feeling going uphill at 1/4 to 1/3 throttle. I attribute this to the transmission. Step on the gas, let it shift down and no more surging, just a smooth pull. The 6L90 does funnny things sometimes. 

Share this post


Link to post
Share on other sites
I get a pulsating/surging feeling going uphill at 1/4 to 1/3 throttle. I attribute this to the transmission. Step on the gas, let it shift down and no more surging, just a smooth pull. The 6L90 does funnny things sometimes. 
That's works when I'm not pulling, but when I pull my machinery it doesn't downshift until a 2-3 second delay. Pretty dangerous trying to get Into traffic and my truck doesn't get up and go.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites

My '16 does the same thing when running empty.  Usually between 2 and 3000 rpm  going uphill or under slight load and maybe 4th gear and 40 to 50mph.  If I run the same conditions with a 8000 lb 32' travel trailer behind the truck it runs smooth. 

Share this post


Link to post
Share on other sites

I did some reading, I think it is the TCC.  When I first bought the truck, I did a few controlled panic stops to see how it handled and the engine stalled once.  Apparently that is a TCC symptom.  We will see what the dealer says.  

Share this post


Link to post
Share on other sites
16 hours ago, i82much said:

I did some reading, I think it is the TCC.  When I first bought the truck, I did a few controlled panic stops to see how it handled and the engine stalled once.  Apparently that is a TCC symptom.  We will see what the dealer says.  

I think others were having the same problem in an older thread and the consensus was that the torque converter would like to stay locked too long, causing the pulsating. People who had their trucks tuned said the problem went away. Keep us posted, hopefully GM has updated the software to eliminate this.

Share this post


Link to post
Share on other sites

Yeah, my '15 6.0 did this... Tune will clean it up. It doesn't do it all the time now. 

Share this post


Link to post
Share on other sites
On 9/5/2018 at 11:09 AM, 16Lucho said:

That's works when I'm not pulling, but when I pull my machinery it doesn't downshift until a 2-3 second delay. Pretty dangerous trying to get Into traffic and my truck doesn't get up and go.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

Are you using Tow - Haul button??? Makes a HUGE difference

Share this post


Link to post
Share on other sites
Are you using Tow - Haul button??? Makes a HUGE difference
Yes, always when I'm pulling my machinary around. Ever since it hasn't been hot out, the truck hasn't done the hesitation.

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.