Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
Brendan Corr

4l80 issues, heat and no lockup.

Recommended Posts

Hello all, i have a 2002 2500hd 6.0/4l80 combo. The truck is blackbear tuned and has been for nearly 10,000 miles. I recently converted the truck to 4x4 with the drive train out from under a 2007 classic. The transmission was a GM reman with little to no miles on it. I dropped the pan, changed the filter and filter o-ring. Then filled with some dex6. The other day i was driving up a fairly steep grad (i-70W), truck was preforming normally trans at around 190-200F when all of a sudden it started shifting crazy hard and getting warm. I scanned it and pulled the dreaded P1870 transmission component slipping No CEL or any other codes. The trans will shift fine when cool until about 175, then it goes back into like a protect mode and will heat over 200F in a couple miles (still have all gears and shifts during this, just very very hard shifts and no lockup.). I have all gear shifts except lockup even when cool. The fluid is still bright pink and has less than 3000 miles on it with no burned smell. My current plans are to pull the trans, change converter and the trans cooling lines as i'm sure the rubber flex joints have collapsed as well as flush both the aux cooler and cooler built into the radiator. Is there anything else i should be doing, or anyone with a similar problem that they've resolved? Any input will be greatly appreciated.

-Brendan Corr

Share this post


Link to post
Share on other sites

(I posted this in your other thread, but copying/ paste here for visibility)

 

It was common in the early 2000s 4l80 trucks for the converter clutch piston to crack and cause a loss of lockup and P1870 code. However, I've seen the issue persist into at least the '06 model year (last one I rebuilt was in a 2006), so I don't think it was ever rectified. It sounds like you are experiencing the same issue. The way I diagnosed it was using a bi-directional scan tool to command TCC lockup and only obtaining about a 25-50 rpm drop (instead of the normal 2-300). The hard shifting is when it goes into limp mode due to what it detects as trans slippage (P1870). This happens after so many minutes of driving, or drive cycles, independent of most any other factors. The reason why it's running hot is simply a byproduct of the TCC staying unlocked.

Share this post


Link to post
Share on other sites
3 minutes ago, carkhz316 said:

(I posted this in your other thread, but copying/ paste here for visibility)

 

It was common in the early 2000s 4l80 trucks for the converter clutch piston to crack and cause a loss of lockup and P1870 code. However, I've seen the issue persist into at least the '06 model year (last one I rebuilt was in a 2006), so I don't think it was ever rectified. It sounds like you are experiencing the same issue. The way I diagnosed it was using a bi-directional scan tool to command TCC lockup and only obtaining about a 25-50 rpm drop (instead of the normal 2-300). The hard shifting is when it goes into limp mode due to what it detects as trans slippage (P1870). This happens after so many minutes of driving, or drive cycles, independent of most any other factors. The reason why it's running hot is simply a byproduct of the TCC staying unlocked.

Thank you, this is what i have been suspecting due to the other gears all applying quickly and firmly like normal before it goes into limp.

Share this post


Link to post
Share on other sites

I would upgrade that transmission cooler. Easy to do and you can fit one twice the size up front. Tranny temps should not go above 160 when empty. Automatics begin to wear parts when trans temps are over 200.

Share this post


Link to post
Share on other sites
3 minutes ago, Formulabruce said:

I would upgrade that transmission cooler. Easy to do and you can fit one twice the size up front. Tranny temps should not go above 160 when empty. Automatics begin to wear parts when trans temps are over 200.

those temps were while climbing a 6% grade for miles. When im down in Texas for the summers, it wont get up there unless towing a semi heavy trailer.

Share this post


Link to post
Share on other sites

I ended up changing lines, flushing Rad cooler (seems quite restrictive) and replacing the aux cooler with one double the size. I got lockup back slowly but weak. The trans still heats quickly, but slower if i can keep it in lockup. i have a reman converter for it and plan to install it next weekend, Does it still sound like the converter. 

Share this post


Link to post
Share on other sites

Yes, it still sounds like that, but can't say with absolute certainty without diagnosis.

Share this post


Link to post
Share on other sites

I ended up bypassing the factory cooler in the radiator all together because I couldn’t get over how hard it was to blow shop air through. Immediately the transmission acted normal but lockup was weak you could watch it slip on the tach. My dad and I ended up dropping the transmission and changing the torque converter. While we were in there we replaced the rear main seal, oil pan gasket, transfer case output seal, and the gasket between the transmission and transmission. The difference is night and day, the truck locks up and stays locked up even in gentle grades where it wouldn’t before (I don’t think this TC was ever good, it came on the transmission from the parts truck) all while keeping in mind, my 22x12’s and 33’s weigh almost 100lbs a tire. Thanks for everyone’s help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By 2018GMC
      4l60e won’t shift into 4th OD with new aluminum pan 1997 k1500 5.7 4x4.
       
      Trans was working fine with original steel pan. It is original to truck with 209k currently. I have done the oversized TCC valve 20k ago due to p1870. 
       
      I just installed a new aluminum 2 7/8 deep pan. Now trans won’t shift into OD and eventually lights SES with p1870. 
       
      Checked fluid hot in park idleing and it’s at the correct mark. 
       
      4l60e is the older one case design with bell housing molded into case. 
       
      See below pics of Dents Dimple in steel pan.
       
      Valve body adjustment?
       
      solenoid adjustment? 
       
      Or need new valve body?
    • By shaneman20
      Well, seeing as how I can't find much on this subject no matter what forum I go to, why not try to start the discussion here and see what kind of following I can get and see where we end up.

      If you're reading this thread, chances are you have thought about modifying or swapping out your current transmission in your 2014+ GM truck. In my case, I don't mind my 6L80 in my truck. It does fine for what I do right now and it's holding up just fine, but I think the big issue is when you start to search for big power (like I'm starting to do), that 6L80 is not going to hold very much (or so we think). Now, let's all face it. We've seen posts after posts, comments after comments, photos, videos, etc. of guys with built motors with turbos or prochargers shooting down the quarter mile in search for the best time on these 6L80s. Some say they're completely stock, others have them built, and we all ask ourselves the same question: Reliability. How well are these transmissions going to hold up to the abuse on the track? Especially if you want to make it a fast street/strip truck and drive it back home to the garage afterwords.

      We know for a fact that 6L90s can hold quite a bit of power. Even though I've mostly seen it in Camaro ZL1 applications, there is a guy on YouTube (GuitarmaggedonZL1) who is running a stock 6L90 on stock converter making 1000HP (give or take on an unloaded dyno) and the transmission hasn't puked all over the ground just yet. (Exaggeration, I know.) So, needless to say, a 6L90 swap sounds nice, at first... After you figure the extra length and weight (and in my case, relocation of the transfer case and getting custom driveshafts made), it starts to look a bit unpromising, but still not out of the ball park yet since it will be able to handle the power some are seeking, but where these newer transmissions lack significantly if you want to do boosted applications at the track (or even just launch control on N/A), no one has developed a transbrake. Very, very few forums are talking about this, and only one video exists of a guy in his BMW testing out a transbrake on a 6L80/6L90, and who knows how reliable it is.

      So, now, you start to think: Well, gee. What can I do now? How about a TH400 or 4L80e swap?

      So far, I've seen few posts on that as well. No one is talking about it, and I think the biggest problem people seem to be facing is the new PCM: E92. Also possibly the fact that the TCM on the newer transmissions is inside the transmission and whatnot, but whether that plays a part in this, I don't know yet. Now, adapting a TH400 or 4L80e can be done (most likely with a different bellhousing since the bolt holes are in a slightly different spot), but you run into the issue of getting it to speak/cooperate/communicate with the new E92, which I don't think anyone has tried. The only video I've seen of anything working in this application was on a 1320Videos video with a Nova where they were using an LT4 long block (built motor to 388 C.I.) and twin turbos, and it had a powerglide in it. Don't know if it was a manual valve body or computer-controlled, but what I do know is that they used the factory computer to run the DI injection system and piggybacked the rest to an MS3 Pro. After dealing with some issues, they were able to make that thing boogy to a 9 second pass at 148mph. So, these engines have potential to haul ass, but we just haven't figured out how to crack the system.

      So, at this point, I'll just leave what I've discussed here and see where the thread goes from here, and I'm hoping people chime in and vendors are watching/listening. Even though the demand isn't hot for it right now, there's going to be a surge for good transmissions when people can buy these trucks/cars/motors/transmissions for pennies on the dollar. Unfortunately, I feel like we'll have to wait that long in order to see results, but oh well.

      Just to give you guys an example: In the next year or two (2019 or 2020), I'd like to go turbo with my truck. (Doing all the supporting mods before going there minus built bottom end until I see where I can get with stock bottom end before sending a rod through the block or oil pan) Ideally, it'd be best to have a transbrake in that application with 2-step, but can't do it on the new transmissions. So, 4L80 seems to be the option, but I can't do that either because no one supports adapters or harnesses to make them work with the new motors/ECUs. That's the boat I'm in. I like to research everything before I go whole hog into something. Risk assessment, I guess.
    • By Travis1027
      Just recently I had my 4L60e go out on my truck (2000 silverado 1500). I've been too hesitant to go to a trans shop as I hear terrible stories and huge bills.
      While debating my options I came across a diesel shop owner who said his friend had a 'built' 4L80 with a standalone system out of a 4wd like mine.
      He wants $1000, I need help deciding if this is a good route that requires little fab.
       
      Would this bolt right into my 5.3 and transfercase?
      Is the length any different where I have to worry about the driveshaft?
      Do I have to flash my ecu?
       
      Any help is much appreciated!
    • By Jaroas
      I have a 2001 silverado, CEL came on, then at the next red light the tranny slipped out of gear and would not go into any gear. Let it set @ 15 minutes, restarted and worked fine or a few minutes then started slipping again. At stop sign could feel a pulsing in the transmission. Set code P1870. Any help will be greatly appreciated!
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    212,925
    Total Topics
    2,283,043
    Total Posts
  • Member Statistics

    187,906
    Total Members
    8,960
    Most Online
    Brandon Yates
    Newest Member
    Brandon Yates
    Joined
  • Who's Online   65 Members, 1 Anonymous, 1,484 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.