Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Same issue with our '19 Z71 Silverado. 24k miles. 

Already had it back to the dealer twice for the braking system issue, Seat belt bolt issue right after buying it. 

Really, really discouraged on a $50K truck having these issues and would love to just offload it and get something else at this point. 

The whole reason we got it was to finally enjoy some years of stress free and trouble-free being able to drive wherever, whenever and not worry about breaking down. 

Just getting started here on the forum, so hope to learn some new things/common issues and fixes about these newer body style trucks now. 

 

Link to post
Share on other sites
  • Replies 169
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

My husband is the Service Manager at a Chevy Dealership and was unaware of this issue until it happened yesterday (Dec. 28th) twice while en route with travel trailer and children on our 2019 Chevy Si

This happened to me this weekend but also had a Brake System Failure message and the brakes barely worked. Thankfully I was sitting in a Starbuck's drive thru before heading on a 3 hour road trip so I

Do everyone a favor and go to NHTSA and report it as a safety issue. Once they get a bunch of complaints that is how recalls get started. Sent from my Pixel 2 using Tapatalk

Posted Images

same thing here!!

 

Went to go out with the family yesterday and get the Service ESC and Reduced Engine power lights on in the dash. Went out this morning to get the mileage for the dealer and no lights on at all. 

 

So embarrassing that you pay this much for a truck and have to deal with this 2nd time in a month. 

 

 

Link to post
Share on other sites

I have a 2019 Sierra 1500 Ultimate. 70,000 km. 

I can confirm I had the N192268090  done Dec 2019, and N192268091 done in Jan 2020. 
Yet last week I got the same ESC service / engine light / etc warnings on the dash, and it drives different. 

At dealership for the day. They are keeping over night. They think it could be mechanical? 
I assume Canadian Dealers have the same resources. 

I'm glad I have extended warranty, but still concerning since it is a safety issue, I haven't driven much in the past several months. Brakes and Steering going, no wonder fiance is scared to drive. 

Link to post
Share on other sites

Same issue as above, same outcome. My wife called the Dealer, who initially told her she would have to pay for the tow and a diagnostic fee, then parts and labor to repair. 

She called me. 

In the meantime I found this forum and sent her the link to this thread, showing now 11 pages of similar issues that Chevy apparently has no knowledge of and has never heard of before. 

Told her to go back out, see if the messages were still there. 

And they weren't. 

SO yeah, thumbs up to the forum people here who gave me the idea to re-check before getting it towed (which was covered under our warranty anyway) and looking like a fool with no codes/messages showing up once it got there. 

I drove it last night, no issues, no indication anything was wonky. 

Very curious.

Edited by Broadicustomworks
Link to post
Share on other sites

My 2020 GMC Sierra Elevation Model was acting up Last night got into truck and was driving off and realized I could not turn steering wheel at all the error code Service ESC was on screen I was in middle of street stuck.   So I put back in reverse to back up closer to home and was finally able to get it close to my curb by pulling the steering wheel hard enough to turn the wheels a bit . I shut it off and on couple times but nothing.    An hour later I tried again started and steering wheel worked properly.  This is dangerous too many sensors be acting up and can cause serious injury .  I still have service tire sensors on since the day I bought the truck been to dealer few times and still not fixed.    Also my remote only works from 20-30 ft Max sometimes I’m in the truck and can’t start it because it don’t sense the remote.   It’s bad.   Yes the remotes have new batteries but no difference.   I’m located in Orange County, California . 

Link to post
Share on other sites
  • 3 weeks later...

I’m on a trip, 5 hours from home and this just happened to me in my 2020 AT4, 30k miles. Never had a problem before, the truck has been perfect to this point.  Service Power Steering and Service ESC.  Driving with no electric steer is both difficult and dangerous.  But I waited 20 minutes like those said earlier in the thread and sure enough, it worked perfectly again.  Strangest damn thing I have ever experienced with a vehicle and upsetting as hell.  

Link to post
Share on other sites

Mine just did this, but now it also will not start...

 

Currently on my 2nd head unit after audio would randomly turn off, brought into dealer 3 times for same issue. Overall I have been happy with the truck, but these little issues are starting to p*ss me off.

Link to post
Share on other sites
  • 5 weeks later...
Posted (edited)

I have a 2021 AT4 with 9k miles.  About a mile from home the truck started bucking. RPMs were jumping up and down from 1k-3k and a loud clicking from the front passenger side of the truck.  This all started at 65mph and I had to slow down to 30 to make it home. No warning lights at the time.     This morning when I started it RPM's are very low and I still have the loud clicking.  I also have "service ESC", "service parking brake" and "service electronic power steering assist".  I also have a small amount of fluid on the garage floor(half dollar size from transmission or transfer case area).  Love the truck but getting frustrated with the flakey technology in this truck.  

 

Update:  Dealer just informed me it's an engine rebuild.  They have to replace the Lifters and possibly the Cam.  Very depressing to spend all the $$$ on a new truck and in the first few months have to have an engine rebuild.   65K for a truck with a rebuilt engine...

Edited by Dean AT4
Update
Link to post
Share on other sites
  • 3 weeks later...

I just got the service power steering drive with care prompt on my 2018 today and completely lost power steering while doing 75 on I 85( talk about a wow moment). Called a friend he cleared the ECM, it drove fine for about 40 miles and then I got the same message and lost steering again. Can anyone share what this could possibly be caused by?

Link to post
Share on other sites

I just got this too when I started my truck. I turned the truck off and back on and what do you know the message just went away. Is this safe to drive? Does GM have a fix yet? My truck is a 2020 Trail Boss LT 6.2L crew cab short box. 

71B27909-7AB9-498E-B81F-A7E0D7B2A877.jpeg

9DAD1FAB-56DC-41CB-A3C8-FA0C2834450B.jpeg

Edited by EricTheRed
Link to post
Share on other sites

It would not surprise me if the NHTSA were heavily subsidized by General Motors.  
 

The NHTSA simply buries major safety issues related to GM vehicles.  It’s been this way for decades.  

Edited by 1997SierraSLT
Link to post
Share on other sites

I just had the same thing happen to me today with my 2019 Trail Boss.  "Service ESC" and "Service Power Steering, Drive with Care".  My steering wheel was completely stiff - no power assist at all.  I called the dealer.  They had me turn off the truck, pull the key, open and close the door and then sit there for about five minutes.  After that, everything worked fine.  They want me to bring the truck in for a diagnostic.  

Link to post
Share on other sites
  • 1 month later...

2021 Silverado Custom.  With the family turning at a stop sign.  Power steering, service trailer brake, service esc and the truck shuddered with extreme difficulty to accelerate.  Last time it happened I brought to a nearby dealer and they reset some controls which appeared to fix.  This is extremely frustrating for a brand new truck.  

Link to post
Share on other sites

Ya that sucks, and by the looks of it GM isn’t doing anything about these issues… customer service is dead.

Link to post
Share on other sites

Wife is freaked out and I have 2 little ones.  Not a good situation.  Calling sales folks and dealer I bought from. I can't be driving around like this.  I dropped my decades long allegiance to Ford for this truck.  Looking foolish right now.  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.