Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By 2002 Chevy Avalanche
      My 2002 chevy Avalanche 1500 Z71 5.3l has 37s mud tires on it, 20 inch rim's, and the abs light turns on and turns right back off on the high way, and then stays off, i heard it not very good for off roading either, which is something i enjoy doing, i read, and some people really hate ABS as it turns out. And they said to just pull the fuse, after i pulled the fuse, i expected the abs light to turn on, but when i looked both the ABS and Brake light were on, any ideas how i can turn that brake light off? The truck still stops good, and there are no problems, just a stupid brake light.
    • By truck_newbie
      I'm finding the brake pedal very noisy. I don't have any braking issues. Every time i press the pedal especially with the radio off, i can hear a loud whoosh and the switch clicking. If this is normal, then it's definitely the loudest brake pedal I have ever experienced. I'm trying to get a consensus if it's normal so i don't waste my time taking it to the dealer. I tried to capture the sound but it doesn't record very well. Full disclaimer that i'm a little more sensitive to noises than most. 
       
      Any one else experience this or is it normal?
      brake_pedal.mp3
    • By jkrosky
      I have a 2017 Chevy Silverado 3500 HD High Country with 6.6 diesel equipped with tow package.  It has dedicated trailer brake and trailer fuses within the primary fuse box under the hood.  My passenger side trailer blinkers and brake lights are not working.  I've traced the lack of 12v power all the way up to the 10a fuse dedicated to the right side trailer brake/signal light (fuse #17).  I have replaced the fuse, re-tested, and still no power.  The left side trailer brake/signal light (fuse #14) has 12v power going to it, tested on the top of the fuse when the flashers are on, but the right side has nothing.  I've also swapped and then replaced the trailer parking lights relay switch (relay #63) and still nothing.  Is this most likely an issue with fuse box or something else supplying power or ground to the fuse box?  Thanks for the help... this is the craziest thing.
    • By dwchapmanjr
      2015 GMC Yukon Denali - 32k miles (6.2L + 8spd).  I don't normally do highway speed but noticed yesterday that I had a slight pedal vibration when doing so and it only seems to happen at 60+ mph.  My daily drive is under 40mph and no vibrations there.  I'm assuming its likely a rear rotor since I don't feel it in the steering wheel.
       
      I looked back on my records and it appears front brakes were at 7mm a year ago and rear at 4mm.  Both in the "green" according to dealer.  I'm not sure if its an eyeball check and they just mark good or if they actually measure but it was 10k miles ago and a year so I likely need new pads.
       

       
      All this to say, with this life and mileage is anyone seeing pad life and possibly rotor life exhausted so quickly?  This is a heavy vehicle and the 6.2L gets it up to speed quickly and it does seem to take a lot more to stop it(always this way so I don't think its the vacuum recall).
       
      If anyone is getting a 4 wheel brake job at the dealer, what has it run you?  Mine is running a special for $139 per axle for pads and $189 per axle for rotors but I'm hoping if it is a warped rotor I only need 1 pair.
       
      Also noticed this on the front passenger rotor.  Is that defined of a groove normal?  To the touch it doesn't feel grooved.
       

       
      Tire inflation is normal.
    • By CraCra
      2006 GMC Savana 4.8 L 2500.
      Failed braking system, power steering pump. My Power steering pump went out along with braking. originally diagnosed as a combo hydroboost/power steer problem, so a new hydro boost was installed. Also replaced master cylinder and replaced 4 power steering pumps, the last one was an AC Delco which has lasted the longest, 3 days. One of the problems has been pedal kickback which is still going on. Was thinking it was the wheel sensors so I disconnected the ABS but still have a slight problem with pedal kickback not as bad as it was before, but still have it.
      Any ideas?
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    211,964
    Total Topics
    2,272,838
    Total Posts
  • Member Statistics

    185,497
    Total Members
    8,960
    Most Online
    Silverblack
    Newest Member
    Silverblack
    Joined
  • Who's Online   65 Members, 1 Anonymous, 1,161 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.