Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
TxDoc

Low beam headlight fuse keeps blowing

Recommended Posts

2005 Chevy Silverado. Painless wiring, 4 headlight kit. Two other trucks with this kit, never a problem.

 

 Few days ago, left low beam hesitated to come on. Like a poor connection that vibration cured.  Then the light didn't come on.

 

 It was a new bulb in place, but I tried a new one and nothing. Checked the fuse. It was blown. With the light removed, new fuses blew with light switch engaged.

I had a stroke last year, so it's hard to manipulate wires one handed.

 

Wanted to see if anyone with this setup had experienced this.  I wondered if my relay might have failed and of that would cause a short and blow the fuses, but it's only one light and not both though.

 

 Thanks for any replies and help.

 

 

Share this post


Link to post
Share on other sites

check the connecter at the light in question

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.