Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Dang! I just bought a 2020 Silverado LT LTZ (LAST WEEK) and the day after I bought it the info-tainment system was black screen when i started the truck.  I noticed that the OnStart light is Red.   Drove home in silence.   Next day, display worked just fine.  OnStar light is green.  I found out that the reason OnStar light goes Red is that it cannot communicate with the head unit.   At first i thought it had something to do with ApplePlay or USB.  However,  this even happens when i don't have anything plugged in, and leave my phone at home.   You know right away that its going to happen when you open the door to the truck, as you don't see the bow-tie logo animation.    Took it to the dealership and they seemed to know nothing about it, and couldn't find any recalls, etc.      They scheduled me to get a replacement head unit, but its on back-order and can't give me a date.   Given that I only have like 500 miles on it, and have only had it a week... i am thinking of going back and  asking for my $$ back.    Especially given the long history of this thread.    The only thing that gives me hope is that last post where he had the "poor connection at the high speed LAN terminal".

Link to post
Share on other sites
  • Replies 155
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Fixed???  (Maybe)   So, after multiple times in and out of the shop.... they did a global reset on the system, they replaced the USB port, etc.    This last time they replaced the "serial da

Had anyone found a fix to this? My 2019 Silverado just started this.

Greetings everyone.   I have a 2019 GMC with the intellink system and have experienced issues like some of you have been going though.  Being the curious type and love working with programming an

Posted Images

On 10/3/2020 at 7:09 PM, panchohughes said:

Dang! I just bought a 2020 Silverado LT LTZ (LAST WEEK) and the day after I bought it the info-tainment system was black screen when i started the truck.  I noticed that the OnStart light is Red.   Drove home in silence.   Next day, display worked just fine.  OnStar light is green.  I found out that the reason OnStar light goes Red is that it cannot communicate with the head unit.   At first i thought it had something to do with ApplePlay or USB.  However,  this even happens when i don't have anything plugged in, and leave my phone at home.   You know right away that its going to happen when you open the door to the truck, as you don't see the bow-tie logo animation.    Took it to the dealership and they seemed to know nothing about it, and couldn't find any recalls, etc.      They scheduled me to get a replacement head unit, but its on back-order and can't give me a date.   Given that I only have like 500 miles on it, and have only had it a week... i am thinking of going back and  asking for my $$ back.    Especially given the long history of this thread.    The only thing that gives me hope is that last post where he had the "poor connection at the high speed LAN terminal".

IF you can I would. 

 

Link to post
Share on other sites

Just had the same issue today for the first time.

 

2020 LTZ 1500 with 7500 miles,

 

Started the truck and the radio came on but the screen was black, tried restarting the truck and the screen remained black and the radio stopped working.  Drove for about 15 minutes and both came back on.

 

 

Link to post
Share on other sites
  • 3 weeks later...
1 minute ago, Walter Sanborn said:

2020 chevy silverado 1250 miles on my truck . today i had my touch screen go black, call the dealership they said to touch the positive and negitive cables together and wait ten seconds. it came back on onstar would not work either

 

?????

Did the magic smoke fix the issue?  But really, what +/- wires were they talking about?? 

Link to post
Share on other sites

2019 Sliverado 79,300 miles.  Radio screen sometimes doesn't come on, maybe once a week.  Today it went dark and would not come on.  When I opened the drivers door and turned off truck the screen appeared for a second or two then faded to dark.  Dealer (service) said it might be sleeping.  Turn truck off for 15-20 minutes.  Working now but no confidence.  Backup camera continued to work. 

Link to post
Share on other sites

Been dealing with this issue since week two of owning the truck.  2020 GMC AT4, 6.2.  Nice truck but I am getting frustrated with it.  

Apparently there is now a class action suit arising out of the middle district of Florida.  May be worthwhile keeping an eye on this one.  

Truck has been with dealer for 2 days.  I picked it up tonight...they told me a video module in back of the rear seat needs replacement and they've ordered it.  But who knows when it will be in.  In the meantime, rebooting and freezing up is the order of the day.  This video module is what another member on page 9 makes reference to.  According to his dealer, his got wet due to the broken or cracked window frame.  (I called the dealer as he suggested).  My dealer told me that this module handles a whole lot of wonderful things that can go wrong.  

Edited by CProfi
Link to post
Share on other sites

My infotainment system is malfunctioning in a different manner. First time, the backup cam would not turn off. Message said take to dealer. Dealer said can’t do anything til they see it happen. This week, 250 miles from home, the screen split in 3 section. The left section shifted to center screen, the remaining screen split in half to either side of that. At the bottom third of the screen I have code.

I also took a video. Dealer still said they can’t do anything til they see it. Thanks be, Ohio’s lemon laws for safety. Stranded me in Cincinnati without GPS.

Link to post
Share on other sites
  • 2 weeks later...
  • 4 weeks later...

Has anyone been successful getting the problems fixed? I have had the screen going black and volume ramping up since oct 2019, 72 km.The truck has been in several times for updates and a new radio,still same old problems.The worst truck i ever had. I HAVE BEEN DRIVING GM PICKUPS SINCE 1978, ALL PURCHASED AT THE SAME DEALER. NO MORE !!! Unfortunatly no lemon law in ontario canada.

Link to post
Share on other sites

My husband and I just bought 2 different Chevrolet vehicles. 2020 Silverado and a 2020 traverse. The black screen seems to be still an issue after reading all these posts! My husband has had his radio fully replaced and still has he same issue occurring. This is extremely disappointing as we were being told to stay away from Chevy! 

Link to post
Share on other sites
  • 2 weeks later...

Hi, today morning I went to work, everything’s working as it should, stopped to fill up real quick, starting my truck, Chevy logo appears as usual, but this time it went on for about 30 seconds, then screen goes blank, the only time screen works is when I switch to reverse, apparently screen didn’t burn out, any of the infotainment controls are working, by the way my 2020 Silverado has only 7k miles on it, this should not happen regardless of the mileage, let alone so early in truck’s life, if anyone knows what’s going on, please share, thanks

Link to post
Share on other sites
  • 2 weeks later...
On 4/5/2020 at 10:49 AM, Cpl_Punishment said:

Mine is a 2019 1500 WT Crew Cab. It has randomly occurred since before its first oil change at 5,000 miles then until now 15,000s. My dealer already replaced the unit but still happening. Dealer said nothing they can do. So embarrassed when it happens with others in my truck. My daughter says "Oh dad, the radio is working! Impressive." 

 

Edited by Interleukin6
Link to post
Share on other sites
  • 2 weeks later...

Has anyone paid attention to possible triggers that lead to the head unit not functioning? For example I have a 2020 Sierra 1500 Denali and when my screen goes out I get a black screen with a red triangle with a red exclamation point inside of it which is an Android OS crash icon. I noticed this weekend that every time my head unit crashes the first indicator will be that the Denali logo which normally flashes when I unlock my truck and the dash display turns on, it doesn't come on, the dash display turns on but with just a black screen where it would normally show the Denali logo then it will load the gauges and the head unit will show me the red icon over the black screen. 

 

Does anyone know how the dash start up is connected to the head unit? It seems as if the bug is a software/firmware bug that crashes upon startup of the OS or it could possible be driven by a bad shut down sequence when we turned the car off that leads to an unrecoverable crash that take a while to reset. On my truck the head unit will come back after I drive around for a bit and shut the truck down and let all systems shut down completely before I turn it back on. Today was the first day where I started measuring distance traveled and time elapsed between crashes and being able to recover. The only time it crashed today it recovered after 23 miles traveled in about 30 minutes. I did check at mile 3 and about 10 minutes of travel time to see if that was enough time to recover and it hadn't so next time it crashes I'll record the same distance and time to see if we can zero in on the recovery time. Wonder if we can find out what the denali dashboard logo and OS starting up sequence ties into the head unit. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.