Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Onstar doesn't work all of a sudden; flashes red light


Recommended Posts

Hello,

New to the site but have been lurking here before. Been looking around and can't find any good information on the situation so I wanted to post a question.

I have a 2015 Silverado LT Crew 4x4. A month or two ago I noticed this faint red (more like orange) light flash on the rear view mirror. I know the red light means Onstar is not connected but in this case it flashes very quickly. I push the buttons and nothing happens.  Then I noticed the compass in the infotainment is empty and the dash shows N all the time.  I called Onstar and they tried to connect and couldn't. They said we cannot connect to your vehicle please take it the dealer.  Well I don't go to the dealer if I can help it. So I have been doing some research.

 

Now here is the thing that has me concerned...in October of last year I installed a Rough Country 30" light bar.  No problems, it works fine, but I really can't remember if this Onstar issue was before or after that.  I looked in the manual about Onstar stuff and found in there "Dont add electrical equipment" it could effect Onstar etc. etc. Is this really my problem?  I disconnected the light bar and Onstar doesn't come back, I have checked the fuses that are linked to Onstar and they are fine.

 

Has anyone seen this type of problem?  Is it pure coincidence that the Onstar problem happened after I put on the light bar?

 

Is there a way on the truck to reboot Onstar?

 

Any help would be appreciated!

 

Thanks,

Justin

Edited by opeg1979
Link to comment
Share on other sites

It's not hard. First of all , you don't need to drop the whole thing. Just the front. Remove the left "A" pillar molding, sun visor, sun visor anchor, left assist handle and the upper console. There are two screws  under the flat trim plate that holds the switches. The plate snaps down ( plastic pry tool ). Remove the two screws and pull the console down.That will give access to the cables and antenna bolt.

  • Thanks 1
Link to comment
Share on other sites

14 hours ago, tbarn said:

It's not hard. First of all , you don't need to drop the whole thing. Just the front. Remove the left "A" pillar molding, sun visor, sun visor anchor, left assist handle and the upper console. There are two screws  under the flat trim plate that holds the switches. The plate snaps down ( plastic pry tool ). Remove the two screws and pull the console down.That will give access to the cables and antenna bolt.

When you say left “A” pillar molding, and the the left assist handle is that the same piece or is there two? Thanks for the tip too, I would not want to drop the whole liner ?

Link to comment
Share on other sites

58 minutes ago, tbarn said:

Left assist handle is above the center of the door opening. 2 different parts.

What year are we talking about? Okay, I feel like an idiot...went and looked, just found it right where you said it would be, one on the passenger side too! I never even noticed them being there ? so thanks once again!! I was thinking the A pillar handle (installed after purchase) but learned something new ?

Edited by SS502
Added me being an idiot lol
Link to comment
Share on other sites

6 hours ago, SS502 said:

What year are we talking about? Okay, I feel like an idiot...went and looked, just found it right where you said it would be, one on the passenger side too! I never even noticed them being there ? so thanks once again!! I was thinking the A pillar handle (installed after purchase) but learned something new ?

Your statement was fine, and I see you are becoming an expert with the thumbs up, thumbs down emoji!

  • Thanks 1
Link to comment
Share on other sites

  • 2 months later...

Update on this. I got a new antenna.  When I took off the old one I did not see any signs of water and I am not surprised given the fact that I live in AZ.  I quickly realized i got the wrong one,  because it was missing the XM connector.  Anyway, I plugged it in and it did not fix the issue. So doing more research I think I found the next best possibility. Onstar has a backup battery, and I read that if you disconnect your backup while the key is on or the dash lights are on it triggers the backup battery to engage as if the vehicle was in an accident to contact Onstar.  This may have happened by me or when Walmart put in a new battery in the truck I am not sure, but that seems to be a logical possibility.

Link to comment
Share on other sites

  • 1 month later...

so how did you fix it?   mine did the same thing when i changed my battery.  just 4 days ago....Im pissed cause i dont want to spend money at the dealership just for changing a beat 3 year old battery.

 

ive got a 2016 sierra 1500 slt 4by   

 

changed battery and all of a sudden onstar stopped working and myGMC wont connect to the truck.  light is red on the mirror.

 

they told me same as you....take it to a dealership to have them look at.

 

this must be a common problem they know of.

Link to comment
Share on other sites

  • 1 month later...

I'll be honest I have not found a solution, cause it is not a top priority.  I can't find where this so called backup battery is at and don't want to start tearing into it till i find some good info on it. I think its behind the radio screen though. Maybe someone on here can confirm?  Just had my battery replaced again (batt. last 2 years here in AZ) so now i have a new fresh battery I will start looking into it more.  Lately, i have not even seen the light flash or i just keep missing it! I hope we can find a solution, its just annoying when stuff doesn't work even if you don't use it!  My main reason to fix is i like the mobile connectivity stuff like remote door locks specifically.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By bpdamas
      Does anyone know how to add the digital key for the GMC Hummer EV? It says it should be in the app to select but I don't see it there. I followed the manual instructions as well but don't see the option for a digital key. If anyone knows or can help I would appreciate it. 
    • By Madtownwis
      I have a 2018 Silverado. I replaced the battery last fall and each onstar diagnostic report afterwards warned that my battery was low. I took it to my Chevy dealer and they said the batter is fine. Is this a know issue?  
    • By SquattedChevOnBlack
      Hey there I have a
       
      2015 1500 5.3L LTZ Silverado 4WD (midnight edition)
       
      Anyway I was doing highway miles and got a console alert that oil level was low. Stopped at the auto parts store, added one quart, saw level was still low.. so I added a second quart which filled it up. I climbed under the engine in the parking lot, and took a peek at the oil pan. I noticed the gasket was all mushroomed out and there was oil pretty much caked everywhere lower than that seal.
       
      I took it to the dealership to get it repaired and the service manager told me the strangest stories.
       
      He said
      1) the lower oil pan is one time use
      2) the lower oil pan gasket is RTV
      3) the upper oil pan gasket was also leaking
      4) the crimp in the oil cooler line was leaking (didn't realize my engine even had an oil cooler!? Why would a light duty truck have this equipped?)
       
      He quoted $2000 for everything including 10% sales tax.
       
      Does this raise the alarm for anyone else here? I only saw oil from the lower gasket downward. The parts on rock auto are about $70. I think I'll have to do this one myself but would love some thoughts. 
       
      Thanks in advance.
       
    • By CajunSpices
      Hello, I've done quite a bit of searching on this topic and can't really seem to find a fix. Was wondering if anyone could help me out here as it's starting to get annoying. In my 2014 Chevy Silverado, my options to connect a new phone to bluetooth are greyed out. It doesn't let me click it at all. Another thing that is maybe just coincidence is my onstar seems to not be working either. There is a red light instead of a green one on my rear view mirror. Every now and then it'll go green for 2-3 seconds, and then turn to red. Not sure if this has anything to do with the bluetooth. 
       
      The troubleshooting I have done is: 
      Taken the radio out, cleaned the plugs, refitted them and reattached the radio; Nothing. 
       
      Fooled with the wire behind my rear view mirror to see if it's a bad connection of some sort; Nothing. 
       
      Tried to pair my phone through voice and any other work around; Nothing. 
       
      Removed all previous devices, and still nothing. 
       
      Im kind of at loss here, any help would be appreciated. Thank you! 
    • By Jackp007
      So onstar light comes on and “cal” where compass used to be is there now.. front center and right park assist now flashes and seat buzzes every time I slow to a crawl...  onstar call says gps is gone...  
      move had GMC 3/4 diesels, 3/4 HD, 1/2s...  always Denali...  this truck is a horrible build... 2017 1500 Denali...  control arm banging (of course off warranty)... seat left side caved in (no I’m not obese), fan buzz (off warranty), “Chrome” on plastic all pitting, coating on wheels all falling off, so so many issues I never had on last 5 GMC trucks....   
      now get to go pay to have GPS and park assist fixed....   thinking it may be Toyota time after 5 fully loaded Denali’s....   
       
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    241.4k
    Total Topics
    1.4m
    Total Posts
  • Member Statistics

    305,419
    Total Members
    8,960
    Most Online
    Jay Kuropatkin
    Newest Member
    Jay Kuropatkin
    Joined


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.