Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

midriv

Anyone lost brakes besides me.

Recommended Posts

Just had the truck back again- this time, the camera goes on the screen each time you come to a complete stop. How annoying is that?

Share this post


Link to post
Share on other sites
1 hour ago, Jeff and his Silverado said:

Just had the truck back again- this time, the camera goes on the screen each time you come to a complete stop. How annoying is that?

Wow, that’s a new one. GM finally issues me a rental, 2500 Heavy Duty Ram

Share this post


Link to post
Share on other sites
2 hours ago, Jeff and his Silverado said:

Just had the truck back again- this time, the camera goes on the screen each time you come to a complete stop. How annoying is that?

Sounds like one of your sensors are causing the camera to come on.

Share this post


Link to post
Share on other sites

Had the brake issue for over 2 months now ever since it got cold. Doesn't happen always but my engine light has been on for weeks from the several brake failures. Also it is not just a single ignition cycle I have had to retry starting the truck over 3 or 4 times to clear it after waiting 20 mins. 

 

2019 Trailboss LT, took it in early Jan had all the recalls fixed, alternator cable, catching fire issue and supposedly the brake fix flashing ECMB? Something like that. Anyway by mid Jan was -15 degrees and boom brakes go out before work. Then every other day or sometimes 3 days between. Now it has been week and a half since they failed but has been warmer. Check Engine light has been on for a month now, brand new truck engine light on it tickles the OCD part of my brain seeing it everyday. Will cross my fingers on this yet again time consuming process. Oh and can not get into dealer until March 10th .

Share this post


Link to post
Share on other sites
2 hours ago, tsbond said:

Had the brake issue for over 2 months now ever since it got cold. Doesn't happen always but my engine light has been on for weeks from the several brake failures. Also it is not just a single ignition cycle I have had to retry starting the truck over 3 or 4 times to clear it after waiting 20 mins. 

 

2019 Trailboss LT, took it in early Jan had all the recalls fixed, alternator cable, catching fire issue and supposedly the brake fix flashing ECMB? Something like that. Anyway by mid Jan was -15 degrees and boom brakes go out before work. Then every other day or sometimes 3 days between. Now it has been week and a half since they failed but has been warmer. Check Engine light has been on for a month now, brand new truck engine light on it tickles the OCD part of my brain seeing it everyday. Will cross my fingers on this yet again time consuming process. Oh and can not get into dealer until March 10th .

I would contact GM and have them start the investigation into it, get a rental that GM pays for and be safe.

  • Like 2

Share this post


Link to post
Share on other sites
On 2/9/2020 at 12:26 AM, TBL569 said:

I just had the newest one done yesterday -the update to fix the fix for the fix for the recalls.  So far 36hrs and no problems!

Have you used the myGMC app to remote start your truck with no issues?

Share this post


Link to post
Share on other sites
Just now, RadioFlyer32 said:

Have you used the myGMC app to remote start your truck with no issues?

Nope, not throwing money at Onstar to use their app but would if it was free like it used to be.  Going on 9 days now without issues!

  • Like 1

Share this post


Link to post
Share on other sites
Have you used the myGMC app to remote start your truck with no issues?


Used it several times since the latest update. No issues so far!

Share this post


Link to post
Share on other sites

Well I have joined the crowd with Brake issues. Just purchased 2020 Trail Boss LT yesterday and left it at the Dealer yesterday. Have Service Brake Assist and Engine light. Drove back to dealer and they said they forgot to reset fault after software load, good to go. I also drove the truck 40 miles before warning came on. So forgetting to reset fault is BS. Well I made it 2 1/2 mile and the warning returned , back to Dealer and they gave me another new truck as a loaner it has acted good so far. No news today from Dealer.

GM needs to fess up and fix these issues!!!!

 

The waiting game begins.

Share this post


Link to post
Share on other sites

I have a theory on the brake issue. I had a eerily similar problem recently happen to me on my 2009 Tahoe and I ended up having to self diagnose it as the dealership guys have no clue what to do except start replacing uber expensive parts. Believe me if it is on your dime (out of warranty coverage vehicle) they will be happy to spend thousands in just a few hours and NEVER EVER actually pinpoint the real issue. It will be fixed but you will be bankrupt in the process. GM will NOT allow the dealerships to do this to them no more than I would allow it myself, so they are still searching to find the root cause and it seems to be putting a lot of people in true jeopardy from having insufficient brakes while they fumble along doing part restriction until they find a root cause and a economical way to do the repair. 

Here is my Theory: Issue is the ABS assembly underneath all modern vehicles, it has an exterior mounted control module with electric solenoids. The  control module to valve body gasket is bad which allows water to get inside and onto the solenoids. If you read back through the posts you will see numerous people mention automatic car washes. These car washes are forcing water at the ABS assembly and the leaking seal is simply allowing water into the control module and shorting it out.  Usually happens shortly after driving though large puddles / fording deep water or going through your friendly neighborhood car wash.

 

GM could easily replace all these ABS assemblies as a whole but the cost would bankrupt them so it is a self preservation move to stall until they pinpoint the issue. Once they figure out the exact problem is just a 300 dollar control module they will replace the individual part and add a better 100% seal gasket and everyone can motor on safely. In the meantime all these vehicles should be parked NO JOKE!  Here are some pics of a typical control module that has leaked. 

Once the water shorts it out you loose Power Boost / Stabiltrak and ABS functions until it dries out a bit but eventually it will not be able to reset at all.  

Note to GM corporate: just direct deposit the 10 million that I just saved you

IMG_9401.jpg.feb20484c4c36f9b20335cd08a31b833.jpgIMG_9406.jpg.c239def75538adea3a9db0ee6b2810b8.jpgIMG_9407.jpg.400bded96db5426cb6a494e4ff72a895.jpg 

 

 

 

     

  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/16/2020 at 11:40 AM, pstrouse167 said:

 


Used it several times since the latest update. No issues so far! emoji1694.png

 

Thanks!  Went ahead and received all of the recalls. Have used remote start (app and key) multiple times with no issues. 

  • Like 1

Share this post


Link to post
Share on other sites

I just got the brake warnings and check engine when i started the truck. Turned off and restarted and the brake stuff went away, but my check engine light is still on. Ive never used the app to start, only used the key fob remote start once a while back just to see if it worked.  So its not just the trucks using the app that have the problem.

Share this post


Link to post
Share on other sites

Looks like the ABS assembly is under the brake fluid reservoir.

1502632441_2019SierraABSassy.thumb.jpg.f4838879aae9364f427a6313d7e57e9d.jpg  

Share this post


Link to post
Share on other sites

Was scrolling through the infotainment system and noticed this recall info in the MyGMC area. On the previous screen it had a date of Jan 30th 2020

IMG_9451.thumb.jpg.2f216b6923319b53bfa6e901fab24b8d.jpgIMG_9452.thumb.jpg.dbbad4d445f291d9009c3e24d67cb4a5.jpg

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.