Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Terrible Feature - Truck Shuts Off On It's Own?!?!


Recommended Posts

It's supposed to... Sorry, didn't read all the comments but, the engine is supposed to shut down when you come to a stop, under certain conditions. See page 210 of the owners manual it will tell you all about it...  It can also be inhibited  by pressing the engine function button  on the dash. Ha .... that was the first thing my dealer showed me when he gave me the Pre Delivery Show.

Sorry.....didn't see your original

posting date of Jan 2019....

Edited by Darry Pastula
Link to post
Share on other sites
  • Replies 228
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

The lack of reading comprehension in this thread is painful. lol.      

Its a safety feature so you dont pull up in your garage and kill yourself.    Leave the key in the car and it wont quit. 

lol everyone just ignores the part about sleeping in it overnight when you need the heater on

Posted Images

5 hours ago, Darry Pastula said:

It's supposed to... Sorry, didn't read all the comments but, the engine is supposed to shut down when you come to a stop, under certain conditions. See page 210 of the owners manual it will tell you all about it...  It can also be inhibited  by pressing the engine function button  on the dash. Ha .... that was the first thing my dealer showed me when he gave me the Pre Delivery Show.

Sorry.....didn't see your original

posting date of Jan 2019....

not what the thread is about.  it's about leaving the truck running when it's parked, not about when you stop at a light while driving...

Link to post
Share on other sites
On 12/21/2020 at 2:03 PM, fsuboy75 said:

 

It did not work for me...at least the three ways I just did it.

 

1.  Press brake, press and held start button for 15 seconds....probably more like 20.  Shut off at 30 min.

 

2.  Press brake, press button, kept button pressed but took foot off brake for like another 20 seconds just to be sure.  Shut off at 30 min.

 

Both times no indications, beeps or messages popped up.

 

3.  Press brake, press start, released.  Pressed button again quick, obviously shut off.

 

 

******

 

Was the remote inside the truck while you were testing it?

 

Link to post
Share on other sites

Didnt read about the 15 second thing until now, but yesterday I had the dealer Update or reflash my truck with the UF3 Fast Idle Feature (my 3500 didnt come with it)  Was about $150 to "rewrite" the computer from GM. 

I tested it and it ran for over 3 hours without shutting down.  Remote left inside the cab (just like if it had a key, it would need to be inside)

You can test if you already have the fast idle feature in your truck by 

start truck, 

parking brake on

turn cruise control on

press "set"

(make sure youre not pressing on the brake)

If your idle goes up, then you have it, if it doesnt you dont.

to disengage the fast idle press on the brake or turn off cruise control, to engage it again just "set" your cruise again without pressing on the brake. 

hope this helps, it definitely worked for me yesterday tested it for almost 3.5 hours.  Not sure how long itll stay on but at least I can sleep at cold rest stops longer than one hour now.  

  • Like 1
Link to post
Share on other sites
Didnt read about the 15 second thing until now, but yesterday I had the dealer Update or reflash my truck with the UF3 Fast Idle Feature (my 3500 didnt come with it)  Was about $150 to "rewrite" the computer from GM. 
I tested it and it ran for over 3 hours without shutting down.  Remote left inside the cab (just like if it had a key, it would need to be inside)
You can test if you already have the fast idle feature in your truck by 
start truck, 
parking brake on
turn cruise control on
press "set"
(make sure youre not pressing on the brake)
If your idle goes up, then you have it, if it doesnt you dont.
to disengage the fast idle press on the brake or turn off cruise control, to engage it again just "set" your cruise again without pressing on the brake. 
hope this helps, it definitely worked for me yesterday tested it for almost 3.5 hours.  Not sure how long itll stay on but at least I can sleep at cold rest stops longer than one hour now.  

Interesting. Although I think most of us have 1500’s. I haven’t heard of fast idle for the half tons.
Link to post
Share on other sites
1 hour ago, bamorris2 said:


Interesting. Although I think most of us have 1500’s. I haven’t heard of fast idle for the half tons.

Correct.

UF3         High idle switch

is a 2500/3500 thing.

 

 

Link to post
Share on other sites
On 1/11/2021 at 6:17 PM, RhinoGuy said:

Pressing and holding down the start button for 10-15 seconds disables this in my 21 Yukon.

Sent from my SM-N986U1 using Tapatalk
 

Are you leaving a FOB inside, or does that not matter?

 

Foot on the brake, press and hold, engine starts, keep holding for 10 to 15 seconds?    

 

Any indicators that tell you this engages?   

Link to post
Share on other sites
5 hours ago, 2020 said:

Was the remote inside the truck while you were testing it?

 

No....I took the remote in the house with me....do you have to leave a remote inside???

Link to post
Share on other sites
Are you leaving a FOB inside, or does that not matter?

 

Foot on the brake, press and hold, engine starts, keep holding for 10 to 15 seconds?    

 

Any indicators that tell you this engages?   

Remote inside of the vehicle, hold down the brake, press and hold start button for 10-15 seconds.

 

ETA: just tried without holding the brake the whole time. It still works. And to clarify, the engine does start just like normal during the process. You just dont stop pressing the button like you normally would starting the vehicle.

 

 

 

075d42f71768cd59f28d7fd8b5bd0ed0.jpg

 

Sent from my SM-N986U1 using Tapatalk

 

 

 

Link to post
Share on other sites

Just started the vehicle doing the 15 second trick. Took a the fob out of the vehicle, locked the door using the fob, and brought the fob into my house. I'll update you guys in a hour to see if it's still running.

Sent from my SM-N986U1 using Tapatalk

  • Like 1
Link to post
Share on other sites
Just started the vehicle doing the 15 second trick. Took a the fob out of the vehicle, locked the door using the fob, and brought the fob into my house. I'll update you guys in a hour to see if it's still running.

Sent from my SM-N986U1 using Tapatalk


Still running!

Sent from my SM-N986U1 using Tapatalk

  • Like 1
Link to post
Share on other sites
1 hour ago, RhinoGuy said:

Still running!

Sent from my SM-N986U1 using Tapatalk
 

Must just not work on the Silverado?   I dunno.   

Link to post
Share on other sites
Must just not work on the Silverado?   I dunno.   

It’s a completely different electrical platform so that’s not surprising.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.