Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
Cpl_Punishment

Anything you hate about your truck?

Recommended Posts

The transmission by far.  Low power, always hunting for gears, clunking in and out of gears.  The warranty is the only reason I haven't gotten this thing tuned.  Also the AFM.  What little fuel economy it provides is not worth what you suffer in performance and drive-ability.  These trucks just have no "get up and go" like the older  models did and it's all in the tuning.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/4/2019 at 7:35 AM, 1SLOW1500 said:

And how did you get 420hp. More like 320. And really much less with torque management.

Sent from my SM-N960U using Tapatalk
 

Nope.   420HP and 460lb ft at the crank which is what Adioss was referring to.  Probably 320ish at the wheels.  Torque management has nothing at all to do with how much power the engine makes, just with how it is put to the ground. 

Share this post


Link to post
Share on other sites
Nope.   420HP and 460lb ft at the crank which is what Adioss was referring to.  Probably 320ish at the wheels.  Torque management has nothing at all to do with how much power the engine makes, just with how it is put to the ground. 
I agree the point was to say the tune and trans are limiting the power is all. I have dynoed a few and am aware of the power numbers.
If the tune only allows say 30% off idle then how much is at the wheels? Most people dont understand that they take the biggest number they hear and that is just what they have period. Then pick a reason to be upset when it drives slow or shift weird. Then pick a issue afm/DOD, or trans. Also most people dont know there is also a fuel cut built in that cases some trouble.

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
Share on other sites
3 hours ago, bayouguy71 said:

I usually just crack the back passenger window and it goes away, makes the overall noise lower as well.

Or Rear Slider if you have one.

Works for me.

Share this post


Link to post
Share on other sites
On ‎4‎/‎4‎/‎2019 at 8:20 AM, Darmichar said:

I've had both OE setups, the black Tenneco's on my 2014 and now the Rancho's on my 2018, both leave a lot to be desired.

Your "Rancho's" are made by Tenneco.

Share this post


Link to post
Share on other sites
On ‎4‎/‎3‎/‎2019 at 6:07 PM, ickyoldman said:

You guys wanting more electronic shit crack me up.  I want LESS ELECTRONIC nanny shit on my vehicles.  Adaptive cruise?  Give me an effing break.  I can hardly keep the dam thing out of the dealership for all the codes it likes to throw.  Some of you guys don't need a truck.....you need to go back to your beamers and imported shit so you can get all the electronic crap you seem to need.

I agree Icky....

If you want more electronics, go buy a TESLA :thumbs:

  • Like 1

Share this post


Link to post
Share on other sites
29 minutes ago, Sierra Dan said:

Your "Rancho's" are made by Tenneco.

Oh, trust me, I know.  I think they're actually a little sloppier than the black OEM's

Share this post


Link to post
Share on other sites

I was happy to ditch my Ranchos. Rusted to the max and peeling paint after only about 36k miles.

Not to mention they rode like pogo sticks. Rebound dampening is atrocious to put it nicely.

Share this post


Link to post
Share on other sites
1 minute ago, Sierra Dan said:

I was happy to ditch my Ranchos. Rusted to the max and peeling paint after only about 36k miles.

Not to mention they rode like pogo sticks. Rebound dampening is atrocious to put it nicely.

I was under my truck 2 weekends ago and mine were starting to look pretty crusty, too.

Share this post


Link to post
Share on other sites
41 minutes ago, 1SLOW1500 said:

I agree the point was to say the tune and trans are limiting the power is all. I have dynoed a few and am aware of the power numbers.
If the tune only allows say 30% off idle then how much is at the wheels? Most people dont understand that they take the biggest number they hear and that is just what they have period. Then pick a reason to be upset when it drives slow or shift weird. Then pick a issue afm/DOD, or trans. Also most people dont know there is also a fuel cut built in that cases some trouble.

Sent from my SM-N960U using Tapatalk
 

AdioSS said "I really hate that 98mph speed limiter! I’ve got 420 horsepower! Let me use it!"

Driving slow has NOTHING to do with having only 30% of your power available off idle.  That would be acceleration.  AdioSS is talking about top speed.  The fuel cutoff limits your top speed. 

If you were limited to only 30% of the total 420hp because of drive line loss for instance, your top speed would then be limited to how much drag 126hp could overcome.  

Please do not be offended by this because I think you really know your stuff.  Your grammar, punctuation and the "train of thought" style that you type in can make it very hard to follow and understand what you are trying to say.  Not just in this post.  I have read hundreds of your posts and most are difficult to grasp.  You have a tremendous amount of knowledge, it just doesn't present very well.

 

Share this post


Link to post
Share on other sites

No offense. I run 2 laptops a TV a phone and a tablet all at the same time. Everyone I talk to says the same thing. I am in many forums and also many messages at once. The 30% as I was saying is the torque management saying wow no no you can have that power. Not drive train loss.
The fuel cut I was speaking of is regular non speed based cut offs.
Sure I missed some thing on phone I cant read comments once I type.

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
Share on other sites
4 hours ago, NCPGMC said:

I think the idea behind the remote start it to do it on a cold day to warm it up and/or a hot day to cool it down...I get that it can be done anytime but it's a convenience thing. I don't think it was designed to use everytime you drive the truck. Why would you do it so often when its not really needed?

 

 

 

Ive used remote start on everything I’ve owned for 99% of every start for at least 10 years now. I always let my motor run a few minutes before I pull off. Give it time to warm up the oil a little and circulate it well. 

Share this post


Link to post
Share on other sites
5 minutes ago, Darmichar said:

I was under my truck 2 weekends ago and mine were starting to look pretty crusty, too.

If ever you go to replace them, compress down and notice how they instantly sink down about an inch, then feel like a spring inside.

That is how mine reacted. Absolutely no compression was left and a pogo stick rebound.

Share this post


Link to post
Share on other sites
On 4/12/2019 at 4:29 PM, rah7777777 said:

 

 

 

Ive used remote start on everything I’ve owned for 99% of every start for at least 10 years now. I always let my motor run a few minutes before I pull off. Give it time to warm up the oil a little and circulate it well. 

 

Same here.  I've had my truck for 5 years now and I can probably count on one hand how many times I've used the key in the ignition to start it up.  I pretty  much always use the remote start.  It shouldn't hurt anything to do it every time and I fall into that crowd of letting your vehicle run for a couple of minutes before you just get up and go.  Some people I know are throwing their vehicles into gear while the start up chime is still going off...I don't understand that kind of abuse.  These are the same people that throw it into drive and hit the gas while the vehicle is still rolling backwards from going in reverse.

Share this post


Link to post
Share on other sites

The rancho shocks... swapped in Bilsteins and couldn't be happier

Remote start, but no keyless go... ridiculous.

The v4 mode. since disabled.

woulda liked to have had a 6.2, but I bought used.

 

other than that, can't really complain

Quote

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.