Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

3 hours ago, Mariah Forar said:

The dealership told me that the transfer case was "confused" and didn't know what driving mode it was in so it ended up getting stuck in 4HI causing the rear diff to slip and the truck wouldn't drive forward at all. I was told they had to re-program the transfer case control module so basically meaning they reset it?? and I was told it's good to go... Well we'll see. If it comes down to a computer getting confused then like any phone or laptop, which happens quite often, we reset those when they get "confused" but with my truck, I had to get it towed yesterday because the computer was confused??? Ridiculous. I'll be waiting impatiently for a recall notice.

Good luck hopefully that fixes yours ( although mines still driveable). They did the realern on mine last week and it still is showing up after.

Edited by 19Sierra

Share this post


Link to post
Share on other sites
On 1/25/2020 at 1:33 AM, Colossus said:

Not according to the NHTSA. 

Im still waiting on your NHTSA numbers that they dont provide.  IF you dont know just shut it. 

Share this post


Link to post
Share on other sites
On 1/28/2020 at 5:32 AM, Mariah Forar said:

The dealership told me that the transfer case was "confused" and didn't know what driving mode it was in so it ended up getting stuck in 4HI causing the rear diff to slip and the truck wouldn't drive forward at all. I was told they had to re-program the transfer case control module so basically meaning they reset it?? and I was told it's good to go... Well we'll see. If it comes down to a computer getting confused then like any phone or laptop, which happens quite often, we reset those when they get "confused" but with my truck, I had to get it towed yesterday because the computer was confused??? Ridiculous. I'll be waiting impatiently for a recall notice.

How can the rear Diff slip? I think that there is some else causing the problem and they do not know how to fix it.

Share this post


Link to post
Share on other sites

HI everyone,

 

I am part of this too. Bought a LT trailboss last June and mine was stuck on 4-LO today as I pulled out of my driweway after a snowstorm. For some reason I don't understand although it is stuck in 4-LO the front axle doesn't get any power. That 60k$ truck stuck on rear wheel drive LO gear in deep snow wasn't going anywhere....Had it towed to the dealership...I will let you know what is the problem once they find it. 4wd warning service light is on

What is even more curious, the loaner I have for the weekend  had an amber 4-Hi light with the service 4WD light popping up on my way back from the dealership. It disapeared after a couple miles but still very weird. It cannot be a simple coincidence.

 

Good night

Share this post


Link to post
Share on other sites

Mine is currently at the dealership and they are trying to figure out why this is happening. Dropped it off Thursday night. Will update when I have more information.

Share this post


Link to post
Share on other sites

Damn electrical/electronic garbage. 

Share this post


Link to post
Share on other sites

I have an 18 2500 with the DMAX, currently having the same issue. Truck has 34k miles, and didn’t have any issues until last oil change at dealer. I assume they did an update and a week later the “service 4wd” message came on. I have an appointment at my local dealer tomorrow and will let everyone know what they say. 

Share this post


Link to post
Share on other sites

Starting to lose my patience with this dealer. Was told they cannot duplicate the issue so far (dropped truck off last thursday night with the service light on). Was told that if you shift the transfer case in park than it will throw that light everytime as the transfer case is not supposed to be shifted with the truck in park. I'm calling bs on that. And even if that was the case than they should be able to get an active code fairly easily than. The light has come on when driving as well as when switching out of auto when I pulled into the garage. Was also told that they need the loaner back as it has been sold. When I asked what there plan is now for the truck I was told that since they dont have another loaner available that they will let me keep it for one more day and they will try to duplicate again tomorrow. 

Share this post


Link to post
Share on other sites
28 minutes ago, 19Sierra said:

Starting to lose my patience with this dealer. Was told they cannot duplicate the issue so far (dropped truck off last thursday night with the service light on). Was told that if you shift the transfer case in park than it will throw that light everytime as the transfer case is not supposed to be shifted with the truck in park. I'm calling bs on that. And even if that was the case than they should be able to get an active code fairly easily than. The light has come on when driving as well as when switching out of auto when I pulled into the garage. Was also told that they need the loaner back as it has been sold. When I asked what there plan is now for the truck I was told that since they dont have another loaner available that they will let me keep it for one more day and they will try to duplicate again tomorrow. 

one would think an intelligent GM engineer would build this logic into their software.

Share this post


Link to post
Share on other sites
4 minutes ago, 1997SierraSLT said:

one would think an intelligent GM engineer would build this logic into their software.

You would think. They've gotten the same code 4 times. Now they tell me that it is always a history code not an active code and that they cant do anything unless it's an active code. So At first I'm told they cant do anything unless there's a code. Now that there is a code I'm told it's the wrong kind of code. Seems they are trying all they can to get me to just live with it. That's not gonna happen. 

Share this post


Link to post
Share on other sites
On 2/10/2020 at 6:31 PM, 19Sierra said:

You would think. They've gotten the same code 4 times. Now they tell me that it is always a history code not an active code and that they cant do anything unless it's an active code. So At first I'm told they cant do anything unless there's a code. Now that there is a code I'm told it's the wrong kind of code. Seems they are trying all they can to get me to just live with it. That's not gonna happen. 

I took my 18 2500hd in today and got told the 4wd actuator is going out on the new trucks like crazy. I was told it would take 2 days to get it in. So be ready for the 4wd light to come on

Share this post


Link to post
Share on other sites

Dealer is going to replace the transfer case range position sensor. Said part is on National backorder right now.

Share this post


Link to post
Share on other sites
On 12/24/2019 at 11:45 AM, Ksalway said:

Scheduled an appointment for mine can’t get it in until December 30th. Any luck on your part coming in? The service 4wd message has come on 4 times now but clears itself

 
Still haven’t gotten the new TCCM.  It’s been over two months that it has been on order. Tonight while the truck was in 2WD the warnings and messages came back. The parking brake also did not want to disengage automatically when putting it in gear and giving a bit of gas. 

Share this post


Link to post
Share on other sites
 
Still haven’t gotten the new TCCM.  It’s been over two months that it has been on order. Tonight while the truck was in 2WD the warnings and messages came back. The parking brake also did not want to disengage automatically when putting it in gear and giving a bit of gas. 

Share this post


Link to post
Share on other sites
7 hours ago, KyAT4 said:
 
Still haven’t gotten the new TCCM.  It’s been over two months that it has been on order. Tonight while the truck was in 2WD the warnings and messages came back. The parking brake also did not want to disengage automatically when putting it in gear and giving a bit of gas. 

Mine is going back in Monday now to get an update to the tccm. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.