Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

On 11/11/2019 at 5:30 PM, Trail Boss said:

Same issue... 2019 Custom Trail Boss... @1800 miles, towed to dealer as parking brake would not disengage (computer reprogrammed); 4100 miles, service 4wd and parking brake engaged, was able to get electronic brake to disengage (been at dealer for 2 weeks, replacing actuator and contacts).  Was given a loaner vehicle.  Hoping to get vehicle back soon and that this fix works!

 

11/16/19 -- vehicle still at dealer, waiting on "new connectors"!!!

Any luck? I'm sitting in a parking lot as we speak, with this issue... and I'm mad as hell. Haven't even made my first payment on the truck yet. 

Share this post


Link to post
Share on other sites
Posted (edited)
On 11/11/2019 at 5:30 PM, Trail Boss said:

Same issue... 2019 Custom Trail Boss... @1800 miles, towed to dealer as parking brake would not disengage (computer reprogrammed); 4100 miles, service 4wd and parking brake engaged, was able to get electronic brake to disengage (been at dealer for 2 weeks, replacing actuator and contacts).  Was given a loaner vehicle.  Hoping to get vehicle back soon and that this fix works!

 

11/16/19 -- vehicle still at dealer, waiting on "new connectors"!!!

Any luck? Literally sitting in a parking lot with this same problem. Haven't even made my first payment. 

Edited by David J. Miller

Share this post


Link to post
Share on other sites

I have a 2019 GMC Sierra 1500, with all of the same issues, it started when the truck had approx. 1500 km it, now it has 39,000 km and the issue is ongoing with no resolution in sight. This truck has had 4 recalls on it and the transfer case was one of them, still happening almost every time I use 4 wheel drive. I feel your pain I live in Northern Alberta Canada and there is a reason I bought a truck with 4 wheel drive, because I want/need to use it.

Share this post


Link to post
Share on other sites

Well this hit me today. Driving on a dirt road about 56*F dry conditions. Switched from auto to 2H just before I hit pavement again and got the service 4wd and the orange light for the indicator. Drove home about 5 miles parks and waited for about 5 mins. I restarted and it’s all still there. I take mine to the dealer tomorrow for warranty work on it. I hope it’s a fast fix but these posts don’t seem good. 

44E3E4C3-7AB1-4B4F-B67F-3259E4C2DF46.jpeg

Share this post


Link to post
Share on other sites

I'm starting to wonder with the gm plants shutting down for now if the sensor for mine will ever come in. Lol

Share this post


Link to post
Share on other sites

Hey Guys,

 

Had the same issue you guys have been reporting, but with a slightly different twist. When I start my truck it gave me the service 4wd message and the 4wd indicator on the dash went yellow. Parking brake engaged. Brought it to the dealer today and the code came back as Transfer Case Control Module C15A9 5A - Range Actuator Position Sensor and Transfer Case Range Position Sensor Not Plausible.

 

They "Fixed It" by reprogramming the TCCM.

 

Less than 12 hours later it reoccured.

 

Is there a fix, and if so what is it???

IMG_1483.jpg

Share this post


Link to post
Share on other sites
20 hours ago, Mhugg226 said:

Hey Guys,

 

Had the same issue you guys have been reporting, but with a slightly different twist. When I start my truck it gave me the service 4wd message and the 4wd indicator on the dash went yellow. Parking brake engaged. Brought it to the dealer today and the code came back as Transfer Case Control Module C15A9 5A - Range Actuator Position Sensor and Transfer Case Range Position Sensor Not Plausible.

 

They "Fixed It" by reprogramming the TCCM.

 

Less than 12 hours later it reoccured.

 

Is there a fix, and if so what is it???

 

Mine is the same code. They tried the reprogramming but that didnt work for mine either. They said it's the sensor now but it's been on national backorder since beginning of February. 

Share this post


Link to post
Share on other sites
On 3/28/2020 at 6:24 PM, 19Sierra said:

Mine is the same code. They tried the reprogramming but that didnt work for mine either. They said it's the sensor now but it's been on national backorder since beginning of February. 

So i've contacted the dealer and they are have ordered the sensors and expect them in 3-5 days (highly doubt this will happen).

 

I've also reached out to GM customer care and im trying to work something out with them. I'm tired of all the headache of this truck. Are the 20's and better? does anyone have any tips for dealing with them?

Share this post


Link to post
Share on other sites
5 hours ago, Mhugg226 said:

So i've contacted the dealer and they are have ordered the sensors and expect them in 3-5 days (highly doubt this will happen).

 

I've also reached out to GM customer care and im trying to work something out with them. I'm tired of all the headache of this truck. Are the 20's and better? does anyone have any tips for dealing with them?

Good luck, hopefully the sensors come in as that would mean they are no longer on national backorder. As for dealing with them just be persistent but stay polite, they are a pain in the a**. There go to seems to be just call it a software anomaly Lol.

Share this post


Link to post
Share on other sites
On 3/30/2020 at 12:32 PM, Mhugg226 said:

So i've contacted the dealer and they are have ordered the sensors and expect them in 3-5 days (highly doubt this will happen).

 

I've also reached out to GM customer care and im trying to work something out with them. I'm tired of all the headache of this truck. Are the 20's and better? does anyone have any tips for dealing with them?

No.  They have their fair share of issues.  If you want a truck with fewer issues, go back about 10 years to the GMT-900s (without AFM) or even the GMT-800s.  Find a low millage and you'll have a GREAT truck!  Or go get a Crapota Tundra :( Sucks to say that but they have the fewest issues out of Dodge, GM, Ford, and Nissan. 

  • Like 1

Share this post


Link to post
Share on other sites
On 3/30/2020 at 7:39 PM, 19Sierra said:

Good luck, hopefully the sensors come in as that would mean they are no longer on national backorder. As for dealing with them just be persistent but stay polite, they are a pain in the a**. There go to seems to be just call it a software anomaly Lol.

Sensors came in and they are currently installing them... hopefully thats the fix.....

Share this post


Link to post
Share on other sites
23 minutes ago, Mhugg226 said:

Sensors came in and they are currently installing them... hopefully thats the fix.....

Good for you, sucks for me though mine are still supposedly on national backorder. Lol do you know which sensors they are? Maybe you are getting different sensors replaced.

Share this post


Link to post
Share on other sites

Truck is back and working for now.. they replaced the transfer case range position sensor... truck threw both C15A9 5A and C11AD 08 codes at them

Share this post


Link to post
Share on other sites
4 hours ago, Mhugg226 said:

Truck is back and working for now.. they replaced the transfer case range position sensor... truck threw both C15A9 5A and C11AD 08 codes at them

Yup that's the sensor I've been waiting on. Lol 

Share this post


Link to post
Share on other sites
7 minutes ago, 19Sierra said:

Yup that's the sensor I've been waiting on. Lol 

I'm located in Canada, perhaps the Canadian PDC's had stock and the US is out of stock?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.