Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Limelight

Jingle jingle underneath only in 2wd

Recommended Posts

19 hours ago, RAYS B4U said:

I know it's frustrating, and I'm going through it with my front diff jingle too, but problems happen to all manufacturers. We had a Ford Crown Vic Police car. It had a problem with losing power...(and a Ford can't afford to lose any power lol)...we had it to the dealer about 4 times, and finally after about $5k in repairs they finally fixed it.

 

So it can and does happen to all manufacturers.

I get it.  Just frustrating.  Had nothing but problems with this truck.  I went through this before with the leaky rear window too.

Share this post


Link to post
Share on other sites
On ‎9‎/‎12‎/‎2019 at 7:33 AM, z71 man said:

The new fix did not work on my truck, new shaft seals etc. still had the jingle. The engineer came by the dealership and told them to put a new differential in it.  This is my second new one.  The first differential they put in it had the jingle in it by the time I got the truck home about 20 miles. The new one has a little over 200 miles on it and so far no jingle!      This may be the fix for me, only time will tell.

Second new differential still has the jingle. Back to the dealership Monday

Share this post


Link to post
Share on other sites
22 hours ago, dho238 said:

I have no idea what is going to be replaced.  The truck is still at the dealership waiting for parts.  I'll have to wait and see.  Did you also have this same issue? 

Mine does not have any noise. It is an SU4 AAM AAHD tagged model and my truck was made in November 2018. I have 3400 miles on the truck now.

 

On page 1 of this thread, Limelight posted a video of the movement that was thought to be the issue. Mine has that same movement and my axle is quiet while driving.

 

Ive also spend a lot of time at dealerships testing other 4x4 models of different trim packages and they all have that same movement. Even the GM SU5 axle that is not affected has the same movement.

 

Whatever is causing the axle noise is internal and there is no other way to test it besides driving the truck and seeing if it makes the noise. 

Share this post


Link to post
Share on other sites
35 minutes ago, Tom Cox said:

Has anyone posting here actually had the issue corrected? 

 

None have been successful.

Share this post


Link to post
Share on other sites

I’ve had so many issues with my 2019 RST and still have them. The differential has been replaced twice and it still chirps at higher speeds but isn’t so bad the slower ya go. The transmission has all but been replaced and it still slams into gear like someone rear ended me. Last week I went to the lake and was pulling my bass boat up a pretty big hill and the truck shook and vibrated like it was gonna explode. Worst purchase I’ve ever made. Hope it’s just a lemon and I got unlucky. Still working on a replacement truck. The process of that alone is an extremely agonizing one. Hope to see a fix soon. 

Share this post


Link to post
Share on other sites

My truck went in for the supposed fix. It was OK for about 500 miles, but now it's back. Going to call GM once again and notify them. I started a case in early August. 

Share this post


Link to post
Share on other sites

Three strikes and you are out...at least here in Georgia. 

Edited by Tom Cox

Share this post


Link to post
Share on other sites
4 hours ago, lworley said:

I’ve had so many issues with my 2019 RST and still have them. The differential has been replaced twice and it still chirps at higher speeds but isn’t so bad the slower ya go. The transmission has all but been replaced and it still slams into gear like someone rear ended me. Last week I went to the lake and was pulling my bass boat up a pretty big hill and the truck shook and vibrated like it was gonna explode. Worst purchase I’ve ever made. Hope it’s just a lemon and I got unlucky. Still working on a replacement truck. The process of that alone is an extremely agonizing one. Hope to see a fix soon. 

Good luck. 

Share this post


Link to post
Share on other sites

Well got an email from gm exec. I guess they’re tired of calling me and hearing my mouth. It states they are reviewing my case and will follow up on 9/16. Hopefully, they will finally say something new rather than the let’s wait for this and wait for that game and nothing ever happens.


Sent from my iPhone using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

I got mine done a few weeks ago and I haven't heard the jingle come back yet. Probably been close to 400-500 miles since the repair. 

Share this post


Link to post
Share on other sites
5 minutes ago, The Tos said:

I got mine done a few weeks ago and I haven't heard the jingle come back yet. Probably been close to 400-500 miles since the repair. 

What did your repair consist of?

Share this post


Link to post
Share on other sites

Dropped my truck off this morning. Shop Foreman said that Engineer gave them "some things to try" - he wouldn't elaborate about what those things were. Not much confidence they will actually get the truck fixed. So we'll see - if they do fix it I'll be happy. But if they don't have it fixed by the third attempt it will be time to get some legal assistance with lemon law claim. 

Share this post


Link to post
Share on other sites

Just got a call from gm and they told me buyback not approved by district manager until field engineer looks at it. Wtf, I’ve been waiting for weeks to have the engineer look at it. Wasting my time and dragging things on. I’m pretty sure I’m over the 30 days required by my state law and the truck is still going to have multiple repairs done to it the next time it’s in the shop. Ohhhh the games they play


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.