Jump to content

Recommended Posts

I have a 1993 GMC Sierra C1500 v6 4.3L with an automatic transmission and i have tried replacing the distributor cap, router button, spark-plugs and the module that sits under the distributor cap but nothing works it just rolls tries to kick and if it does start it dies instantly. also when trying to start it smoke rolls out of the throttle body I have no clue how to fix this

Share this post


Link to post
Share on other sites

Try pouring some gas into the throttle body and then try to start it.

if it fires for a short time, fuel pump.

:)

Share this post


Link to post
Share on other sites

I opened the gas fill cap and you can hear the pump i replaced the pump in February it gets gas and its a mad enough misfire is floods up the plugs every time and smoke that smells like burning gas pours out of the throttle body

Share this post


Link to post
Share on other sites
1 hour ago, 95k150050 said:

Any check engine codes?

Service engine light has been in for like 5 years now and I dont have a code reader

Share this post


Link to post
Share on other sites

It's  your '93 right?  If so, it's OBDI, and I believe you can just use a paperclip to short some pins together to read the codes via a flashing light where you count the flashes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.