Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
Itsjustme

2019 factory fog lights

Recommended Posts

For folks that have installed the lights, does the orange indicator on the fog button illuminate when the lights are on? 
 

Mine does not. Others have reported the same. 
 

Would fix of this issue be under warranty?

Edited by swing4terps

Share this post


Link to post
Share on other sites
1 hour ago, swing4terps said:

For folks that have installed the lights, does the orange indicator on the fog button illuminate when the lights are on? 
 

Mine does not. Others have reported the same. 
 

Would fix of this issue be under warranty?

No. However the green fog light indicator on the instrument cluster lights up when the fogs are switched on.

 

I'm not even sure the fog light button even HAS an indicator on it. 

Share this post


Link to post
Share on other sites
35 minutes ago, Method2Madness said:

No. However the green fog light indicator on the instrument cluster lights up when the fogs are switched on.

 

I'm not even sure the fog light button even HAS an indicator on it. 

Apologies. You are correct. The button doesn’t have an indicator. The indicator in the cluster happens to sit right behind the wheel and I did not notice it. 

Share this post


Link to post
Share on other sites

I just had the kit installed on my 2019 1500 LT by my local dealer.  The one thing that is bothering me is that when I engage the Fog Lamps the dash indicator for daytime running lights comes on - there isn't any indicator that tells me that the fog lights are on (nothing separate).  My brother has the RST which has a 'blue fog lamp' indicator when his are engaged.  Mis-wired by the dealer?

Share this post


Link to post
Share on other sites
I just had the kit installed on my 2019 1500 LT by my local dealer.  The one thing that is bothering me is that when I engage the Fog Lamps the dash indicator for daytime running lights comes on - there isn't any indicator that tells me that the fog lights are on (nothing separate).  My brother has the RST which has a 'blue fog lamp' indicator when his are engaged.  Mis-wired by the dealer?
Blue should be high beams only. The fog light indicator is green.

Sent from my ONEPLUS A6013 using Tapatalk

Share this post


Link to post
Share on other sites

Yes, my mis-statement.  There is a Green Fog light indicator on his RST.  I can see that my truck has the mid-level cluster (as it's an LT), and that the correct template is there that includes the fog light indicator - it just doesn't light up.  If the sunlight hits it just right, it's definitely there.

The dealer should have "flashed" this to enable it?

Share this post


Link to post
Share on other sites
Posted (edited)

The green fog lamp cluster indicator comes on when they are on(downward angled light symbol). The daytime running light indicator will also come on when you turn the fog lights on if it is during the daylight.

Edited by BronzeSierra

Share this post


Link to post
Share on other sites
On 6/4/2019 at 11:08 PM, Moend said:

So the programming procedure didn't required dealer to hook up to it?

Can you provide Programming instructions?

Share this post


Link to post
Share on other sites
37 minutes ago, TNT799 said:

Can you provide Programming instructions?

Dealer has to do it. 

Share this post


Link to post
Share on other sites
Just now, Method2Madness said:

Dealer has to do it. 

Truck is a week old and Fog lights dont work, just trying to get them up and running before appointment 

Share this post


Link to post
Share on other sites
Posted (edited)

Yup, dealer has to enable them. Make sure you have the GM part number & serial number(label) from the box for the dealer. GM was being real sticklers with my dealer, and wouldn't give them the ability to flash the truck without s/n, had to reschedule. Must be getting real protective to copyright infringement.

 

You'll need to aim them once they are working. Mine were pointing at the ground. Phillips screw on the bottom back dial them in. For reference, measure the center height of the fog light to the ground and put some tape on a wall at that same height. The truck should be 25' from the wall to align.

Edited by BronzeSierra
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

I'm getting ready to do this in a few days.  I had a quick look and the fuse for the fog lights is already there.  Does anyone know if that means I just need to plug the lights into the harness our do I still have to mess with the underside of the fuse box ( step 18-25)?

Share this post


Link to post
Share on other sites
On 12/8/2019 at 8:53 PM, hamadybrother said:

I just had the kit installed on my 2019 1500 LT by my local dealer.  The one thing that is bothering me is that when I engage the Fog Lamps the dash indicator for daytime running lights comes on - there isn't any indicator that tells me that the fog lights are on (nothing separate).  My brother has the RST which has a 'blue fog lamp' indicator when his are engaged.  Mis-wired by the dealer?

I had mine done yesterday and seem to be having the exact same issue, there is no indication on the dash to show that they are on, also anyone know if they have any form of adjustment they seem a little low for my taste!

Share this post


Link to post
Share on other sites
1 hour ago, Comscan said:

I had mine done yesterday and seem to be having the exact same issue, there is no indication on the dash to show that they are on, also anyone know if they have any form of adjustment they seem a little low for my taste!

I don’t understand why this is such a problem. When I had mine done the dealer got the dash light to illuminate but not the fog lights themselves. They had to keep it for almost 2 days before they could figure it out. 
 

They told me they needed to install a jumper as part of programming. Whether this is right or not, who knows. May be a suggestion those with issues can make. 

Share this post


Link to post
Share on other sites

https://www.bajadesigns.com/Products/Chevy-Silverado-2019-Fog-Pocket-Mount-Kits.asp

 

Here is another option: Combined 6,300 lumen's with brackets, has wire plug adapters to plug into factory harness, otherwise will need to install a switch. $415 if you call they will pretty much give you a 10% discount if you ask!

Edited by Trvlngnrs
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.