Jump to content

Blanz

AC crapped out, Transmission shudder UPDATE_2

Recommended Posts

Posted (edited)

UPDATE: Link for the transmission shudder issue from GM techlink publication. 

https://gm-techlink.com/?p=11127

 

Well its been only four months and 2,300 miles and I'm already at the dealership service department with two major issues.

1) AC stopped blowing cold air a few days ago, WTF!

2) I've have the infamous 8-speed transmission shudder from takeoff to second gear since day one.

 

Here's the news I got from the service department today:

The AC system is leaking at the evaporator and the console and the entire dash will have to be removed to replace the evaporator coil. 

For the transmission issue, they have a TSB that has them flushing out the transmission and Torque Converter and replacing with a Mobil 1 product (was hoping for a software update but no luck there).

 

Best part (sarcasm here) is they have asked me to take back possession of the truck until July 9th before they can get to both issues!

I cannot imagine the amount of broken plastic clips I'm going to wind up with once they get the dash back in. 

 

Really GM!!!

Oh my ache'n ass!

More to follow...

Bill.

 

Edited by Blanz
  • Sad 1

Share this post


Link to post
Share on other sites

Bring on the creaks and rattles 

  • Haha 1

Share this post


Link to post
Share on other sites

Wow, sorry to hear that Bill.  That's crazy.. Can't you leave truck and get a loaner? Tell them you need A/C. A good service dept. Would do that.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

That's terrible.  Especially on a brand-new truck!  Apparently, GM has no quality assurance methods now whatsoever, except to pump out vehicles as fast as they can and let us beta-test it for them.  Best of luck on the repairs.  

 

 

Edited by MaverickZ71

Share this post


Link to post
Share on other sites
32 minutes ago, MaverickZ71 said:

That's terrible.  Especially on a brand-new truck!  Apparently, GM has no quality assurance methods now whatsoever, except to pump out vehicles as fast as they can and let us beta-test it for them.  Best of luck on the repairs.  

 

 

Beta test would mean that when we find the problems they would fix them, let's face it this ac problem goes all the way back to the 2014 model years and the 8 speed trans shudder to the 2016 model year. Safe to say they will never fix these issues and everyone here will more then likely eventually have to deal with it. My best advice i can give is if you plan to keep this truck past 3 years and own it, you would be a fool to not buy an extended warranty with what these things cost to fix today.

  • Like 1

Share this post


Link to post
Share on other sites
43 minutes ago, bshort said:

Bring on the creaks and rattles 

+2 on that

Share this post


Link to post
Share on other sites

2-3x my AC has not blown cold when I start the truck. (I have an RST just like you, OP). However, it always starts cooling whenever I turn the AC off, then back on, and after I start driving the truck. No major issues yet, thankfully. 

 

I'm closing in on 3000 miles, and my A8 has really tamed a LOT. I did have a super hard shift from 1-2 after reversing out of a parking spot 10 days ago. Otherwise, the shifting has gotten a lot better. 

 

I'm about to go in for my first oil change at 3K, so I am going to have them do the torque converter flush via the TSB on the A8, since I'll be in there for it. Otherwise, I'm pretty happy and many of the little issues I once noticed have either gone away or I stopped noticing them. 

Share this post


Link to post
Share on other sites

Trade it for a 2020 10 speeed with engine of choice and gtfo out of that 8😂

Share this post


Link to post
Share on other sites

My Lt has had the shudder too since new, anyone got a copy of that TSB to take to my dealer? I know it’s a crap shoot but figure I may try it. 

 

6.2 10 speed looks better and better:/

 

 

Share this post


Link to post
Share on other sites

should of bought a Toyota....

Share this post


Link to post
Share on other sites

So they want yo to drive in the summer months in your 'New" truck without Air Conditioning?  I wonder if they would do that.  Sorry to hear.  Unfortunately the bad dealers reflect on GM as a whole.  Manufacturers all need to be more focused on their dealers service departments quality.  Problem is they always take the dealers side. If you call any of them they always say they have to stand with the dealers decision. 

  • Like 2

Share this post


Link to post
Share on other sites

UPDATE#2:

Stopped by the dealership shop and here is what my 2019 Silverado RST with 2,300 miles looks like when your replacing a defective Evaporator coil!

He is only 80% in, as the cross-beam support still needs to be removed before the HVAC box can come out. 

Hope for everybody else sake that this is not a systemic issue from the HVAC supplier. Maybe I'm the one in a million, should have played the lottery instead.  

So much for a new truck!!!

Bill.

 

 

2019-07-12 13.46.31.jpg

Share this post


Link to post
Share on other sites

Holy Crap! :puke:

Share this post


Link to post
Share on other sites

Yet here I was stressing about someone pulling out my seats to install Katzkin leather..... :sigh:

 

That sucks...

  • Like 1

Share this post


Link to post
Share on other sites

Once you get close to 30 days out of service, that is lemon law territory.

Sent from my Pixel 2 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By B_Faja
      Desperate for help! Long-time lurker...
       
      I have a '15 Sierra 5.3L with some A/C problems and I can't take the heat! Last summer it wouldn't hold any refrigerant and I didn't fix it right away because I would be gone overseas for 9 months. When I got back, I replaced the infamous condenser that displayed huge amounts of leakage in the same upper right corner. Pulled a vacuum, charged it, PAG oil, etc... it worked perfectly for about 5 months. NOW.... out of nowhere, it's blowing hot air again. I hooked up gauges and initially before doing anything else it showed 100PSI on the low and 150PSI on the high with the compressor refusing to engage. I've replaced the pressure sensor hoping for a cheap fix to no success. Pulled a vacuum (vacuum held for 15 minutes) and attempted to refill, but the compressor refuses to engage. Upon starting the engine the clutch face looks like it is engaging and stops after a few seconds. With the A/C on, the clutch face IS magnetized and seems like it is attempting to engage spinning slowly and making half turns every so often. It doesn't make any weird noises and is free spinning while "engaged". I have read about trying to jump the clutch coil directly with battery power to see if it engages, but I don't know if there is an easier way (i.e. relay) than reaching down to the harness on the compressor.
       
      Do I need a new compressor? Or a new clutch? Or can someone smarter than me tell me what I'm doing wrong haha
    • By JACOB1557
      Hello everyone. I'm new to the forum. But I came here because I know I can get good info from this site. So let's get to it. I have a 1990 Chevy C1500. It didn't come with A/C. It's getting hot out. I know it's possible to add A/C. I just don't know where to start. I also know that there are under dash units that will not fit my truck. I also know that auto A/C shops can get kits for specific vehicles, however I can't find one for my exact year, make, and model anywhere. Would anyone be able to put me in the right direction for one of these kits or help me with my problem? Thanks so much, everyone. 

    • By Reedsters
      The a/c on/off and blower position display on the mylink screen started rapidly flashing on and off. The air won’t turn on, it just acts as though it’s turning off and on very fast but on screen only. What would cause this? Any ideas what it might be? Thanks. (See video)
      F9520B0C-50EF-4173-825C-AD7A41320960.MOV
    • By Kovah
      My 2004 Silverado 1500 AC is not blowing out of the top vents, it only blows from bottom.  I took it to get diagnosed and asked for name and part number but when I looked online I couldn't find it. He said he it was called a "control head' part number 599-009. What can I do to fix this?
    • By Devin.chevy
      Not sure if I'm posting this in the right thread but mabey y'all can help me. I recently bought a 08' Silverado from a guy that had it since he bought it brand new and the last two years he had it he had to press the recerculate button to get cold air because the fresh air came out warm , any ideas?
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    208,523
    Total Topics
    2,233,183
    Total Posts
  • Member Statistics

    177,973
    Total Members
    8,960
    Most Online
    Kjpfam21
    Newest Member
    Kjpfam21
    Joined
  • Who's Online   28 Members, 0 Anonymous, 278 Guests (See full list)

×

Important Information

By using this site, you agree to our Terms of Use.