Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Unhooked my trailer and cannot clear this message.  Cycled the truck off/on, hit the steering wheel button.  Nothing.  Any ideas?

20190815_173227.jpg

Share this post


Link to post
Share on other sites
19 minutes ago, teyaroch said:

Unhooked my trailer and cannot clear this message.  Cycled the truck off/on, hit the steering wheel button.  Nothing.  Any ideas?

20190815_173227.jpg

No ideas but I like your heading!! “Got my DIC stuck” Lmao

 

hope it all works out for you

  • Like 2

Share this post


Link to post
Share on other sites
14 minutes ago, Eds240z06 said:

No ideas but I like your heading!! “Got my DIC stuck” Lmao

 

hope it all works out for you

I agree, not going to be any help with the truck,

 

But best post title in a while!!!!

Share this post


Link to post
Share on other sites
37 minutes ago, teyaroch said:

Unhooked my trailer and cannot clear this message.  Cycled the truck off/on, hit the steering wheel button.  Nothing.  Any ideas?

20190815_173227.jpg

Maybe pull the fuse for the plug, let it sit for a few minutes then plug it back in.

Share this post


Link to post
Share on other sites

Pull the battery connection. Take a video of what it is doing so that if it happens again you can bring it to the dealer.

Share this post


Link to post
Share on other sites

Probably needed to lube the slot a bit.  

  • Haha 2

Share this post


Link to post
Share on other sites

Damn. I needed this! Great laugh. I did not even see the obvious until the second post. Best title ever. 

 

I also suggest taking the battery cable off. 

Share this post


Link to post
Share on other sites

Haha, good. Well, I was parked and restarted twice and nothing happened.  Then I put it in drive.  When I moved ahead it shut off the message.  Weird glitch.  Thanks for the ideas!

Share this post


Link to post
Share on other sites

Going to use my first post just to say great job with the title, glad you worked it out.  Hi to everybody btw, bought a used F150 XLT for the first truck, a year later it was plagued with the cam phaser problem so I'm now a proud owner of a 19 LTZ Z71, first chevy vehicle.  

Share this post


Link to post
Share on other sites
22 minutes ago, ChinkySuperman said:

Going to use my first post just to say great job with the title, glad you worked it out.  Hi to everybody btw, bought a used F150 XLT for the first truck, a year later it was plagued with the cam phaser problem so I'm now a proud owner of a 19 LTZ Z71, first chevy vehicle.  

👏

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.