Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Posted (edited)

Hi! In April, my Yukon was throwing codes P0172 P0175. Local GMC dealer in Louisiana "fixed", by replacing some sensor. Traveled to PA, codes came back on. Local GMC dealer fixed by replacing BCM, body control module in June. Now my check engine light is back on! Power train Warranty ran out 2-3 weeks ago. Also had extended warranty, which also ran out at 5 years, which was Sept. Code onstar says its throwing now is P0430, all of the codes from I can find are related to exhaust system. My question is are these 3 codes related??? Could this be something they will have to fix under warranty, given it's related and has been worked on several times? 

If not, what does this mean? Catalytic converter bad? Help! My husband is being laid off in the next week. So, obviously finances are tight. Yes, obviously itll be fixed regardless, just trying to plan and cut back elsewhere if needed. This has been a great vehicle! As luck has it, trouble starts when warranty runs out. 

 

Really wanting to trade, but waiting on new body

 

Adding mileage if matters, 91K

Edited by KNJ
Added mileage

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Jake Brown
      I drive a little less than 50 miles a day back and forth to work. My odometer was 80,0** yesterday now its showing 81,157. Really dont know what to do about it. Has anyone else had this problem? Really dont want to wake up to a million mile truck tomorrow.
    • By Txloanstar
      Hope this helps anyone that runs into this. My original battery died and I changed it out yesterday. After the change my AC was not operating correctly. I surfed the forums and found all sorts of fixes like pulling fuses and disconnecting/reconnecting the battery. None worked. I then notice that the outside temp on the intellilink screen is showing 36 degrees. Figuring it reset to Celsius (I’m in Texas so that is a logical centigrade reading for us) I checked settings and found it was set to F.
       
      Buried in a forum about calibrating the temp gauge I found a GM service bulletin that says after a battery dies you need to drive the car at least 5 minutes over 20 mph for the temp gauge to calibrate; or let the car sit off for 8 hours. I drove the car down the highway and this worked like a charm.
       
      When the outside temp is showing 36 degrees, it is basically telling the ac compressor not to come on and sending heat to the car. Not a lot of fun in 95+ heat in Texas. 
       
      On a side note why why is there no documentation that this is the norm?  I called the dealer to have a girl laugh at me and tell me the car “has” to have a lot of things reset after a battery swap...and they want $155. Which was basically corrected with 5 minutes of driving. 
    • By Gorehamj
      John Goreham
      Contributing Writer, GM-Trucks.com
      9-11-2019
       
      General Motors has announced that NHTSA is mandating a safety recall for the following vehicles:
      2014-2018 Chevrolet Silverado and GMC Sierra Pickups (1500 / 2500 / 3500) 2015-2018 Chevrolet Suburban, Tahoe, GMC Yukon vehicles  2015-2017 Cadillac Escalade  
      NHTSA reports that the amount of vacuum created by the vacuum pump may decrease over time. The group says that as the vacuum level drops, the brake assist decreases, and that this increasing braking effort, extending the distance required to stop the vehicle, thereby increasing the risk of a crash. This new recall covers 3.4 million vehicles. 
       
      The Problem: The brake pump uses engine oil to lubricate itself. If the pump becomes clogged with engine oil sludge the units ability to create vaccum is diminished over time. As a result, braking force and ability also drops. The issue is usually accompanied by a "Service Brake Assist" warning message in the dash. 
       
      The Fix: GM will reprogram the computer that controls the secondary brake assist pump. The secondary pump will now activate at lower speeds and different situations quicker to compensate for any lost output from the main pump. Since the pumps are not failing, GM has decided not to replace them.
       
      GM's number for this recall is N192268490. In compliance with federal law, GM will notify owners, typically by snail mail. GM says that its dealers will reprogram the Electronic Brake Control Module. However, GM has not yet provided a notification schedule. Owners may contact Chevrolet customer service at 1-800-630-2438, Cadillac customer service at 1-800-458-8006 or GMC customer service at 1-800-462-8782.
       
      If you own one of these vehicles and wish to check to see if your vehicle is included (or not) you can do so at this link immediately.
       
      As with every safety recall, customers will not be charged by GM for the needed repairs or modifications. 
       
      NHTSA's public information on this issue indicates that many accidents have been reported to NHTSA including some with injuries. This recall is the result of a NHTSA investigation that lasted nearly a year. In its investigation report, NHTSA noted the following details about the problem:
       
       
    • By Palmeroj
      1996 GMC Suburban K2500 7.4 check engine light goes on for a few days, then off, then back on again. I put the OBD and it shows code P0135, Oxygen sensor bank 1 sensor 1. If I'm not mistaken, this is the upstream sensor on the driver's side.
       
      I did a web search and came up with a lot of hits, some sensors are labeled as "heated sensor", some are not. I have a few questions.
       
      1. Should these be replaced in pairs, both upstream and downstream?
      2. Does anyone have a part number, or link to the correct sensors.
       
      Thanks.
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    211,909
    Total Topics
    2,272,220
    Total Posts
  • Member Statistics

    185,308
    Total Members
    8,960
    Most Online
    Karren John
    Newest Member
    Karren John
    Joined
  • Who's Online   21 Members, 0 Anonymous, 630 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.