Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

cmat1120

Neutral not being detected

Recommended Posts

Hello, I have a 2002 silverado 1500 that I'm having a strange issue on. The most obvious symptom I'm experiencing is that the dash gear indicator disappears when I shift into neutral. It shows up for everything else just fine while the engine is running, but only displays park when the motor isn't running but key is on(I'm pretty sure it's supposed to indicate all the gears normally even when motor isn't running as long as key is on). That last sentence leads me to believe that the transmissions internal pressure switches are relaying the gears just fine, but the transmission range is not. I replaced the neutral safety switch(fixed my reverse lights coming on in neutral) and I've tested the transmission range outputs all the way at the PCM and I got what I expected. So basically everything seems good until it hits the PCM, after that I'm not sure what happens and I'm not sure how to test. I tried calling my local dealer to see if they would hook up a scanner to see what gear the pcm thinks I'm in, but they said they can't do that(which doesn't sound right). I thought I'd post online to see if anyone had any suggestions.

 

The one other indication I have that it's not detecting at least neutral is that the truck won't even try to shift into 4lo. It goes between 4hi and 2hi no problem as there's no need for neutral there, but it doesn't even attempt to go to 4lo. I replaced the encoder motor with a new caldone motor before realizing it was probably more related to the neutral thing.

 

Other things I've tested: I have good power and a good ground at neutral safety switch.

Truck starts in park and neutral as it should.

 

I apologize if my post is a little scatterbrained, I've been working on this for a week now trying to figure it out and I think I'm going a little crazy.(I spentan hour trying to track down a discontinuity that turned out to actually just be me holding the PCM connector upside down)

 

Share this post


Link to post
Share on other sites

Sounds like the dealer knows you'll be annoyed because he will charge you $100+ just to hook up the scanner and tell you what it's reading.

 

I would suggest getting an online subscription to the full-service manual for your truck and a good scanner, such as Autogenuity w gm enhancement (software for windows + a usb - odbii cable) that reads codes from all the computers on your truck, displays/records live data, does a bunch of diagnostic and testing procedures.

 

Not cheap, but you shouldn't have to throw so many parts at the truck to fix things...

Share this post


Link to post
Share on other sites

Just thought I'd post an update. Charging the battery fixed the issue at this point. I'm honestly not positive if the dash indicated any gears at all before replacing the NSS and encoder motor, but after replacing both of those and then charging the battery up all the way(it was at 11.9 when I took it off) everything works 100% including 4lo. The NSS was necessary anyways and the encoder motor I took off was very likely 230k miles old so those were needed anyways. Just goes to show its always worth checking the simple stuff first.

 

Also thanks for telling me about the autogenuity thing. I probably will buy either that or a tech 2( I don't plan on buying a 2014+ silverado anytime soon) scanner just for future issues.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.