Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

I've had my 2019 Silverado RST Double-cab about 4 months.  I use the USB port and Apple maps regularly to get me where I'm going.  The USB port worked fine this morning, and this evening when I got in the truck to go home, no dice.  Nothing.  The phone will still charge from the rear seat charger, and I think I got the blue tooth going, but no charge from the front seat USB port and no Apple Carplay.  Is there a setting I need to find somewhere?  Is there a dedicated fuse for this?  Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By skyline2413
      *************Radio and HMI sold. Cluster was returned to vendor on eBay.*************
      Hey guys, If anyone is interested, I have a radio and 2.5 HMI I purchased from White Auto and Media Services (WAMS) on August 20th for my 2015.5 1500. It was programmed to my VIN, but in the short time since, my truck got hit and I am no longer in need of them. You would need to ship them to get reprogrammed, which is just $100. I’d like to get something for them. For both parts, $300 plus shipping (I’ll confirm what they charge me to ship them back to me). That’s half the price they charge for asking them to source both components for you. Send me a message or reply and we can work out the details. 
       
      I definitely would trust WAMS for any radio/HMI and cluster upgrades. Their service is fantastic and turn around time is great. 


    • By Frankielozano214
      Selling this as a set or separately let me know what u need, send me a PM will sell together for  right price plus shipping 
      price is next to item if you prefer to buy separately 
      •hmi2.5 with navi-225$ Sold
      •Bose Radio Module-75$ 
      •8in screen with digital controls-125$
      •Red Denali Cluster-275$ Sold
       
       
       





    • By Slow_5.3
      Hi I’m new here, and I was just wondering if you can swap the radio from a 2017 Silverado with Apple CarPlay to my 2015 Sierra that doesn’t have Apple CarPlay? Would CarPlay work or no?
    • By tommy2wheels
      Bought truck in July and had infotainment issues from the start, the screen is black but backlit, the screen displays but will not work with touch, sometimes the hard buttons will move it other times not. The climate control changes sometimes will display, loss of back up markers, sometimes loss of back up camera with a screen error of connection lost, audio is lost sometimes, CarPlay won't always sync and I'm sure other things I am forgetting as well. Only has issues on start up, never going down the road so I don't think its a lose or broken wire, improper pin alignment. Sometimes it works, sometimes it doesn't. Its so random how long it doesn't work for, not very often stopping and starting will fix it, sometimes its a day or more before it works again. 
       
      The radio was replaced at dealer, 2 weeks later it starts acting up again, dealer worked with TAC(?) to determine they were replacing the radio again, strike forced it to be delayed but eventually replaced, less than 2 weeks later same thing, then they replaced the screen/digitizer, I went to pick it up, started truck and screen was blank. Now after having my truck for about 3 weeks (this time) GM wants to try replacing the bus cable from radio to screen but they want me to not connect my iPhone as they think it could be causing the issue, even with video documentation showing my phone not plugged in and blue tooth disabled and 2 times with dealership mechanics seeing my phone in my pocket. 
       
      My questions are -  
      1) anyone else have this issue? what was the fix?
      2) What kind of compensation should I be seeking for 5, almost 6 months now of it not working right, repeated trips to dealership, long waits in lounge, being told it was fixed only to show up and it's not? I have kept extensive records for every time it happens, videos of probably half of the instances. 
       
    • By Todd Richert
      I have owned many GMC trucks so I have delt with the radio issues in the past but this one is driving me crazy. Only when apple car play is active and connected to my phone the radio screen will go black and will reboot at random times. Today when I made a phone call, 30 seconds into the call it goes dead, about 20 seconds later it reboots and phone call is still there.  My cluster is not affected, I have changed phone cords. Using iPhone 11 Pro Max with latest update.  Any help would be appreciated. Thank you 
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    230,447
    Total Topics
    2,461,671
    Total Posts
  • Member Statistics

    229,013
    Total Members
    8,960
    Most Online
    Najar45
    Newest Member
    Najar45
    Joined
  • Who's Online   10 Members, 0 Anonymous, 1,192 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.