Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Jswaze88

"Brake system failure" "Service ESC" LEMON?

Recommended Posts

Just picked mine up after the first service.  I told them I wanted to wait and do the recalls later.  They said to bring it back whenever I was ready.  I did not have to sign anything.

Share this post


Link to post
Share on other sites
9 hours ago, Dymondan said:

Ok just dropped it at the dealer. We’ll see what they say. My CEL was still on so that was good for them to pull codes. I had to raise a little hell to get them to give me a loaner later today if I need it. Haven’t had the mushy brakes since but I’m avoiding using the app until this gets resolved. The shuttle guy mentioned that a lot of folks have had this issue in the past week. Fingers crossed GM gets a fix for it soon!

 

OK they called from the dealer.  Just like they've been telling all you guys it's a software issue related to using the OnStar App.  GM is working on it and they are currently re-calibrating my truck and clearing the codes.  If it holds for 30 mins without throwing any new codes they will release the truck to me, otherwise they'll give me a loaner.  Heading there in a few mins, hopefully I can take her home.  He said not to use the app at all until they are notified by GM that the issue has been resolved.

Share this post


Link to post
Share on other sites

So if we have the recall done, and don’t use the app to start it, it should be fine?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
26 minutes ago, Dymondan said:

OK they called from the dealer.  Just like they've been telling all you guys it's a software issue related to using the OnStar App.  GM is working on it and they are currently re-calibrating my truck and clearing the codes.  If it holds for 30 mins without throwing any new codes they will release the truck to me, otherwise they'll give me a loaner.  Heading there in a few mins, hopefully I can take her home.  He said not to use the app at all until they are notified by GM that the issue has been resolved

21 minutes ago, hotrodz37 said:

So if we have the recall done, and don’t use the app to start it, it should be fine?


Sent from my iPhone using Tapatalk

That’s what they’re telling me. And, When GM has an official recall or service bulletin to address this issue, I’ll have to bring the truck back in to have the module updated. 

Share this post


Link to post
Share on other sites

Mine was “fixed” 2 weeks ago.  All has been perfect since then, complete with remote start via the app, and tonight it came back.  
 

restarted the truck 4 times and good except for CEL. 
 

anyone know if there is an issue with driving with the CEL on until a fix is there?

Share this post


Link to post
Share on other sites

Just got a call from dealer that my truck is FUBAR until the next software is released.  They will not give me the truck back because my ABS is currently comprised.  I am in a loaner for 2-more weeks.   I would advise anyone with appointments to get anything software related done, to wait.  

Share this post


Link to post
Share on other sites

I emailed my service advisor last night and she emailed me this morning telling me to bring it in. Here is my question, I now know the trick to limp along with the CEL on.  If that is working out and I have my brakes back, should I just wait out a software update or bring it in?  
 

Best case scenario I bring it in and they claim to fix it only for the issue to recreate in a week or so.  it’s abundantly clear that Chevy has no idea how to fix the software and until they do everything else is a bandaid.   

Share this post


Link to post
Share on other sites
I emailed my service advisor last night and she emailed me this morning telling me to bring it in. Here is my question, I now know the trick to limp along with the CEL on.  If that is working out and I have my brakes back, should I just wait out a software update or bring it in?  
 
Best case scenario I bring it in and they claim to fix it only for the issue to recreate in a week or so.  it’s abundantly clear that Chevy has no idea how to fix the software and until they do everything else is a bandaid.   


I’m just driving mine with the CEL on cause I love my truck aside from this issue. Also my dealer now seems to be ignoring my calls. Had a loaner 2018 over the holidays and didn’t like it.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
15 hours ago, JAshworth03 said:

Mine was “fixed” 2 weeks ago.  All has been perfect since then, complete with remote start via the app, and tonight it came back.  
 

restarted the truck 4 times and good except for CEL. 
 

anyone know if there is an issue with driving with the CEL on until a fix is there?

The CEL informs you one of the Modules are in error. Some errors will prevent operation of the vehicle or the user will notice a change in driveability. Just find out what the CEL is telling you just in case continued operation will harm you or the vehicle. Stop at Auto Zone etc, and let them tell you what the codes are.

Share this post


Link to post
Share on other sites

Just called On Star. They have no knowledge as of this time of the issue. Asked me if I wanted to go ahead and try using the app again...Politely declined because I didn't want to go get CEL cleared from the dealer again. They had no idea what the problem was or when it's going to be fixed. I'll wait a few weeks and if its not fixed I'll cancel On Star and try again after its fixed. Hopefully that is the issue and it doesn't happen if I remote start with my key fob. 

Share this post


Link to post
Share on other sites
 

I have (sitting at the dealership) a 2020 GMC AT4 just got on 11/20/19, had to take it in on 12/13/19 as i got the ESC error code and check engine light that wouldn't go off, dealer called a week later and stated that GM told them to replace the brake module, so they get the module but apparently need to order new bolts to put it in as they cannot use the old ones, so another 2 weeks later they contact me and say all parts are in but they cannot get the module to communicate correctly with my computer system and there was a software update just released that day (1/3/20) and they need my truck for 5 more days and i might get my truck back this week. I also asked if they would get the battery cable recall issue addressed and he said they should. So as of this Friday it will have been a month that i don't have my brand new at4, does this seem ridiculous to anybody else out there?? anybody experiencing a similar issue???

I have had the same issue on my brand new 2019 LTZ still driving the loaner truck after 3 weeks. Never had any problems till they did the brake software update and i only have 3100 miles on it. Mine did it twice after the update both times i started with my phone.

Share this post


Link to post
Share on other sites

I just had this happen two nights ago and was able to get them to reset to just a CEL after a bit of messing around. Dealer pulled codes and opened a case now waiting for a new update to be issued from GM. I just had the brake recall done and module updated of course their is no ETA on the update...7,200 miles


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Add me to the list. After the Brake recall. Started the truck via fob and inside the truck itself, no problems. Then same day, remote start via the MyChevy app and Service Brake messages came up. My dealer asked me if I drained the battery somehow the night before that might have caused the errors. I didn’t.

Good to find this thread. Following.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Will GM pay my monthly payment if my truck spends the month at the dealership???

Share this post


Link to post
Share on other sites

It's not unheard of. 

When the dealer had my truck for three weeks, I had a loaner...so I didn't even bother to ask.

I think there are other's on this forum that have had either dealer / GM make their monthly payment.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.