Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

2020 Silverado Trail Boss Infotainment screen freezes/goes black


Recommended Posts

I Have ~6,000 miles on my 2020 Silverado Trail Boss and have had an intermittent issue with my infotainment screen. Occasionally when I start the truck, The screen is illuminated but nothing is working or showing. I try several things like pressing and holding the power button, turning the truck off and back on, nothing works. The screen stays like this even when the truck is turned off. When I put it in reverse, the back-up camera comes on but there are no lines on the screen. When I put it back into drive or park, the screen goes black again. I drove 45 minutes to work and the screen stayed this way the whole time. When I started the truck to come home after work, everything was back to normal.

 

Anyone have this happen to them?IMG_4304.thumb.JPG.11ab3e26fe8c15e676510a1c7963fdc9.JPGIMG_4299.thumb.JPG.f92affdd58a97efe008bb60c4ad56591.JPG

Link to comment
Share on other sites

Not quite that but my phone iPhone Xr when plugged in for car play doesn’t play music though it says it’s playing, stuttering screen and general slow/no response from the screen.  Playing music through Bluetooth is fine.  Took it in and he tech plugged in his 6s and it played no problem.  
 

Mind you my iPhone had zero issue with my 2018 Sierra and still works fine in my wife’s ‘17 Malibu.

Link to comment
Share on other sites

My radio does the same thing here and there where my phone says it’s playing but nothing is coming out to radio. I have had two trucks with non Bose and 2 with the Bose  and the Bose runs flawlessly but both trucks without Bose must have some software programming that gets stuck here and there! I noticed that if you switch apps on your phone like going from pandora to YouTube if you shut down completely before opening the other it limits it getting stuck!

Link to comment
Share on other sites

I have had this happen once, but also had it where it just decided to play over the air radio and either satellite radio or something from my phone at the same time and it wouldn't let me change it. 

 

Also had numerous issues with it just deciding it wont let me have any volume or changes the volume settings over bluetooth randomly when I get in the truck. 

 

Usually restarting the truck will fix it. For the first two issues, it took a couple hours foe the first and the second it was working again the next day. Lots of little issues like this and next to impossible for a dealer to fix them. 

Link to comment
Share on other sites

  • 3 weeks later...

This may help you guys.

 

have had mine for a week. 2020 GMC 2500HD AT4 Duramax. I couldn’t figure out why between short key cycles I would lose all audio and everything in the IC screen expect for the main info page with speed and trip etc. nav, audio, phone all blank. Center stack screen shows me that the Sirius radio is on and the songs change but I have zero audio, no audio for Bluetooth or apple car play either. I tried key cycles, opening and closing door etc....

 

WELL....its apple car play. On these short key cycles I would leave my iPhone plugged into the USB port. Drop my kids off at school and come back out to no audio. Now when I have these quick trips I make sure I unplug my phone and everything functions like it should. It takes 3-5mins for it to reset with truck off and door opened if you do leave it plugged in and this happens to you. I let my dealer know of the issues I was having but plan to call them today and let them I know I figured it out.  Clearly they wouldn’t of had these issues if I dropped it off to be looked at. Maybe this works for you. Good Luck

Link to comment
Share on other sites

1 hour ago, LSPowered65 said:

This may help you guys.

 

have had mine for a week. 2020 GMC 2500HD AT4 Duramax. I couldn’t figure out why between short key cycles I would lose all audio and everything in the IC screen expect for the main info page with speed and trip etc. nav, audio, phone all blank. Center stack screen shows me that the Sirius radio is on and the songs change but I have zero audio, no audio for Bluetooth or apple car play either. I tried key cycles, opening and closing door etc....

 

WELL....its apple car play. On these short key cycles I would leave my iPhone plugged into the USB port. Drop my kids off at school and come back out to no audio. Now when I have these quick trips I make sure I unplug my phone and everything functions like it should. It takes 3-5mins for it to reset with truck off and door opened if you do leave it plugged in and this happens to you. I let my dealer know of the issues I was having but plan to call them today and let them I know I figured it out.  Clearly they wouldn’t of had these issues if I dropped it off to be looked at. Maybe this works for you. Good Luck

I was beginning to believe same thing but dealer said GM asked me to not plug my phone in at all after one of their can't replicate it so its not broken diagnosis',  so I didn't for 2 weeks, no cable, no bluetooth and it still acted up over those 2 weeks. Finally got them to get a GM engineer to be at dealer to check mine out, its been 3 weeks there this time, finally got to look at it and I was told they sent the test results to china. They are waiting to hear back from them to see what to do. Pretty sure after all the replacement parts they swapped out and the troubleshooting over the previous 8 months, this isn't a CarPlay problem. 

Link to comment
Share on other sites

  • 5 months later...

I pulled the infotainment fuse 2 (2020 Silverado 1500 LTZ) waited 30 sec plugged it in booted back up. No idea what root cause is but it did work. I believe in here I saw a host of other issues regarding traction control parking brake etc. Solved this by applying P brake putting in drive and “driving it off” style of release.

Link to comment
Share on other sites

I have had the same issue probably a dozen times in 5k miles. More annoying than anything else. I only use bluetooth, nothing plugged in via cable.

 

I mentioned it during my first oil change, and they updated the software to the latest and greatest, but it has done it twice since it was "updated". I'd have to check and see what version I have.

Link to comment
Share on other sites

  • 7 months later...

I have a 2019 silverado lt. Infotainment system will crash when using apple carplay intermittently but especially when using gps and using the phone. I have most recent updates on info system and iphone 11. I have brought my truck in 4 times. They replaced the radio and it still occurs. Completely unacceptable, extremely dangerous to the driver. Really making me rethink chevys hunk of junk!!!!!!!!

Link to comment
Share on other sites

I have the same issue unfortunately I have a few others in addition to the screen going black. It started with poor audio quality, skipping, poor reception both plugged into phone and bluetooth.  unfortunately it wasn’t just the CarPlay it was doing it with Siri and regular radio as well as my phone calls. I thought is was just needing update. I have been on the phone with OnStar trying to get it resolved, they checked my radio signal, made sure my phone tower location was set to the correct one for my area, they boosted my signal strength over the  air while on onstar call and rebooted the whole radio ota. But unfortunately no matter how many times I ask them to remove the Internet from my free trial they never do and my phone has to be several feet away from my truck in order for me to use it without turning off my Wi-Fi.  Just forget wireless settings on phone? Nope. Somehow it possess it back into functioning??? WTAF?!?!
 

After all of the troubleshooting with technician, he determined that my whole infotainment system needed to be replaced. I have yet to hear from anybody but do you have a case number from a couple weeks ago.

 

This Friday I had a scary moment, I had my cruise set to 62 and my truck just accelerated up to 70 something before I brake checked it down to speed, the screen went black on the infotainment system, and my information centre in the instrument cluster went to trip counter. I had to stop the truck and turn off the ignition in order to reset it to function. Now however every time I drive it it reverts back to trip on the instrument cluster upon start up. 

 

I will be calling my dealer and find out what the hell is going on as this is becoming dangerous. And no I didn’t accidentally press the button up too long on this cruise control,  I  only pressed set by getting to the desired  by pedal and managed to hold set speed a couple hundred feet B4 it crapped the bed. 

 

I had something similar to this happen on a previous vehicle, and that ended up being the main computer module. They told me it was caused by leaving my key fob in my truck while in garage, so I no longer do that. It never once ran away on me though.

 

This is the second strike for this truck. From day one my lane assist did not work and it was found to be a faulty front driver side camera which was replaced.within a week of ownership. however I have tested it after it’s been fixed and I can hit the gravel on the other side of the road before self correcting as there is no indication at times of lane departure. 😱 I sporadically get a seat rumble and I’ve checked my settings, there’s just no rhyme or reason.  My automatic engine shut off is a joke. It starts and stops and starts and stops awaiting at an intersection so badly that people probably think I have turrets of the foot. Now its common practice to turn off upon start up.  Jeebs

E922EDE8-2B8A-41BD-9730-C09B1C510828.jpeg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.