Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

BBE

2020 denali duramax no internet connection??

Recommended Posts

Just got my 2020 denali duramax a few months ago, 8k miles on it so far.  I pay 25 dollars a month for the unlimited data plan, but my data is not working.  The truck is broadcasting it's hot spot.  and I can connect to it's hot spot from my phone, and it works just fine.  But with any data going through the actual dashboard of the truck itself, it doesn't work.  Apps won't download, spotify doesn't work, I cant even see the anything in the "manage plans" under the mygmc app.  This just started all of a sudden out of nowhere a few nights ago at about midnight.

 

I've talked to onstar about it and have tried doing factory reset on the dashboard, and a few other things they had me try.  The said they will have to escalate it to tier 2 offline software support  and I would hear something back within 5 business days.  Kind of frustrating because the legit only reason I bought the 25 dollar unlimited data was to listen to spotify through my truck and not use my phone's data.  So I'm kind of paying everyday for the unlimited data for nothing.

 

Has anyone heard of this or have any ideas what's going on?  Or ideas of things to try?  I can connect to a different wifi hot spot with my truck such as my home wifi and everything works great when I'm on that.

Share this post


Link to post
Share on other sites
Posted (edited)

I have a 2020 2500 LTZ and I am having the same exact problem. Talked to the onstar and they told me the same thing. It has done this before but not for this long. It has been going on for about 2 days. I wish someone would tell me what I am doing wrong?!

Edited by Joshmartinatx
Information needed.

Share this post


Link to post
Share on other sites

Forget the truck's WiFi on your phone, then search and again and connect back to it. That helps sometimes. Don't just disconnect from it, delete it/forget it on phone, then reconnect.

  • Like 1

Share this post


Link to post
Share on other sites
On 2/24/2020 at 6:54 PM, BBE said:

Just got my 2020 denali duramax a few months ago, 8k miles on it so far.  I pay 25 dollars a month for the unlimited data plan, but my data is not working.  The truck is broadcasting it's hot spot.  and I can connect to it's hot spot from my phone, and it works just fine.  But with any data going through the actual dashboard of the truck itself, it doesn't work.  Apps won't download, spotify doesn't work, I cant even see the anything in the "manage plans" under the mygmc app.  This just started all of a sudden out of nowhere a few nights ago at about midnight.

 

I've talked to onstar about it and have tried doing factory reset on the dashboard, and a few other things they had me try.  The said they will have to escalate it to tier 2 offline software support  and I would hear something back within 5 business days.  Kind of frustrating because the legit only reason I bought the 25 dollar unlimited data was to listen to spotify through my truck and not use my phone's data.  So I'm kind of paying everyday for the unlimited data for nothing.

 

Has anyone heard of this or have any ideas what's going on?  Or ideas of things to try?  I can connect to a different wifi hot spot with my truck such as my home wifi and everything works great when I'm on that.

Did you ever get this resolved? I'm having the same issue and cannot enable "Share Hotspot Data" setting in wifi settings

Share this post


Link to post
Share on other sites

I had a similar issue. Could not join the WiFi network. Called OnStar a talked with a tech. Tried numerous attempts to diagnose the issue. Multiple resets etc. He was stumped for a bit as to why he could not resolve the issue. On a whim he decided to have me delete the network from my phone. He then remotely changed the network password and had me join the network using the new password. Bingo! It worked. No issues since. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.