Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

key fob transmitter faulty?


Recommended Posts

I have a 20 Silverado bought June 26th. No tinted windows and I’ve had the remote stop working 3 times now. Dealer has no idea what to do........ thankfully it’s a lease....... I will never get another GM after this, and my uncle worked there for 33 yrs.... very disappointing. I’ve always been a GM guy

Link to comment
Share on other sites

  • 2 months later...

2021 Silverado 2500... Had all windows tinted yesterday and everything worked as normal UNTIL today.. I had the windshield tinted and about an hour later, neither key fobs worked. Had to put the key in the cup holder spot to start the truck. Just now (6hrs later) my key fob is working intermittently. After reading this thread, it has to be related to the tint process. Fingers crossed 

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...
On 12/14/2020 at 11:30 PM, Desmo said:

Same issue here, just had windows tinted, including the windshield. But my gauges, radio and turn signals stopped working too.

Have you had them come back on yet? At 24 hours currently after getting windshield tinted and they have yet to start working again. Neither fob works as well as the tire sensors stopped working. 

Link to comment
Share on other sites

  • 1 month later...

I'm having similar issues, additionally with the "Service Steering Column Lock" DIC message. In reading this thread I don't believe it's the tint, I think it has to do with having the doors open for a prolonged period of time. I had it open, and then tried putting it in ACC after 20 minutes or so. I was working on installing my opt-7 interior LED lighting. I'd expect the tinters to have the doors open prolonged period of time without the key in it as well, so must be a fail safe. 

 

I thought maybe it was from me poking around in the fuse box, but now there seems to be a common theme. I think the anti-theft system just has to wait to be reset. Not sure if theres a faster way to reset it. My key 'works' to unlock the doors, but only by button. Not passively, and i have to put the key under the center seat/console to start it which is real annoying. 

Link to comment
Share on other sites

I’ve changed the battery in one of my fobs twice and it’s dead again. Only seem to get a month out of it before It dies. I figure it’s a bad fob. The dealer changed the battery once under warranty so hopefully they just replace it. They changed the battery in both at the same time as the battery low message was coming up in the other one so hopefully this isn’t a chronic issue. So far the other one has seemed to hold voltage. 

Edited by L8T
Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 4 weeks later...
On 5/18/2020 at 10:41 AM, FirstAscent said:

Thanks, good info. So doesn’t sound like it was one of the antennas then.

I still think it’s somehow related, just not sure how exactly.

Could be a coincidence of course but the only two times was immediately after getting tinted. First time got all windows tinted, 2nd time was just Re-tint of windshield which is why I suspected windshield area.

Currently juat had my windshield tinted 2020 2500hd and now my remote fob no longer detected amd tire monitor system service light is now on, definitely related to windshield tinting 

Link to comment
Share on other sites

1 hour ago, Bjamin14 said:

Currently juat had my windshield tinted 2020 2500hd and now my remote fob no longer detected amd tire monitor system service light is now on, definitely related to windshield tinting 

yeah it's quite odd, and a little annoying. But just know it'll be all good by tomorrow or the next day at the latest. For what it's worth, I haven't had any fob issues since, only for that first 24 hours or so after having it tinted. 

Link to comment
Share on other sites

On 11/19/2020 at 8:03 PM, Jriola83 said:

2021 Silverado 2500... Had all windows tinted yesterday and everything worked as normal UNTIL today.. I had the windshield tinted and about an hour later, neither key fobs worked. Had to put the key in the cup holder spot to start the truck. Just now (6hrs later) my key fob is working intermittently. After reading this thread, it has to be related to the tint process. Fingers crossed 

Did yours get all back to normal? I'm in the waiting game now 

Link to comment
Share on other sites

2 hours ago, FirstAscent said:

yeah it's quite odd, and a little annoying. But just know it'll be all good by tomorrow or the next day at the latest. For what it's worth, I haven't had any fob issues since, only for that first 24 hours or so after having it tinted. 

I'm going to hope your right and all is well tomorrow. At the moment as nice as the tint is I feel like I made a mistake in getting it. I like hearing other have had this and seen it fixed. I just tried to reprogram my smart remotes and still nothing, only on hour 7 at the moment. 

Link to comment
Share on other sites

On 1/5/2021 at 7:10 AM, Jgr2116 said:

Have you had them come back on yet? At 24 hours currently after getting windshield tinted and they have yet to start working again. Neither fob works as well as the tire sensors stopped working. 

Back when this happened to me, I took it to the dealership. It sat there for 3 days until they told me the problem was related to my aftermarket power running boards plugged into the OBD2. Which is total BS, because when I picked it up the running boards were still plugged in and everything was working fine. It just needed to sit and dry out for a few days. Was cold weather here back when I had the windshield tinted.

 

long story short: It just needs to dry out for a day or two, parked in the sun preferably.

 

p.s. sorry for the late response.

Edited by Desmo
Link to comment
Share on other sites

On 5/11/2021 at 7:17 PM, Bjamin14 said:

I'm going to hope your right and all is well tomorrow. At the moment as nice as the tint is I feel like I made a mistake in getting it. I like hearing other have had this and seen it fixed. I just tried to reprogram my smart remotes and still nothing, only on hour 7 at the moment. 

Are you back to normal now?

Link to comment
Share on other sites

So I’ve now had something similar happen. 2021 Denali 3500, we parked at a campsite yesterday and everything was fine. Today neither of our fobs work for remote lock/unlock, but we can use the physical handle buttons on the door, and keyless start does still work with the fob in my pocket. It’s dry and sunny today, and we did not just get any windows tinted!

 

I like the theory that it has to do with the doors being open for a long time. It’s possible I left the doors open last night for a long time while I was unhitching the RV. In any case, I’ll update whether it fixes itself or if I need to take it to a dealer. I just wanted to add that this problem seems to occur without tinting :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.