Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Numerous issues with AT4, is this just how it is?


Recommended Posts

1 hour ago, 1997SierraSLT said:

Just another great reason to go with the Tundra.  Well established and reliable platform.  Oh.....and all the computer controlled stuff actually functions as intended.  

BULL CRAP. 

Link to post
Share on other sites
31 minutes ago, RE1 said:

What’s up with the Tundra? Known Issues?

good luck getting Colossus to provide evidence of any known issues.  He just points you to the Tundra forum.  Not a lot going on over at the Tundra forum.  Folks just really enjoy life and their reliable and functioning as intended vehicles.  

Link to post
Share on other sites

It's a great truck, it's just not as perfect as a few on here make it out to be.  It has it's own issues like all trucks do.  Go visit the forums and you'll see the patterns over there just like we have patterns here with the GM trucks.  Thing is-  I'd probably buy a new Tundra over a new Silverado/Sierrra on the looks alone, I can't stand the new GM twins. 

  • Like 1
Link to post
Share on other sites
I bought a 2019 GMC Sierra AT4 exactly a year ago today. I knew it had lots of tech in it and figured I'd have an issue or two here and there but nothing like this.
 
The first problem I had was my rear window started leaking after the first rain storm.
 
Then I started noticing the paint was really delicate and have had to patch 3 big holes that actually left the bare metal exposed.
 
I had two of the "Brake system failure" warnings but that seemed to be fixed after a software update. The software update broke my lane change system, it was completely off. A computer reset fixed that.
 
When it started getting hot here in Texas, my "Park assistant blocked, see owners manual" warning started appearing. It comes up at least 15-20 times a day, its not just a single message though, it "flickers". The light on the dash flashes sporadically and the on screen message comes and goes. I can't clear it since its continually popping back up. Eventually, it stops and the system is off, it reactivates itself later and does it all over again. The dealer has "reset the computer" that controls it...which did nothing.
 
After that reset I noticed my lane keep assist was going nuts, the indicator icons on the screen would be flashing and the system was turning off and on while the in dash button flashed too.
 
My driver's side window rubber seal(?) that's on the outside of the window frame got sucked up inside the track and couldn't be removed. They had to replace that.
 
The light bezels around the fog lamps lost their finish in a few small spots and one very large section came off exposing the chrome. I bought the AT4 to avoid all of the chrome. The grill is made of the same stuff, its also got so many chips/finish loss that I can't even keep count.
 
The towing app has never once worked properly. I was actually excited about this because I'm a nerd and love the data tracking. I tow 70% of the time so getting to see each trailer's mileage and average MPG was going to be helpful. However, the truck doesn't keep any information on the two trailers for long. At least once a day the trailer mileage resets and the average MPG resets with it. It happens after starting the truck. I can't figure out any rhyme or reason to it. After it does reset, the average mileage is WAY off from reality. I'll drive 100 logged miles by the app with that trailer but it claims I got 0.5 MPG. If I reset the average MPG, it starts tracking the MPGs accurately until it resets itself again. 
 
I know it sounds like I'm just complaining up a storm here but I do love the truck. I'm just highly frustrated with all of the random issues. Even more frustrated that they seem not never fix any of it. This doubles as my work truck and it has 33,600 miles with 1000 engine hours. I'm nearing the end of the manufacturer's warranty and fast! 
 
Has anyone else had these issues and has your dealer resolved them? Are the 20's any better? I've invested a lot of money in this truck by putting work signs on it, a camper shell, clear bra to protect the horrible paint and other small things. I'd hate to trade it so quickly, especially if the next year's model is plagued with issues too. I'm not sure if any of this could fall under the lemon law. Thanks for the advice in advance! 
I had tons of problems with mine as well, I've got numerous posts here detailing them, some of them the same or similar to yours, I finally had enough and traded it in. The dealer tried to fix them, but they were so random was next to impossible.

I'm going to be waiting for either the cybertruck or the new tundra if that ever comes out before I get another truck. I've had a lot of fords and one Chevy and then this GMC, had problems with all of them, so think I'm done with American vehicles until they get their act together, if they ever do.

Sent from my SM-N960U using Tapatalk

  • Like 1
Link to post
Share on other sites
  • 11 months later...

I purchased my AT4 in July 2021 and the check engine light has come on at least 5 different times since I have owned it. GM has replaced the lifters already but that wasn't the problem. It is back in the shop and I think they are just throwing parts at it to try and make it go away. The code is PO300. So it can be any number of things. I tried to talk to the GM at the dealer about swapping it out and no way that was gonna happen unless I pay alot more money. I already paid $5000.00 over MSRP. Now they want another $5000.00. Are you kidding me ? If you go with the lemon law you just get your money back. I think GM should allow me to do an even trade with no more money involved. This truck only has 1850 miles on it. Hopefully this doesn't fall on deaf ears and I get some assistance from someone. John from Ocala, Fl

Link to post
Share on other sites
On 8/21/2021 at 7:26 AM, John Mcrae said:

I purchased my AT4 in July 2021 and the check engine light has come on at least 5 different times since I have owned it. GM has replaced the lifters already but that wasn't the problem. It is back in the shop and I think they are just throwing parts at it to try and make it go away. The code is PO300. So it can be any number of things. I tried to talk to the GM at the dealer about swapping it out and no way that was gonna happen unless I pay alot more money. I already paid $5000.00 over MSRP. Now they want another $5000.00. Are you kidding me ? If you go with the lemon law you just get your money back. I think GM should allow me to do an even trade with no more money involved. This truck only has 1850 miles on it. Hopefully this doesn't fall on deaf ears and I get some assistance from someone. John from Ocala, Fl

 

It's called Inflation and it is here to stay so get use to it, hardly the fault of GM or any car dealership for that matter!

Link to post
Share on other sites

I have a ‘21 11000 miles 6.2 AT4, it's at the dealership as I type this. Push rods and lifters replaced at around 6k miles, now it has the same problem but on oposite side of engine block. Hopefully its the last time it gives me that problem!!!!!

Link to post
Share on other sites
On 9/16/2020 at 5:10 PM, 1997SierraSLT said:

good luck getting Colossus to provide evidence of any known issues.  He just points you to the Tundra forum.  Not a lot going on over at the Tundra forum.  Folks just really enjoy life and their reliable and functioning as intended vehicles.  

Lol yup, guys a goof

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.