Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

I have a 2014 GMC Sierra 1500 5.3 2WD 4 door. Only cold air coming out the vents. So i pulled the glove boxes out so I could see the blend door actuator. I could see the clip wasn't connected to the actuator. So I connected to wire clip to ghe actuator,  and was excited to see if maybe I had found my no heat issue. But, now my teuck won't crank. Turn the key, 1 click and nothing. Ive checked every fuse. All good. I even jumped the starter relay. The truck would turn over but wouldn't start. I'm clueless. 

Link to post
Share on other sites

No battery is fully charged. Also I jumped the starter relay and the starter engaged and turned the truck over but it wouldn't start. I forgot to mention,  for some reason I've got a message on my dash saying stabilitrac disengaged or something like that and steering assist limited. Never had that before now. 

Link to post
Share on other sites

Behind the glove box is the "Brain " of the truck. It has a few plugs going into it. I would make sure you did not dislodge something when you was working on the blend door.

 

Yotaman

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Ricky Bergeron
      2014 sierra 1500 5.3. Blend door actuator wasnt working. I pulled the glove boxes to look at actuator, noticed the wire clip wasn't even connected. Connected the wire clip to the actuator. Went to crank my truck, nothing. And now I have stabilitrac messages on my dash. And one about steering wheel assistant limited or something like that. I've checked all my fuses. They're good. Where do I start??
    • By Chevyowner1234
      I recently got a 2000 chevy s10 LS 4.3 v6 4wd that wont start it cranks no problem everything else works but the security light is always on it never flashes its solid i have tried the relearn procedure 10 times nothing i have scanned it for codes got none i have tried putting a ziptie tip in the passlock plug in and nothing i have found a forum that is having the same issue but they did the resistor and it didnt work for them i dont know what to do to fix it and get it to run i dont have the money and dont want to take it to the dealer so dont suggest that if you know how to fix it please let me know thank you.
    • By DL_98 Sierra
      98 Sierra 1500 5.0 vortec 4x4 SLE ext cab 295xxx
       
      Ill try to keep this short, any help appreciated thx in advance.
       
      My front signal and head light started doing all sorts of weird things head lights flashing with 4 ways, left signal wouldn't work with head lights active. The interior lights where acting weird. Work sometimes. The cluster gage illumination would not turn off. And there was nothing to rear rail or third break lights. Also some funky noises coming from the combo light relay
      So I thought it was ignition harness, cluster,dimmer switch relay. All fuses where fine. But my cig lighter fuse keeps blowing. So I went to junk yard and grabs some parts. So I tested battery and all the grounds I could find and cleaned them. As a changed parts nothing changed. So I was checking the wire harnesses and found that on the wires that runs back to rear of bed on driver side frame was melted up in spot and arking against the frame. So I patched the wires. Now the truck wont start and no lights will work. If you press break peddle the signal light on cluster light up. But not actual signal lights and if u try to turn fan on it turns the signal lights on cluster on and as ur turn it up the lights get brighter and my interior light on driver side floor won't turn off. All fuses seem fine beside the cig fuse. I'm out of guesses. 
       
    • By astolt12
      I have a 2006 4.3 V6 Silverado 1500 WT that as of yesterday will not start. The last time I drove the truck was about a week ago before I parked it at the house. Luckily, its in my driveway so I can work on it. I'm a little confused though on why its not starting.
       
      I have tested the fuel rail pressure and have 59lbs when the fuel pump is engaged and about 59-61lbs when I try to crank the engine. I've tested the spark on all 6 cylinders with an inline spark tester and have posted the video of the number 3 cylinder's test below. They all managed to light the plug up telling me I have some spark, but i dont know how much spark at the plugs. I then checked the high tension line by trying to get it to arc off a ground bolt. It was sending power as i managed to shock myself through rubber handle channel locks, but it wasnt creating a visable arc. I also pulled a few plugs and they all were dry but had a color to them as if they were burning normally.
       
      I also tried shooting some starting fluid directly into the throttle body during crank; that didnt give me anything either.
       
      I'm thinking I have a spark issue; but am confused as I have spark at the plugs. Perhaps its not enough? My battery is dead now from troubleshooting so i'll be waiting for a charger to come in tomorrow. Until then - any suggestions???
       

       
       
    • By Jweave
      I own a 1995 gmc sonoma and it left me sit earlier today. After working on it for awhile I discovered a few problems. The motor had no spark or fuel, I figured out the coil was bad and now it has spark and it starts on starting fluid but the tbi injectors aren't spraying. The fuel pump does prime but we aren't sure of how much pressure it's building. We put in new injectors and cleaned the entire throttle body and fuel is making it to the injectors but the injectors don't fire. Any ideas? Do the injectors require the 12 psi of fuel pressure in order to fire or is there another problem? 
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    231,004
    Total Topics
    2,466,248
    Total Posts
  • Member Statistics

    231,501
    Total Members
    8,960
    Most Online
    DerekRST
    Newest Member
    DerekRST
    Joined
  • Who's Online   84 Members, 0 Anonymous, 3,294 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.