Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Carplay changes from SiriusXM station on startup


Recommended Posts

Every time I startup my truck, it automatically connects wirelessly to my phone with CarPlay and starts playing music from my iPhone. 

I'd rather have it remain on the SiriusXM station that I was last listening to when I last turned off the truck.  I have to go out of CarPlay screen to Audio and choose SiriusXM and then go back to CarPlay screen.

 

Has anyone else figured out this problem?  I tried looking at CarPlay settings on my iPhone, there are many options.

 

 

Link to post
Share on other sites

If I'm listening to Sirius XM when I shut my truck off, the next time I start it up it goes to FM them a couple seconds later it says loading XM then it finally goes back to XM. And I have the latest updates.

Link to post
Share on other sites
13 hours ago, steelcity said:

If I'm listening to Sirius XM when I shut my truck off, the next time I start it up it goes to FM them a couple seconds later it says loading XM then it finally goes back to XM. And I have the latest updates.

My truck does this as well. I couldn't figure it out till the other day it took longer than a few seconds to switch. Best I can tell is that if you set up a profile in your radio the radio does not start up in that profile. So you hear the default (no profile) radio (whatever it is set to) till the system loads your profile and starts playing from the stations you have programmed in. I got in my truck the other day and it was playing something different again. I started looking at the station settings and everything had changed I was like WTH. Then a few seconds later my profile loaded and everything was as I had set it.

Link to post
Share on other sites

Not sure about Apple, but Android Auto has a setting in the phone app to select if you want to "automatically resume media on reconnect".  Until I found that setting I was seeing the same behavior you are describing.  I turned it off and now the truck restarts with the same station I left it on.

 

I would suggest looking at the various settings in your phone app, it may not be a truck issue.

Link to post
Share on other sites
6 hours ago, 2016 Sierra Owner said:

My truck does this as well. I couldn't figure it out till the other day it took longer than a few seconds to switch. Best I can tell is that if you set up a profile in your radio the radio does not start up in that profile. So you hear the default (no profile) radio (whatever it is set to) till the system loads your profile and starts playing from the stations you have programmed in. I got in my truck the other day and it was playing something different again. I started looking at the station settings and everything had changed I was like WTH. Then a few seconds later my profile loaded and everything was as I had set it.

So you think if I delete my profile, the station that I have on when I shut the truck off will be the station when I start it up after sitting awhile?

Link to post
Share on other sites
2 minutes ago, steelcity said:

So you think if I delete my profile, the station that I have on when I shut the truck off will be the station when I start it up after sitting awhile?

Yeah that is what I'm thinking. I've not tried that yet though.

Link to post
Share on other sites
6 hours ago, 2016 Sierra Owner said:

Yeah that is what I'm thinking. I've not tried that yet though.

I did and I wouldn't recommend it, lol.  It deleted everything. 

Link to post
Share on other sites
17 hours ago, 2016 Sierra Owner said:

My truck does this as well. I couldn't figure it out till the other day it took longer than a few seconds to switch. Best I can tell is that if you set up a profile in your radio the radio does not start up in that profile. So you hear the default (no profile) radio (whatever it is set to) till the system loads your profile and starts playing from the stations you have programmed in. I got in my truck the other day and it was playing something different again. I started looking at the station settings and everything had changed I was like WTH. Then a few seconds later my profile loaded and everything was as I had set it.

The profile option is more of a pain in the ass than it's worth.  Plan on nixxing it tomorrow

Link to post
Share on other sites
On 3/4/2021 at 1:48 PM, steelcity said:

If I'm listening to Sirius XM when I shut my truck off, the next time I start it up it goes to FM them a couple seconds later it says loading XM then it finally goes back to XM. And I have the latest updates.

Do you have your iPhone connected?  If I don't have my iPhone with me, it goes to last station I was listening to (FM or XM).  But if my iPhone connects, it will tune to my playlist on my iPhone.

Link to post
Share on other sites

It automatically connects when I start the truck up.  It just tells me that my phone is connected.  Upon startup mine goes to FM then slowly loads XM and then goes to the last station that I was listening to on XM. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.