Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

3.0 Duramax cranks but won’t start


Recommended Posts

By chance, is anyone else with the extended crank/no start issue experiencing intermittent harsh shifting? Wondering if it isn’t a bad cam position sensor. Also, yesterday my truck randomly shut off while in park. This was after starting the truck with the push button (not remote). It had been idling for maybe 10 min or so. 

Link to comment
Share on other sites

Mine did it again today @ 2630 miles.  This time it was with the remote start.  As soon as I caught that it was continuing to crank without starting, I pushed and held the start button on the remote again and it immediately stopped cranking.  It started right up on the second try.

 

The first time it did this was when I was starting it with the dash's start button, but it seemed to keep cranking no matter what I did to the start button, so I liked that the remote stopped it immediately rather than letting it keep cranking.  Just wanted to pass this along as I don't recall reading that the remote would stop it immediately like it did for me today.

 

Other than this, the truck has been great!

Edited by V8Chevy
Link to comment
Share on other sites

15 hours ago, WontStart said:

By chance, is anyone else with the extended crank/no start issue experiencing intermittent harsh shifting? Wondering if it isn’t a bad cam position sensor. Also, yesterday my truck randomly shut off while in park. This was after starting the truck with the push button (not remote). It had been idling for maybe 10 min or so. 

Yes I have what I consider rough shifts every blue moon. I also have the intermittent fuel knock that someone mentioned earlier. GM has had ground (-) issues before. I’m starting to feel like this is a nostalgic feature to remind us what cars were like in the ‘80s. But seriously every time I’ve had a stupid intermittent issue like this it was either a bad or loose ground connection or wiring connector. And after finding my battery cables with barely any torque along with the fuse box, I am certain there are other loose connections. I’d also like to share both times my truck ‘crunk’ and no start it was the first start of the day while sitting in my driveway. Hopes this helps you GM.

Edited by fireaxxe
Link to comment
Share on other sites

2 hours ago, Anthony Dugstad said:

2021 Silverado LT 14,000 miles on it. I was on the interstate taking the off ramp and and it started sputtering and then halfway up the off ramp I pull over, shut it off try to restart and then just a continuous cranking have tried five times now waiting for a tow truck


Well that really sucks. Also kinda interesting. I’m far from a mechanic but the Google says this would also support the cam position sensor theory. Please keep us updated and good luck with the truck! 

Edited by WontStart
Link to comment
Share on other sites

On 8/21/2021 at 8:07 AM, WontStart said:

By chance, is anyone else with the extended crank/no start issue experiencing intermittent harsh shifting? Wondering if it isn’t a bad cam position sensor. Also, yesterday my truck randomly shut off while in park. This was after starting the truck with the push button (not remote). It had been idling for maybe 10 min or so. 

The trucks are programmed to shut off after idling for a period of time.

Link to comment
Share on other sites

Quick follow up to my post... Dealer ordered the shim and a new cam sensor, but both are on backorder. They called GM and spoke to a technical advisor about the issue. 

 

They also couldn't get the front camera to relearn so they ordered a new one--also on backorder.

Link to comment
Share on other sites

On 8/21/2021 at 10:07 AM, WontStart said:

By chance, is anyone else with the extended crank/no start issue experiencing intermittent harsh shifting? Wondering if it isn’t a bad cam position sensor. Also, yesterday my truck randomly shut off while in park. This was after starting the truck with the push button (not remote). It had been idling for maybe 10 min or so. 

 

I have had a few of the crank no-start issues.  Mine shifting from 1st-2nd and 2nd-3rd the truck does jerk a bit, even when accelerating gently.  The rest of the changes I can't feel them.   I am not sure if this is what you consider harsh shifting or not.

Edited by moobaru
Link to comment
Share on other sites

Mine shifts exactly as you described but I chalked that up to normal. The harsh shifting that I find a little odd is when I start to let off the gas while accelerating I get a couple sharp “jolts” or shudder. 

Link to comment
Share on other sites

I'm curious if anyone who's had this issue with dry starts have the keyed ignition or is everyone reporting this only have the auto start stop/ pushbutton starting? It seems to me like a solenoid timer delay issue? 

 

LOA68

2021 Silverado RWD RST

 

 

 

 

 

IMG_20210719_105656_570.webp

Link to comment
Share on other sites

Hey Guys. I just bought a 2021 Chevy Silverado Z71 and I am now having this problem. I have had this truck for a couple of days and only have 312 miles on it.  I have tried to started it a couple times and it wont start.  When I put my foot on the brake and hit the start button it will turn over for about 20 or so seconds and then shut down. I just called the dealership and they are sending a tow truck out right now. I will keep you posted on what I find out.  

Link to comment
Share on other sites

43 minutes ago, sedufort said:

Hey Guys. I just bought a 2021 Chevy Silverado Z71 and I am now having this problem. I have had this truck for a couple of days and only have 312 miles on it.  I have tried to started it a couple times and it wont start.  When I put my foot on the brake and hit the start button it will turn over for about 20 or so seconds and then shut down. I just called the dealership and they are sending a tow truck out right now. I will keep you posted on what I find out.  

 

Tell them to take your new truck back and get your money.

Link to comment
Share on other sites

I have 9000 miles on the truck and the issue has happened about 6 times.  First time was within the first 400 miles.  Last time was about 1 month ago.  Had my 2021 GMC Sierra SLT 3.0 in the shop for about a week.  Dealership had no knowledge of the issue and I supplied the service bulletin # for them.  They dug all the way down to the "bent wheel" issue and visually inspected that it was not bent.  So that was not the issue with my no start long crank problem.  GM told them to put it back together and update the computer and give it back to me.  It's been 1 week post "repair" and has not happened yet.  Since it's intermittent I'm expecting it to happen again, but will probably be a while longer.  I think at this point GM doesn't have a clue.  I've reached out to other youtube people that reviewed these trucks/engines and had talked with the GM engineers in reviews past.  The YouTube influencers are now saying that GM is keeping tight lips on this one!  Just means they don't have a clue and they don't want the YouTube influencers jumping all over this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.