Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

I just replaced my rear main seal and obviously you have to remove the transmission. After I got everything back together, I drove it around and noticed it shifts hard now. When I put it into gear it spits and sputters and eventually will die and it idles perfect. Never had any problems before shifted great and ran great. it seams shifting into 4th gear is smooth and normal but not the other gears. What could it be? Something electrical?

 

04 GMC 2500HD 6.0L 4L80E

Share this post


Link to post
Share on other sites

maybe check for codes from the tcm?  This takes a more advanced code reader than the regular cheap ODBII code readers.

 

But also maybe unplug/replug the electric connectors, and check that the shift cable is properly attached.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.