Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Lifter Ticking Noise on 2019 Silverado 1500 6.2


Recommended Posts

I have 64K miles on my 2019 Silverado 1500 6.2, mostly highway, and I recently started hearing the dreaded lifter noise.  I was unaware of the ongoing issue until I started researching it and am disappointed to hear that it sounds like this is an epidemic.  However, Im wondering if GM has a "fix" for this problem, or are they just replacing parts, and should expect to have this concern again in another 60K miles?  Has anyone had the repair completed and is now experiencing the same issue again?  Looking for advice to see if I should dump the truck and walk away even though I really like the truck overall.  

Link to comment
Share on other sites

20 hours ago, Dbogie said:

No lights are coming on right now.  Im taking it to the dealer tomorrow and see what they say.  I will keep you posted.

Good luck, my dealership told me they couldn't/wouldn't do anything until it coded.  They had it for 3 days & "couldn't replicate" the sounds. Told me sorry but you are going to have to drive it until it does.  Very proactive knowing they agreed on what the issue was in the first place.  Drove it home & on the way home it did more than just throw codes.  OUT of my truck for a good while since lifters along with everything else is just sitting on the container ships in the LA port.  

 

Edited by RSVolcom
Link to comment
Share on other sites

Well I think I have the lifter failure now also, I was getting a loud pop or clunk noise once in a while over the last week and today it started ticking loudly and the engine light is on.

Link to comment
Share on other sites

Well to my shock, I got my truck back yesterday after only 3 days at the dealer.  Failed lifter on cylinder 6, they replaced all 8 lifters on that side along with one pushrod and the truck runs great again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.