Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

2015 Silverado 5.3 LT shows P129D even after new fuel pump module and battery?


Recommended Posts

My truck will throw the P129D every couple of days when I start my truck, code never comes up driving. I’ve installed a new fuel pump control module, and a new battery, and the issue still persists. Anyone else had this issue before? It’s got me confused

Edited by greenoliver1
Added to post
Link to comment
Share on other sites

On 10/19/2021 at 8:53 AM, silveradosid said:

watch this video 

 


i watched the whole thing, but the problem is in Eric’s case the code was staying no matter what, if I clear mine it goes away for a few days then randomly comes back when I start my truck. If mine was constantly on I could easily do the same procedure for finding the break, but I checked my whole harness as best as I could and didn’t see any chafes, and I opened the harness in a few spots and tugged the wire hoping it was broken and would come out, but it was nice and tight in there 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.