Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

1995 Chevrolet 454 starts then stalls


J.c.
 Share

Recommended Posts

I have a 1995 motorhome with a Chevrolet 454 tbi. It was running fine one day and the next it would start then stalls immediately after.  Replaced the fuel pump, filter, map sensor, engine temperature sensor, water temperature sensor, coil and the sensor at the base of the distributor. If I disconnect the vacuum line from the brand new ac delco map sensor it will start and run but not very well. Was told I needed a new tbi system but $500 is a lot of money for me to spend just to find out it wasn't the problem after all.  At the end of my rope and need guidance desperately.  Thanks in advance. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.