Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Push Button Start won't let me take control.


Recommended Posts

I'm going to be a little stubborn here. I'm not going to remove the car wash membership sticker.  I have removed all other RFID signals one by one.  and removing those didn't stop this from happening.  So I don't believe its getting confused with other signals. If it is then GM needs to fix truck.  I'm sure there are thousand of GM Cars/trucks working just fine with a easypass transponder stuck to the windshield.   

Link to comment
Share on other sites

7 hours ago, rlambert said:

I'm going to be a little stubborn here. I'm not going to remove the car wash membership sticker.  I have removed all other RFID signals one by one.  and removing those didn't stop this from happening.  So I don't believe its getting confused with other signals. If it is then GM needs to fix truck.  I'm sure there are thousand of GM Cars/trucks working just fine with a easypass transponder stuck to the windshield.   

Those transponders are passive (at least all the ones I have had) and are not the problem. They work like the chip on a credit card active only when put under a transponder reader.. I would be looking for something interfering with the remote to truck signal. Could be something on the truck or something in the area you live causing issues. Aftermarket wireless cameras have been known to cause issues with keyless entry/starting.

 

Jay

Link to comment
Share on other sites

  • 3 weeks later...

Here is a update on this after happening 2 more times.  My dealer service rep. contacted GM cooperate for Tech support on this issue.  He sent them my videos and they took a few days and reviewed them.. The Technician at cooperate came back and suggested that the dealer replace the drivers door latch and locking mechanisms. The thought is that the drivers door is not communicating that its been opened and someone got in the truck, therefore the push button wouldn't work because it thinks no one is in the truck to push that button.  So 3 days in and so far the issues has not presented itself.   Time will tell. 

 

        Its no wonder these trucks need all these computer chips and cost so darn much. Who would have thought the drivers door tells the truck when its been opened?  I would rather just put a key in the dash and turn it. Than to have this ridiculous push button, And I never know what to do with the remote once I'm in truck.  then I always forget to take it with me after driving. and I get the 3 horn beeps reminding me....... 

Link to comment
Share on other sites

  • 2 weeks later...

Back to square one! 

   Went to get in the running truck Sat. morning and once again it wouldn't let me take control.  Had to take another vehicle to do what I set out to do, came home 7 hours later, tried truck and worked like nothing happened.  This is so frustrating  because the dealership can't get it to do it when it at the shop. Its been a little over 3 weeks since the last incident. 

Link to comment
Share on other sites

  • 4 weeks later...

Any luck with this issue? Very similar issues happened to me about a month ago (2019 Silverado LTZ) chalked it up to a dead battery and switched to the spare fob. Replaced the battery in both to be safe, and this past week it has done it at least once every day. I can lock an unlock the truck, remote start, drop the tailgate.. everything but actually drive the thing. It will give me the same DIC message every time.. "Press Engine Start Button To Learn" (you cannot start the truck). The next message is "Remote Learn Pending Please Wait" and I have to go through the whole cycle as if I'm programming the fobs right out of the manual. I intentionally reprogrammed both fobs last night and everything worked until I tried to leave work. I have to wait for the 30 minute timeout before I can start the truck. Can't get into the dealership until Monday.

Link to comment
Share on other sites

Hey Doug1234  

      They (GM) has not figured this out for my truck as of yet.  About a month ago they replaced my drivers door latch?  Telling me that it wasn't telling the computer that someone entered the truck So, it wasn't looking for the Start Button to be pushed. That didn't help. About a week later the truck acted up again and it spent over a week at the dealership.  They came back and said they were going to try a new drivers door window switch.  Telling me that everything loops through the door and that is what GM wants to do for the next troubleshooting idem?   So, I really have no faith that it will solve the issue but its been 5 days now without it happening.   

     Please update me here as to what they tell u.     My service rep actually told me that he was surprised that GM hasn't done a "buy back" on my truck.  I told him they won't because I'm the 2nd owner. I bought it as a GMC certified vehicle with 12K miles on it. He says yes being the 2nd owner I lose those rights.  Kind of stinks for me.  so I all I can do is be a pain in their side until this is fixed.  I have 20,000 more miles to get it right.  fingers crossed.  Hope u get better results. 

Link to comment
Share on other sites

A couple of months ago I purchased a wireless charger for my iPhone to mount in the truck. Some kind of interference  was happening with the electronics as I started receiving the Remote Not Detected message almost immediately. The manufacturer of the charger sent me an older model (the previous model of the New & Improved version) and the problem went away.

Link to comment
Share on other sites

Dejadoo, I wish my problem was as simple as interference lol Glad you got your issue figured out! My truck has no issue recognizing the fob, it just puts itself into key learning mode (which should only be possible through inserting the key in the driver's side door and turning CCW 5 times in 10 seconds) and I can't get out of it until 30 minutes is up, even holding the start/stop button for 12 seconds does nothing until that timer is up. No shot the dealer is going to be able to replicate, even with my videos.

Link to comment
Share on other sites

On 4/20/2022 at 10:02 AM, rlambert said:

Hey Doug1234  

      They (GM) has not figured this out for my truck as of yet.  About a month ago they replaced my drivers door latch?  Telling me that it wasn't telling the computer that someone entered the truck So, it wasn't looking for the Start Button to be pushed. That didn't help. About a week later the truck acted up again and it spent over a week at the dealership.  They came back and said they were going to try a new drivers door window switch.  Telling me that everything loops through the door and that is what GM wants to do for the next troubleshooting idem?   So, I really have no faith that it will solve the issue but its been 5 days now without it happening.   

     Please update me here as to what they tell u.     My service rep actually told me that he was surprised that GM hasn't done a "buy back" on my truck.  I told him they won't because I'm the 2nd owner. I bought it as a GMC certified vehicle with 12K miles on it. He says yes being the 2nd owner I lose those rights.  Kind of stinks for me.  so I all I can do is be a pain in their side until this is fixed.  I have 20,000 more miles to get it right.  fingers crossed.  Hope u get better results. 

I can kinda see where they are coming from but if you have the same thing as me, it's not an issue of not recognizing the RKE, it's that it (the immobilizer or some related component) is putting itself into key learning when there's no way it should be, according to what the manuals states it requires to do so. I have been able to replicate the issue when entering through other doors, but it's completely random. 

Link to comment
Share on other sites

Doug1234,   

    my truck does give me the "Learning remote please wait" message in the DIC when it acts up.  I've had the remote batteries replace twice now over the last year and had them reprogramed as well.  Did not solve the issue.  Its been a week now since the window switch has been replace and so far no issues. If its going to follow the previous patterns it should act up here soon. 

Link to comment
Share on other sites

Dejadoo  the dealer did suggest that I might have something interfering.  I removed everything. The E-Z pass, the RFID chip to my house door and anything else I could think of and did not help my issues. 

 

Doug1234   sounds like you and I have the same issue going on.  when my issue come up my fob works for everything.  doors, tailgate, remote start but I would get the learning remote message and the trucks push start button won't let me go anywhere.  I wait and hour or so and come back to truck and everything is fine and works as it should until the next random time it decides to act up. 

Link to comment
Share on other sites

rlambert, I got lucky (or unlucky) that I got to the dealership today before they opened and they asked me to bring it into the service bay, go out and it happened! Had a service tech come out and remote started it and he's like put it in drive and I'm like good luck, here's the fob, wait 30 minutes and you can move it 😂 

  • Haha 1
Link to comment
Share on other sites

Keeping yall updated. Yesterday, the dealership gave me a new fob since they thought that was the issue (told them highly doubtful, but I'll take their word for it) and got stranded twice today to and from work using the new fob.. taking it back in next week when they have time to look at it again. I still believe it's whatever component/software that stores the RKE codes and authorizes new codes that's fubar. 

Link to comment
Share on other sites

Doug1234  That is very interesting to me that it happened to them.  Please keep me updated as to what they do.  I am now a week and 5 days since they replaced my drivers window switch.  So far no issues but it has to work correctly for a few months before I say that fixed the problem.   Keep us updated. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.