Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Forward collision and lane keep assist still a problem on 2022 refresh?


Recommended Posts

On 8/12/2022 at 4:59 PM, dickpencil said:

My Sierra got the forward collision alert yesterday. No cruise control, but I also noticed my automatic high beam function doesn't work either. Pulled the fuse with no luck. I'll try the bendy thing and let you know if it works. 

This is certainly not what we like to hear, dickpencil.  Please know, customer satisfaction is extremely important to us. Our team would be more than happy to take a closer look into the concerns with your 2022 Sierra Elevation. To do so, please send an email to [email protected] with ATTN: dickpencil/GM Trucks in the subject line.

Please include your contact information, VIN, a brief description of your concern, and the name of your preferred dealership. We look forward to hearing from you. To learn more about GM’s privacy policy, please visit https://www.gm.com/privacy-statement.html.
 
Privacy Statement | General Motors
Your privacy is important to General Motors. This Privacy Statement addresses the personal information GM collects and how GM handles that personal information.
www.gm.com
 

Link to comment
Share on other sites

1 hour ago, GMCustomerService said:

This is certainly not what we like to hear, dickpencil.  Please know, customer satisfaction is extremely important to us. Our team would be more than happy to take a closer look into the concerns with your 2022 Sierra Elevation. To do so, please send an email to [email protected] with ATTN: dickpencil/GM Trucks in the subject line.

Please include your contact information, VIN, a brief description of your concern, and the name of your preferred dealership. We look forward to hearing from you. To learn more about GM’s privacy policy, please visit https://www.gm.com/privacy-statement.html.
 
Privacy Statement | General Motors
Your privacy is important to General Motors. This Privacy Statement addresses the personal information GM collects and how GM handles that personal information.
www.gm.com
 

Get us service loaners, so we can have the dealership diagnose the issue if customer service is extremely important to you.

  • Like 2
Link to comment
Share on other sites

So I decided to check my ghetto heatsink solution(which made it work for the last two weeks so it does look like it's helping...)

When I got in the truck, the temps were at 188 degrees! crazy hot!

1951200464_WhatsAppImage2022-08-22at7_48_27PM.thumb.jpeg.70b5fbb7291cdbf667013ae2ca7964fd.jpeg

after 20 minutes of driving, it went down to 105.

964012671_WhatsAppImage2022-08-22at7_48_28PM.thumb.jpeg.72e8165fa9614f2df19515638bf27312.jpeg

I'm happy with the results.. Just wanted to keep you guys posted...

Edited by Manny Man
  • Like 1
Link to comment
Share on other sites

Add mine to the list of affected trucks. 2022 refreshed TrailBoss LT and barely over 1k miles. I tried the fuse thing and the light was still on. Auto-high beams, lane keep assist don't work either. I haven't tried cruise control, which would be the only feature out of these that I care about. Super annoying for a brand new $65k truck to have this problem and I'm not sure if I'm relieved that so many of you also have it, or more annoyed.

Link to comment
Share on other sites

You might have to pull the battery cables to do a hard reset on the ecm to clear the code. You can Google how you do it to drain all the energy from the truck before replacing the cables. Make sure you do a slight twist on the spades so they make tight contact with the connectors in the fuse block. Hope that helps

Link to comment
Share on other sites

Add my ‘22 AT4X to the list. Just happened this morning on the way to work. I’m gonna try the twisty thing when I get home. I’m not mechanically savvy so, I need to be clear on this. Remove fuse 11 then twist one spade one way and one of the other spades the other, correct? 

D52558F7-D48E-45E7-B9C8-699B9ECC3F20.jpeg

Link to comment
Share on other sites

2 minutes ago, LTZcoog said:

Add my ‘22 AT4X to the list. Just happened this morning on the way to work. I’m gonna try the twisty thing when I get home. I’m not mechanically savvy so, I need to be clear on this. Remove fuse 11 then twist one spade one way and one of the other spades the other, correct? 

D52558F7-D48E-45E7-B9C8-699B9ECC3F20.jpeg

Twist all 3 of them. 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

5 minutes ago, Manny Man said:

Twist all 3 of them. 

Thank you. Can I do this by hand or do I use some kind of tweezers? 

Link to comment
Share on other sites

11 minutes ago, LTZcoog said:

Thank you. Can I do this by hand or do I use some kind of tweezers? 

Yes, you don’t need any tools..

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

21 minutes ago, LTZcoog said:

Thank you. Can I do this by hand or do I use some kind of tweezers? 

I used a pair of small needle nose pliers to get a small twist on mine because there are 3 spades on the fuse. I can control how much I twist with the pliers rather than my hands. It's not required though.

  • Thanks 1
Link to comment
Share on other sites

11 minutes ago, LTZcoog said:

Thank you. Can I do this by hand or do I use some kind of tweezers? 

Yes, you don’t need any tools..

  • Thanks 1
Link to comment
Share on other sites

Hello all, just want to add my story, 2022 TB refresh 6.2, before I purchased my truck I researched a lot of these forums to learn about it and to find any issues.  I have 3400 miles on it now and one morning my collision light came on and I remembered reading about this issue on here.  So I tried resetting with fuse and no luck and was about to call dealership about it and then it dawned on me—the night before I was messing around with all the settings and had changed the collision setting from alert and brake to just alert and what do you know—the light comes on.  Hopefully people are aware of this before going to dealership.  Thanks to this forum I have learned a lot about this truck so Thank you.

  • Like 1
Link to comment
Share on other sites

On 8/23/2022 at 1:21 PM, Brews02ws6 said:

Add mine to the list of affected trucks. 2022 refreshed TrailBoss LT and barely over 1k miles. I tried the fuse thing and the light was still on. Auto-high beams, lane keep assist don't work either. I haven't tried cruise control, which would be the only feature out of these that I care about. Super annoying for a brand new $65k truck to have this problem and I'm not sure if I'm relieved that so many of you also have it, or more annoyed.

This is certainly not what we like to hear, Brews02ws6.  Please know, customer satisfaction is extremely important to us. Our team would be more than happy to take a closer look into the concerns with your 2022 refreshed Trailboss LT. To do so, please send an email to [email protected] with ATTN: Brews02ws6/GM Trucks in the subject line.

Please include your contact information, VIN, a brief description of your concern, and the name of your preferred dealership. We look forward to hearing from you. To learn more about GM’s privacy policy, please visit https://www.gm.com/privacy-statement.html.
 
Privacy Statement | General Motors
Your privacy is important to General Motors. This Privacy Statement addresses the personal information GM collects and how GM handles that personal information.
www.gm.com
 

Link to comment
Share on other sites

So the system is not giving any fault codes or warnings but I noticed that the lane keep assist is not working.

it’s seeing the car in front of me but not engaging the LKA even though the lane markings are perfectly visible and I know that it works on this road (it actually works all the time when I’m over 30mph, it’s pretty good at detecting lane markings)
it didn’t work all day today so I just tried the reset again, and it works fine now… idk what’s going on with this system but it’s weird, always something new.

6F841BD0-696B-40BD-993C-4B03514E4FC9.thumb.jpeg.cc0115a8145a367ec43f10882e3d5b1e.jpeg
 

9FDC6F05-A016-46F9-B6F4-73B597F97C1F.thumb.jpeg.a17b19bf5528e8fc7241b10abd217117.jpeg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.