Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

This brake light is driving me to the brink


Recommended Posts

As the title says. Im having brake light issues, drivers side only. I have checked fuses, brake switch. Connectors, junction box and just now finished putting back rear bumper after taking it off to get better view of the wiring. It all checks out i even cleaned up a dodgy looking ground and ran a new ground with it. And finally i have tried multiple bulbs. 

 

Heres my testing results.

1.Bulb socket i only get a red light on the test light on the blue wire.

2.brake switch 2 red lights on white and orange wire.

3. Junction box was swapped with another yukon and still problem continues.

4. And yes fresh new light bulbs where installed with no change.

 

Wnen the truck is off everything works like it should but when i put the key in start or run thats when the brake light decides not to turn on.

 

Anything else i can try?. Sorry for the long posr. Thanks in advance.

 

2004 gmc yukon denali 6.0L

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.