Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Another Service Theft Deterrent System Issue, But it Starts


Recommended Posts

First post here, did a bit of googling and couldn’t find much on a “Service Theft Deterrent System” issue WITH a start condition. I recently bought an auction truck that was indeed stolen, then recovered. From what I can tell, since the truck has been in my possession, it seems that the ignition cylinder and key has been replaced, the driver’s lock is damaged beyond use, and the HMI control module bypass module was missing (it has since been replaced). Everything else looks untouched and and uncut. The truck complains about servicing the theft deterrent system in the center screen gauge cluster screen, but the actual orange lock icon light in the cluster has never illuminated. The truck starts fine, sometimes delayed, and drives around the block. I have unhooked the battery for up to half an hour, tried the key relearn process (three ten minute on positions) and I still get the theft decent system message.

What else could I be missing here?

 

Any help would be appreciated. Thanks.

Link to comment
Share on other sites

Not sure if this would help you but on my 2018 Silverado I was getting the theft deterrent message and truck was still starting fine. Then after some weeks my alarm started going off randomly. I ended up changing the hood latch and all is good since. By the way I had a hard time finding a new one so others must have been having same issue. Hope this helps you. Good luck. 

Link to comment
Share on other sites

Thanks.

 

So I got a proper scan tool and the code returned shows that it’s in key relearn mode. B3031 “Key Decoder Device in Assem Learn Mode”. I have done the three ten minute procedure and can’t seem to get out of this mode.

 

Does anyone have any ideas here?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.