Jump to content

Search the Community

Showing results for tags 'led illuminate panel battery'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GM-Trucks.com Original News & Product Reviews
    • General Motors Product and Industry News
    • The GM-Trucks.com Garage - Vehicle Testing & Product Reviews
    • The Newsroom Archive
    • The Garage Archive
  • Future Vehicle Discussion
    • Silverado / Sierra & Future Vehicle Speculation & Spy Shots
    • 2022 GMC HUMMER EV Electric Pickup
  • Fullsize Truck & SUV - 2019 - 2020 - 2021 T1XX Platform
    • 2019 / 2020 Silverado & Sierra
    • 2020+ Silverado HD & Sierra HD
    • 2021 Tahoe, Suburban, Yukon, Yukon XL & Escalade
  • Fullsize Truck & SUV - 2014-2019 K2XX Platform
    • 2014 - 2019 Silverado & Sierra
    • 2015-2020 Suburban/Tahoe & Yukon/Yukon Denali
    • 2015-2019 Silverado HD & Sierra HD
  • Fullsize Truck & SUV - 1999-2006 GMT800 & 2007-2013 GMT900 Platforms
    • 1999-2013 Silverado & Sierra 1500
    • 2000-2014 Silverado & Sierra HD
  • Chevy Colorado & GMC Canyon
    • 2015-2020 Colorado & Canyon
    • 2005-2012 Chevy Colorado & GMC Canyon
  • Midsize Crossover - 2017-2020 C1XX Platform
    • 2017-2020 Traverse, Acadia, Enclave & XT5
    • 2019 - 2020 Blazer
  • Classic Chevrolet / GMC Pickup Trucks
    • 1988-1999 Chevrolet & GMC C/K GMT400 Platform
    • 1973-1987 Chevrolet & GMC Square Body / Rounded Line Pickups
    • 1967-1972 Chevrolet & GMC Glamour / Action Line Pickups
    • 1960-1966 Chevrolet C/K/Apache & GMC 1000-3000 Pickups
    • 1982-2005 Chevrolet S-10/Blazer & GMC S15/Sonoma/Jimmy
    • 1969-1994 Chevrolet K5 Blazer & GMC Fullsize Jimmy
  • Marketplace
    • For Sale/Wanted
    • Member & Vendor Rating Forum
    • Member Product Reviews
  • GM-Trucks.com is supported by
    • Adam's Premium Car Care
    • Agri-Cover
    • Arnott Air Suspension
    • Black Bear Performance
    • GMPartsDirect.com
    • UPR Products
    • Synthetic Advantage
  • The Lounge
    • Off-Topic
    • Automotive Industry & Market Discussion
    • New Member Introductions
    • Meetups, Events, & Gatherings
    • GM-Trucks.com Comment Box
  • Hobbies & Lifestyle
  • Technical & Advanced
  • Chevrolet, GMC, Buick & Cadillac Crossovers
  • Commercial Vehicles
  • Black Truck Club's Topics
  • Texas Owner's Group's Topics
  • California Owner's Group's Topics
  • New England Owner's Group's Topics
  • Midwest Owner's Group's Topics
  • South Carolina Silverado Owners's Topics
  • Canadian Owners Club's Topics
  • SCUBA divers of GM-Trucks's Scuba Talk
  • Red Truck Club's Topics
  • Idaho Sierra & Silverado Owners Club's Idaho
  • Colorado Trucks's Exhaust Setups
  • Colorado Trucks's Pics of trucks
  • SEO Paint's seo color ordered
  • NorthSky Blue Club's NorthSky Blue Metallic
  • NorthSky Blue Club's Pics
  • diesel 3.0's Topics

Calendars

  • Events
  • Birthdays
  • Texas Owner's Group's Events
  • California Owner's Group's Events
  • Midwest Owner's Group's Events
  • Red Truck Club's Events

Categories

  • Articles
  • News
  • Reviews
    • Project Sierra
  • Resources

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


Yahoo


Skype


Facebook


Twitter


Name


Location


Interests


Drives

Found 1 result

  1. I have a 2003 Chevy Silverado LS 1500 5.3L Gas Extended Cab Longbed and am having a weird battery drain issue. After sitting for about a week in 65 degree temps (or two to three days in freezing temps) my battery will be completely dead - like I can't even operate the door locks it's so dead. I started having the issue about 1.5 years ago and replaced the battery, but that didn't fix the issue... A few months ago I went out and peered into the drivers side window to find that the readout on my instrument panel (where the odometer reading, hourometer and tripometer is displayed) was completely illuminated (see picture below). This was after it had been sitting for at least a full day. As soon as I unlocked and opened the door, it went out. I have seen this many times now. I've had the truck for almost 5 years now and the only thing I have done to it is the installation of a radio about 4 years ago. It all seems to function great, minus the battery drain. Ideas? I have the Ghost Busters on speed dial if needed. UPDATE: I just did a parasitic battery drain test and found that it was pulling 0.25 A when sitting and would occasionally jump up to and sit around 0.6 A. I pulled the IPC/DIC fuse and it drops to 0.004 A. So, I'm getting warmer... I also pulled my aftermarket radio out and found an Access GMOS-01 harness. Could this crappy harness be causing the problem? Is there a way to test it?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.