Jump to content

Search the Community

Showing results for tags 'rough idlevoltage drop'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GM-Trucks.com Original News & Product Reviews
    • General Motors Product and Industry News
    • The GM-Trucks.com Garage - Vehicle Testing & Product Reviews
    • The Newsroom Archive
    • The Garage Archive
  • Next-Generation Full Size Speculation - 2026+
    • 2026 Chevrolet Silverado & GMC Sierra
  • Battery Electric Vehicles - 2022-2026 Ultium Platform
    • 2022-2024 GMC HUMMER EV Pickup & SUV
    • 2024 Silverado EV & Sierra EV
  • Fullsize Truck & SUV - 2019-2025 T1XX Platform
    • 2019-2025 Silverado & Sierra
    • 2020-2024 Silverado HD & Sierra HD
    • 2021-2023 Tahoe, Suburban, Yukon, Yukon XL & Escalade
  • Fullsize Truck & SUV - 2014-2019 K2XX Platform
    • 2014 - 2019 Silverado & Sierra
    • 2015-2020 Suburban/Tahoe & Yukon/Yukon Denali
    • 2015-2019 Silverado HD & Sierra HD
  • Fullsize Truck & SUV - 1999-2006 GMT800 & 2007-2013 GMT900 Platforms
    • 1999-2013 Silverado & Sierra 1500
    • 2000-2014 Silverado & Sierra HD
  • Chevy Colorado & GMC Canyon
    • 2023-2024 Chevy Colorado & GMC Canyon
    • 2015-2022 Colorado & Canyon
    • 2005-2012 Chevy Colorado & GMC Canyon
  • Midsize Crossover & SUV
    • 2024 Chevrolet Traverse, GMC Acadia & 2025 Buick Enclave
    • 2017-2023 Traverse, Acadia, Enclave & XT5
    • 2019 - 2024 Blazer
  • Classic Chevrolet / GMC Pickup Trucks
    • 1988-1999 Chevrolet & GMC C/K GMT400 Platform
    • 1973-1987 Chevrolet & GMC Square Body / Rounded Line Pickups
    • 1967-1972 Chevrolet & GMC Glamour / Action Line Pickups
    • 1960-1966 Chevrolet C/K/Apache & GMC 1000-3000 Pickups
    • 1982-2005 Chevrolet S-10/Blazer & GMC S15/Sonoma/Jimmy
    • 1969-1994 Chevrolet K5 Blazer & GMC Fullsize Jimmy
  • Marketplace
    • For Sale/Wanted
    • Member & Vendor Rating Forum
    • Member Product Reviews
  • The Lounge
    • Off-Topic
    • Future Vehicle Speculation & Spy Shots
    • Automotive Industry & Market Discussion
    • New Member Introductions
    • Meetups, Events, & Gatherings
    • GM-Trucks.com Comment Box
  • Hobbies & Lifestyle
    • Photography
    • Major League Sports, Outdoor Recreation, Firearms, Hunting, OHRV
    • Racing, Strip, & Track
    • Trailers, Hitches, & Towing
    • Garage & Home, Snow Plowing, Landscaping, & Lawn Care
    • Technology, Devices, & Gaming
    • Vehicle Buying, Financing, Incentives, & GM Card
    • Vehicle Builds
  • Technical & Advanced
    • Vehicle Appearance, Care, & Maintenance
    • Ask the GM Technician
    • Performance Engine Tuning
    • Transmission, Suspension, Transfer Case, & Axles
    • Wheels, Tires, & TPMS
    • Audio, Electronics, OnStar, MyLink, Intellilink & SiriusXM
    • How-To
  • Commercial Vehicles
    • 1980-2009 Chevrolet Kodiak and GMC Topkick
    • Chevrolet Express & GMC Savana
    • Chevrolet Silverado Chassis Cab 4500HD/5500HD/6500HD
  • Black Truck Club's Topics
  • Texas Owner's Group's Topics
  • California Owner's Group's Topics
  • New England Owner's Group's Topics
  • Midwest Owner's Group's Topics
  • South Carolina Silverado Owners's Topics
  • Canadian Owners Club's Topics
  • SCUBA divers of GM-Trucks's Scuba Talk
  • Red Truck Club's Topics
  • Idaho Sierra & Silverado Owners Club's Idaho
  • Colorado Trucks's Exhaust Setups
  • Colorado Trucks's Pics of trucks
  • SEO Paint's seo color ordered
  • NorthSky Blue Club's NorthSky Blue Metallic
  • NorthSky Blue Club's Pics
  • diesel 3.0's Topics
  • MIAMI TRUCK LOVERS's YOUR FAVORITE CHERVROLET MOD?

Calendars

  • Events
  • Birthdays
  • Texas Owner's Group's Events
  • California Owner's Group's Events
  • Midwest Owner's Group's Events
  • Red Truck Club's Events

Categories

  • Articles
  • News
  • Reviews
    • Project Sierra
  • Resources

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


Yahoo


Skype


Facebook


Twitter


Name


Location


Interests


Drives

Found 1 result

  1. Hey guys, I recently picked up a 2004 GMC Savana Quigley 6.0 with about 183k miles. It has a couple issues that I was hoping other guys would have some good advice on. Its hard to start cold and has to be kept running for a few minutes before it will idle on its own. After that, it has a low idle and can stall if you're steering in a parking lot and get off the throttle too suddenly. The last issue is that when you come to a stop like at a light or stop sign, the voltage will drop from around 14 to about 9 then take several seconds to climb back up to 14 again. There is no check engine light, and I can't pull any codes with my cheapo scanner. The service light comes on for a short time when it first gets started. It runs good aside from those things. It has plenty of power, and I did some research and read up on other guys with the same and similar issues, but so far haven't found the cause of mine yet. I cleaned the MAF with CRC MAF cleaner which was actually pretty clean. I noticed that 2 of 3 bolts were missing for holding it onto the air box, so I replaced them. Cleaning the MAF made no improvement. I cleaned the throttle body which was also pretty clean. There was some buildup on the throttle body around the butterfly valve, so I cleaned everything off thoroughly with q-tips and CRC Throttle Body Cleaner. I had unhooked my battery before unhooking everything for the throttle body, and I thought everything was fixed after hooking it all back up because it started great and idled perfectly afterwards. I took it for a drive and the voltage stayed right at 14 and didn't drop with the stereo, headlights, front heater, and rear heater all running at the same time when I came to a stop. I started it the next day before having to go somewhere and it had the same issue again. I figure the battery reset the problem until it was run and shut back off again. I unhooked the battery before having to leave about an hour later and it confirmed it. It started right up, and ran perfectly for my 35 mile drive without low idle or voltage drops. My last initial thought was needing an intake manifold gasket, but I'm still not getting any codes, and I would imagine that it would still run bad even with the battery reset like that. I've heard of people having their ECM firmware updated and fixing their problems, but don't want to throw money at the dealer. I can have my intake manifold gasket done, but don't want to throw money at that either if its not the problem. I did have a guy recommend getting a coolant temp sensor because he had a similar issue on a Ford, and I think I remember reading that a couple guys with 6.0's had the same type of problem with theirs and fixed it with the coolant temp sensor as well. I wanted to see if anybody on here had some good advice to give before I do anything else because the next things to throw at it won't be as cheap as the rest. Thanks, and sorry for the long post... Tom
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.