Jump to content

Havea Niceday

Member
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Havea Niceday

  • Rank
    New Member
  1. Recently purchased a 2007 NBS Silverado and am trying to work my way through some of the issues the previous owner let lapse. My biggest issue, I think, is maybe my ECM. My truck is the WT series V6 so it does not have the DIC buttons nor does it have electric locks/keyless-remote entry. I have a "service TPMS" light & message, Service Airbag light and message, Stabilitrak off light and message , Traction Control off light and message. Additionally my oil life remaining is - - - %. I follow the steps to reset the oil life remaining and it doesnt update. I used a Launch CRP129X to reset the oil life remaining and it does not reset. I follow the directions to put the ECM into TPMS learn mode and nothing happens. I use the Launch CRP129X to enter into the TPMS menu and it will not enter into learn mode. As far as the Stabilitrak and Traction control I have no clue since I do not have those buttons. Is there a way to check on the health status of my ECM to see if it is malfunctioning? Should I flash the ECM and hope for the best? Any suggestions at all to address this would be appreciated.
  2. Recently purchased a 2007 NBS Silverado and am trying to work my way through some of the issues the previous owner let lapse. My biggest issue, I think, is maybe my ECM. My truck is the WT series V6 so it does not have the DIC buttons nor does it have electric locks/keyless-remote entry. I have a "service TPMS" light & message, Service Airbag light and message, Stabilitrak off light and message , Traction Control off light and message. Additionally my oil life remaining is - - - %. I follow the steps to reset the oil life remaining and it doesnt update. I used a Launch CRP129X to reset the oil life remaining and it does not reset. I follow the directions to put the ECM into TPMS learn mode and nothing happens. I use the Launch CRP129X to enter into the TPMS menu and it will not enter into learn mode. As far as the Stabilitrak and Traction control I have no clue since I do not have those buttons. Is there a way to check on the health status of my ECM to see if it is malfunctioning? Should I flash the ECM and hope for the best? Any suggestions at all to address this would be appreciated.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.