Jump to content

Rob McGinnis

Member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Rob McGinnis

  • Rank
    New Member
  1. I have a 2003 2500HD with the 6.6L LB7 duramax. It is currently 19F here in ohio and after plugging in the block heater for about 4 hours i started my truck. Engine temp was below 160, everything was running fine, but the check engine light was on, trans temp gauge was pegged aover 300F, and a message was on my dash that said TRANS HOT IDLE ENGINE. I let it idle for a while and it never cooled down. Drove it to the end of my apartment complex parking lot and it wouldnt shift out of first gear. Went back, parked it as it was time for me to go to work. Rarely use block heater. First time i used it since beginning of 2019. The next day(today) I went out to run diagnostics and to see what codes where being thrown. Started truck to see if trans temp was still pegged and the gauge went all the way up to red, then down to 160, then up to just below the red with no TRANS HOT MESSAGE. Drove it to gas station and it shifted hard. While idling at gas station for 5 mins the trans temp climbed into red, TRANS HOT message came across the dash and i limped it home in first gear(maybe quarter mile). Codes - P0380, P0700, P1621. Cleared codes and check engine light was still on. Could the block heater have anything to do with this at all? Maybe a malfunction from a short or something? Fluid is full, doesnt smell bad or seem burnt but i noticed a funny smell when walking away(maybe just paranoid) Please......help.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.