Jump to content

Christiank22

Member
  • Content count

    308
  • Joined

  • Last visited

  • Days Won

    1

Christiank22 last won the day on August 2 2012

Christiank22 had the most liked content!

Community Reputation

18 Good

About Christiank22

  • Rank
    Enthusiast

Profile Information

  • Location
    South Western, North Dakota
  • Gender
    Male
  1. Cam Phaser Bolt/Valve

    Yes it is! Thank you! Sent from my SM-G925V using Tapatalk
  2. Hey I'm looking for some help in finding a part. I need a new cam phaser bolt/valve. I did a cam swap awhile back but was unaware that the original bolt I pulled could not be re-used so I'm trying to find a new one. I'm having a hard time finding it on the handful of OEM parts catalogs out there if anyone could give me a hand that would be great! I'll add a picture for reference as well. Thanks!
  3. Major Issues

    Justin told me its dangerously lean at heavy throttle, super confusing since it's so rich at idle... Maybe my injectors are bad?
  4. Major Issues

    I spoke with Justin, he told me there are major issues in the tune. I'm gonna wait for a word back from him before I drive it any major distances again. Would you recommend Justin as far as GM experience or try and find someone to do in person?
  5. Major Issues

    One for the thumb now! And back to the truck, I may have to let the professionals deal with this one, I'm just starting spring semester so I don't know how much time I'll have. I'll definitely keep everyone posted on here though. I just wanted to post a thread to see if people had some idea! Praying for the best!
  6. Major Issues

    Go Bison! I went to the game this year, it was insane!
  7. Major Issues

    I will man! I really hope it's a fixable issue that doesn't cost an arm and a leg.
  8. Major Issues

    I had a shop do it. They weren't too helpful last time I talked to them. Pretty disappointing, I've talked to a gmtech and have an appointment next week. And man but I love this truck :'(
  9. Major Issues

    Also, when accelerating at a constant ~3500rpm the check engine light flashes
  10. Major Issues

    Alright so I'm gonna start listing off some issues and I need some input here. I don't have any idea what's wrong First off of you can't see my signature cuz you're on tapatalk here's what I have done to my pickup: Supercharger, LT headers, 214/228 114lsa cam, 3000rpm circleD stall, exhaust, intake, tune, 4.10 gears, 305/55/20 tires and a 6in lift with a 1.25 body lift Issues: 1. Torque converter only locks up when I'm going 50mph. If I accelerate to interstate speed right away it doesn't lock. I have to stay between 50-55mph for about 2-3 miles for it to lock. Tune? Converter maybe? Whole transmission? 2. Throttle position sensor code. P0121. It's off and on. I replaced the sensor and it still comes every once in awhile 3. Running unbelievably rich. Every time I start it I feel like I'm huffing gas. Also my friend told me it blows black smoke during acceleration. 4. Sputters during acceleration. There's no smooth acceleration in this thing passed 3000rpm. Also 3/4 throttle has more power than full throttle. 5. Abnormally rough idle, even with my cam. 6. Hard starts on occasion. It's like a dragging start. Sometimes it'll start then die right away. 7. Extremely bad gas mileage. Before the supercharger install I got 12-14 highway (10-11 interstate) now I get 6.5-7.5 on the interstate. It's ridiculous. Notes: It threw the cam shaft position code after the cam install but Justin did a tune for me that removed the code. I'm wondering if there isn't a problem there. It ran like it was either too advanced or there was an issue in the position solenoid. Also most of these issues either occurred strictly after the supercharger install or became worse after it. So what do I do? Burn it and get insurance? (JOKES!!)
  11. Need Some Help

    Or delete it and I'll repost it. Sorry
  12. Need Some Help

    Shoot Im on tapatalk and didn't realize Im on the HD forum. Can a mod move this to the 6.2 area?
  13. Need Some Help

    Alright so I'm gonna start listing off some issues and I need some input here. I don't have any idea what's wrong First off of you can't see my signature cuz you're on tapatalk here's what I have done to my pickup: Supercharger, LT headers, 214/228 114lsa cam, 3000rpm circleD stall, exhaust, intake, tune, 4.10 gears, 305/55/20 tires and a 6in lift with a 1.25 body lift Issues: 1. Torque converter only locks up when I'm going 50mph. If I accelerate to interstate speed right away it doesn't lock. I have to stay between 50-55mph for about 2-3 miles for it to lock. Tune? Converter maybe? Whole transmission? 2. Throttle position sensor code. P0121. It's off and on. I replaced the sensor and it still comes every once in awhile 3. Running unbelievably rich. Every time I start it I feel like I'm huffing gas. Also my friend told me it blows black smoke during acceleration. 4. Sputters during acceleration. There's no smooth acceleration in this thing passed 3000rpm. Also 3/4 throttle has more power than full throttle. 5. Abnormally rough idle, even with my cam. 6. Hard starts on occasion. It's like a dragging start. Sometimes it'll start then die right away. 7. Extremely bad gas mileage. Before the supercharger install I got 12-14 highway (10-11 interstate) now I get 6.5-7.5 on the interstate. It's ridiculous. Notes: It threw the cam shaft position code after the cam install but Justin did a tune for me that removed the code. I'm wondering if there isn't a problem there. It ran like it was either too advanced or there was an issue in the position solenoid. Also most of these issues either occurred strictly after the supercharger install or became worse after it. So what do I do? Burn it and get insurance? (JOKES!!)
  14. Never Ran Worse

    Yeah I had a shop install it. Haven't taken it to them yet, I'm gonna let Justin look at the tune first. And I really hope it's not my transmission...
  15. Never Ran Worse

    Whipple 2.3
×

Important Information

By using this site, you agree to our Terms of Use.