Jump to content

coyt80

Member
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About coyt80

  • Rank
    Enthusiast

Profile Information

  • Name
    Array
  • Location
    Array
  • Gender
    Array
  • Drives
    Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Mine didn't lose power but it feels like the brakes are stuck and the truck feels heavy. The brake pad life percentage also went down to 15% at only 6500 miles. Even after them having reset it to 100% when I took it in at 3200 miles and 65%. WTF. They drove it and of course , they can't feel anything. I drive this everyday. You don't feel if you drive it around the dealer. Only until you've driven it on a daily basis but it feels like I'm permanently towing something. But anyway, I first took it in at 1100 miles just in case I have to file lemon. https://www.gm-trucks.com/forums/topic/223508-brake-pads/?tab=comments#comment-2251844
  2. Bad news. Even after they reset my brake pad life to 100% at 3200 miles. Guess what. It went down to 15% at only 6500 miles. But NOTHING is wrong with it according to the service department. So they swapped out the pad life sensor and reset it again to 100% to shut me up and well, we'll see what happens.
  3. OH GOD YES. I am experiencing a slight resistance in my drive. It feels like i was towing something. Almost like the calipers were stuck or squeezing most of the time. So I'm playing around with the buttons and I check my brake life status and at only 3200 miles my brake life is reading at 66%. I took it in to the dealer with this concern and it even dropped to 65% as I drove in the service bay. They tested it and said they didn't feel any abnormality and that maybe the sensors were giving a false reading. Oh and I also brought up that horrible hard shifting everyone else is experiencing (5.3 8spd). And an engine knocking when idling on a cold start. Anyway going back to the brakes, they reset the percentage to 100% said my pads were fine. Ok. Now 1200 miles later I'm down to 69% and that's AFTER they reset it to 100% at the 3200. If they hadn't reset it I'm assuming I'd be at a what? 34% reading?
  4. YES That is so annoying. I get it in both directions but harder when downshifting from 2-1.
  5. Hey guys, anyone else experiencing a slight resistance in their drive. It feels like i was towing something. Almost like the calipers were stuck or squeezing most of the time. So I'm playing around with the buttons and I check my brake life status and at only 3200 miles my brake life is reading at 66%. I took it in to the dealer with this concern and it even dropped to 65% as I drove in the service bay. They tested it and said they didn't feel any abnormality and that maybe the sensors were giving a false reading. Oh and I also brought up that horrible hard shifting everyone else is experiencing (5.3 8spd). And an engine knocking when idling on a cold start. Anyway going back to the brakes, they reset the percentage to 100% said my pads were fine. Ok. Now 1200 miles later I'm down to 69% and that's AFTER they reset it to 100% at the 3200. If they hadn't reset it I'm assuming I'd be at a what? 34% reading?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.