Jump to content

Bonjrooks

Member
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Bonjrooks

  • Rank
    Enthusiast

Profile Information

  • Name
    Array
  • Location
    Array

Recent Profile Visitors

1,677 profile views
  1. Yeah I haven't had any problems yet! It may be hard tell tell but here's pics. FYI I didn't stack the blocks in the rear like they want you to . I took the stock ones out and threw the superlift ones in cause they were a little taller than stock and I didn't want rake Before After Sent from my iPhone using Tapatalk
  2. 2" Doesn't matter what control arms I went with superlift it's not bad for the $ Sent from my iPhone using Tapatalk
  3. Brand new 2" strut spacer kit $50 obo need gone I bought for my 2016 1500 but ended up going with 3.5" lift http://www.superlift.com/2-inch-gm-leveling-kit-2007-2015-1500-pickup-avalanche-suburban-tahoe-2wd-and-4wd Sent from my iPhone using Tapatalk
  4. Definitely going to do mine ! Do you think the plasti dip will hold up good to a pressure washer? Sent from my iPhone using Tapatalk
  5. The bottom of the shocks mounting point are angled a little, therefore the shock can only go one way . If you look at the pic you can see the spacer that comes in the kit has the triangular bolt pattern 180 degrees rotated . Hope this helps Sent from my iPhone using Tapatalk
  6. I installed this kit last week in my 2016 ..... no problems yet! No disassembly of strut , I just bolted the spacer on , put 2 spring compressors on the spring and cranked them down a little ,wedged the bottom of the strut in something and grabbed ahold of strut spacer and turned 180 degrees. As for the rear they want you to put the supplied blocks on top of factory blocks .... I didn't because the rake is what I wanted to eliminate . So I just switched out my factory blocks with the supplied blocks . http://uploads01.pangeadb.com/superlift/products/website/installation-instructions/14876-3600-6-5-15.pdfStock 3.5" lift I know crappy pic 3.5" lift + removed lower valance Oh also put 33's cooper discoverer atp 275-60r20 Sent from my iPhone using Tapatalk
  7. Update needed....!! Sent from my iPhone using Tapatalk
  8. Had this problem with by buddy's install , got to switch your connector around ( connector in pic) I installed everything and overlooked that connector thinking it can only plug in one way ..... once I backtracked I realized the red wire wasn't going to red and black wasn't to black . So check it out !!! Lmk Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.