Jump to content

Tazzerblue

Member
  • Content count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Tazzerblue

  • Rank
    New Member

Profile Information

  • Name
    Kevin Bock
  • Location
    SW MN.
  • Drives
    RAM
  1. My son's GMC 1500 with the 5.3 is on its last leg were told. its been having the low oil pressure issue's , did engine flush with lasted for a 4 months, Now he came home and started with and it said 0 oil pressure. took it back to same shop and they replace the sensor and screen, they told him its on its way out, has low OP. This truck has 123k on it. Any way he plans on having it rebuilt at the same machine shop I had my boat engine rebuilt. This guy is a race car engine builder, has been for years, and very methodical in his work. Plan is to replace AFM parts with Non-AFM parts, performance cam, lifters. and what ever else it needs, if this guy says its needed, it gets done.. Major OH. Any recommendations for cams and tuning? I've read it will need the ECM software re tuned for non AFM parts and also for the performance cam. Tunner suggestions? I would like to send ECM out while engine is being rebuilt. Any other tips while engine is out? Thanks.
  2. Shop has reset it or what ever they did to get it to run. Didn't solve the problem.. Starts and runs shitty for 30 minutes or so. So Now What?
  3. My son't 2012 flex fuel GMC it having issue's with reading the correct fuel. He has only run e85 once in 120k. It now runs like shit again and I'm sure its this sensor. Truck shop is closed for Christmas. They had checked and cleaned it? the last time it was in. Does anyone have a photo and part #
×

Important Information

By using this site, you agree to our Terms of Use.