Jump to content

JC-sr5

Member
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About JC-sr5

  • Rank
    New Member
  1. The alternator is a rebuilt Ac Delco Unit, I've never had any issues with them in the past Changed the starter today, was not as much of a hassle as I had expected it to be, and now it starts perfectly and quickly every time. I also ordered a new starter relay since is was only about $6 and isn't difficult to change, might as well the one on it is original. Hopefully this has solved the problem, time will tell it if was some type of voltage issue and it goes back to crap starting. My 4x4 switches are original and still work, but do have the piston slap, have always used conventional, and the fuel gauge goes wacky when you get below 1/3 of a tank, not worth dropping the tank I don't feel at this point, unless gauge goes completely, it needs to make it to 300k I think it can do it
  2. Hello Recently the truck has been starting poorly. It has never failed to start, but chugs very slowly almost like the battery is dead. I thought maybe the one in it was going since it was several years old, bought a new one and put it in, made sure battery going in was fully charged, but still having the same issue. It doesn't run poorly, volt gauge reads normal, but just starts like battery is low. Sometimes it chugs more slowly than other times. It does have 253k on the original starter, alternator is recent and is an AC-Delco part, so I do not think it could be causing this. I have not crawled under it to take a look at the starter yet. Problem has existed for about 2 weeks now. Any help is appreciated. Thank you.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.