Jump to content

tms1989

Member
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tms1989

  • Rank
    New Member

Profile Information

  • Location
    Massachusetts
  • Gender
    Male
  • Drives
    2015 GMC Sierra SLE
  1. Hey all, Forgive my lack of technical terms when I describe this but I have been having an issue with steering lately. Whenever I turn backwards to the right at full lock like I keep getting a rubbing noise and a clicking. It feels like the truck is fighting itself to go backwards and it feels like the tire is trying to roll under itself . After going out and checking by the right tire and as you see in the picture below I have rubbing in these two parts. I was wondering if it was possible that the center link had been put in backwards causing this part to be misaligned? The last owner of the truck redid the whole front end so nothing is original. Any tips are appreciated!
  2. Hello! Yesterday I acquired a 2003 Silverado with 140,000 miles on the engine. Today I was going over the truck and I washed out the bottom very thoroughly. Got a little bit of rust dust and some chips of undercoating off. I really went to town cleaning the underside. After this I took the truck for a little drive and started to get a flashing check engine light. The truck seemed to drive fine at speed but when I pulled off onto a side street it felt like it was misfiring a little bit, rough idle. I turned off the truck and turned it back on and the flashing CEL returned after a few seconds. I started to head back home and after about 30 seconds the light went away. I have driven it a few times since then and nothing has come back. I had nothing before washing out the bottom. What could be the cause of this? Thanks for all replies!
×

Important Information

By using this site, you agree to our Terms of Use.