Jump to content

crabcake

Member
  • Content count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About crabcake

  • Rank
    Enthusiast
  • Birthday 06/15/1954
  1. Replaced the purge valve today. We’ll see. Sent from my iPhone using Tapatalk
  2. I know this is the 4.3 engine but I have the 6.2 liter! Still in the same location ? Sent from my iPhone using Tapatalk
  3. Could you show me a pic of where this purge valve is located? Engine light still comes on. Sent from my iPhone using Tapatalk
  4. Thanks for the information. Sent from my iPhone using Tapatalk
  5. Update on the engine light and tighten gas cap indicator. I recently bought a brand new gas cap and that didn’t help. I did reset it by disconnecting the battery. Been 2 weeks now and no light indicator on so far! [emoji16] Sent from my iPhone using Tapatalk
  6. I just purchased an iPhone 8 and also having the same issue! Sent from my iPhone using Tapatalk
  7. I have a 2013 Sierra 4x4 crew cab with 39,000 that I bought new. I noticed at speeds around 70 and up especially during ecceleration the steering seems loose! Sent from my iPhone using Tapatalk
  8. Would like to know if anyone has had this problem before. I have a 2013 GMC 1500 Extended Cab 4x4. 38,400 miles. Bought it brand new. No issues. Now a message began to appear to tighten the gas cap. Checked that and seems okay. Now the engine light stays on. The message quit appearing. Any ideas? Sent from my iPhone using Tapatalk
  9. I have a 2013 GMC 1/2 ton 4x4 SLT crew cab loaded with towing package. I had to order it with the 6.2 L engine. Got it from Beck and Masten out of Houston. I LOVE this truck. It was born to pull. I have the 3.72 rear end. I replaced the stock 17 inch wheels with 20's. Sent from my iPhone using Tapatalk
  10. I have a 2013 GMC SLT 4X4 Crew cab. Does it have a cabin filter? Sent from my iPhone using Tapatalk
×

Important Information

By using this site, you agree to our Terms of Use.