Jump to content

NTD

Member
  • Content Count

    30
  • Joined

  • Last visited

Community Reputation

5 Neutral

About NTD

  • Rank
    Enthusiast

Profile Information

  • Name
    Array
  • Location
    Array
  • Drives
    Array
  1. Yup have the issue everyone once in a while...not sure what the fix is. Had an F150 that did the same thing and my wife's escape also does the same thing...never been able to figure out the issue.
  2. All you assholes do is blind the people coming at you with these ridiculous light bars.
  3. I checked also and confirmed seats only. There is no option for the steering wheel. This is a '16 that was built in Feb.
  4. Hmmm...I'll have to check mine. Don't remember seeing the option to turn the wheel on...only the seats.
  5. I have the muffler that that comes with that system on my exhaust. Just had a shop weld it in for $200. Sound really nice.
  6. I had this problem in my '10 F150. Except it wasn't the light it was the relay near the steering column. There is an unlock switch, at least on that truck, that will allow you to drive until you get it fixed. $30 and 10 minutes and I was good to go
  7. I test drove a vibrator and it was awful. Started right around 60 and got worse the fast I got. Agreed on a deal and told them I wasn't taking delivery until the vibration was gone. They figured it out. New tires and alignment I believe.
  8. 51k is too much for an LT. buddy of mine just paid 55 for a Denali Duramax Sent from my iPhone using Tapatalk
  9. I don't have it but there is a thread in this section somewhere about it.
  10. I would just go aftermarket. It's amazing what a good stereo shop can do these days
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.